aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorClément Chigot <chigot@adacore.com>2023-01-03 14:24:43 +0100
committerAndreas K. Hüttel <dilfridge@gentoo.org>2023-03-07 00:22:50 +0100
commitef0431d27fc8d2ac0d02736bd7dd0349a62a9602 (patch)
treefb1fe029ae856dd657a6994f2e3e5c00d724b589
parentRegen config files (diff)
downloadbinutils-gdb-ef0431d27fc8d2ac0d02736bd7dd0349a62a9602.tar.gz
binutils-gdb-ef0431d27fc8d2ac0d02736bd7dd0349a62a9602.tar.bz2
binutils-gdb-ef0431d27fc8d2ac0d02736bd7dd0349a62a9602.zip
configure: remove dependencies on gmp and mpfr when gdb is disabled
Since 991180627851801f1999d1ebbc0e569a17e47c74, the configure checks about GMP and MPFR for gdb builds have been moved to the toplevel configure. However, it doesn't take into account the --disable-gdb option. Meaning that a build without gdb will require these libraries even if not needed. ChangeLog: * configure.ac: Skip GMP and MPFR when --disable-gdb is provided. * configure: Regenerate. (cherry picked from commit 5fb0e308577143ceb313fde5538dc9ecb038f29f) (cherry picked from commit 17294931e3e361bee6810b1a39493e214b38c5e5)
-rwxr-xr-xconfigure4
-rw-r--r--configure.ac4
2 files changed, 6 insertions, 2 deletions
diff --git a/configure b/configure
index 417fc5a970c..9cb953a197e 100755
--- a/configure
+++ b/configure
@@ -8032,7 +8032,9 @@ if test -d ${srcdir}/gcc ; then
require_mpc=yes
fi
if test -d ${srcdir}/gdb ; then
- require_gmp=yes
+ if test "x$enable_gdb" != xno; then
+ require_gmp=yes
+ fi
fi
gmplibs="-lmpfr -lgmp"
diff --git a/configure.ac b/configure.ac
index 3a1eb0357e5..e95a9ed116e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1585,7 +1585,9 @@ if test -d ${srcdir}/gcc ; then
require_mpc=yes
fi
if test -d ${srcdir}/gdb ; then
- require_gmp=yes
+ if test "x$enable_gdb" != xno; then
+ require_gmp=yes
+ fi
fi
gmplibs="-lmpfr -lgmp"