summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-libs/gtk+/gtk+-2.9999.ebuild')
-rw-r--r--x11-libs/gtk+/gtk+-2.9999.ebuild22
1 files changed, 8 insertions, 14 deletions
diff --git a/x11-libs/gtk+/gtk+-2.9999.ebuild b/x11-libs/gtk+/gtk+-2.9999.ebuild
index d9fac8c..17025fc 100644
--- a/x11-libs/gtk+/gtk+-2.9999.ebuild
+++ b/x11-libs/gtk+/gtk+-2.9999.ebuild
@@ -1,6 +1,7 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $
+EAPI=2
inherit gnome2-live flag-o-matic virtualx
@@ -15,7 +16,6 @@ IUSE="X cups debug doc jpeg jpeg2k tiff vim-syntax xinerama jasper"
RDEPEND=">=dev-libs/glib-2.17.6
>=x11-libs/pango-1.20
>=dev-libs/atk-1.13
- >=x11-libs/cairo-1.6
media-libs/fontconfig
x11-misc/shared-mime-info
>=media-libs/libpng-1.2.1
@@ -30,9 +30,13 @@ RDEPEND=">=dev-libs/glib-2.17.6
x11-libs/libXfixes
x11-libs/libXcomposite
x11-libs/libXdamage
+ >=x11-libs/cairo-1.6[X]
xinerama? ( x11-libs/libXinerama )
)
- !X? ( dev-libs/DirectFB )
+ !X? (
+ dev-libs/DirectFB
+ >=x11-libs/cairo-1.6[directfb]
+ )
cups? ( net-print/cups )
jpeg? ( >=media-libs/jpeg-6b-r2 )
jpeg2k? ( media-libs/jasper )
@@ -56,18 +60,6 @@ PDEPEND="vim-syntax? ( app-vim/gtk-syntax )"
PATCHES="${PN}-2.12.0-flash-workaround.patch"
pkg_setup() {
- if use X ; then
- if ! built_with_use x11-libs/cairo X; then
- eerror "Please re-emerge x11-libs/cairo with the X USE flag set"
- die "cairo needs the X flag set"
- fi
- else
- if ! built_with_use x11-libs/cairo directfb ; then
- eerror "Please re-emerge x11-libs/cairo with the directfb USE flag set"
- die "cairo needs the directfb flag set"
- fi
- fi
-
if has_multilib_profile ; then
# use an arch-specific config directory so that 32bit and 64bit versions
# dont clash on multilib systems
@@ -165,4 +157,6 @@ pkg_postinst() {
fi
elog "Please install app-text/evince for print preview functionality"
+ echo
+ gnome2-live_pkg_postinst
}