aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEric Blake <eblake@redhat.com>2012-08-20 07:46:38 -0600
committerEric Blake <eblake@redhat.com>2012-08-20 23:39:54 -0600
commit99ae57f8418a45991a8c41b9f0dcb52218fc19a4 (patch)
treef4c1d621c159f283996ba8a068500103a6ea9102 /tools/virsh-domain-monitor.h
parentUpdate the remote API (diff)
downloadlibvirt-99ae57f8418a45991a8c41b9f0dcb52218fc19a4.tar.gz
libvirt-99ae57f8418a45991a8c41b9f0dcb52218fc19a4.tar.bz2
libvirt-99ae57f8418a45991a8c41b9f0dcb52218fc19a4.zip
virsh: split out virsh-domain-monitor.c
Another file worth compiling on its own instead of by .c inclusion. * tools/virsh-domain-monitor.h: New file. * tools/Makefile.am (virsh_SOURCES): Build it. * tools/virsh.h (vshGetDomainDescription): Move to correct header. * tools/virsh-domain-monitor.c: Use new header. * tools/virsh.c: Likewise. * tools/virsh-domain.c: Likewise.
Diffstat (limited to 'tools/virsh-domain-monitor.h')
-rw-r--r--tools/virsh-domain-monitor.h37
1 files changed, 37 insertions, 0 deletions
diff --git a/tools/virsh-domain-monitor.h b/tools/virsh-domain-monitor.h
new file mode 100644
index 000000000..e322006c0
--- /dev/null
+++ b/tools/virsh-domain-monitor.h
@@ -0,0 +1,37 @@
+/*
+ * virsh-domain-monitor.h: Commands to monitor domain status
+ *
+ * Copyright (C) 2005, 2007-2012 Red Hat, Inc.
+ *
+ * This library is free software; you can redistribute it and/or
+ * modify it under the terms of the GNU Lesser General Public
+ * License as published by the Free Software Foundation; either
+ * version 2.1 of the License, or (at your option) any later version.
+ *
+ * This library is distributed in the hope that it will be useful,
+ * but WITHOUT ANY WARRANTY; without even the implied warranty of
+ * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+ * Lesser General Public License for more details.
+ *
+ * You should have received a copy of the GNU Lesser General Public
+ * License along with this library; If not, see
+ * <http://www.gnu.org/licenses/>.
+ *
+ * Daniel Veillard <veillard@redhat.com>
+ * Karel Zak <kzak@redhat.com>
+ * Daniel P. Berrange <berrange@redhat.com>
+ *
+ */
+
+#ifndef VIRSH_DOMAIN_MONITOR_H
+# define VIRSH_DOMAIN_MONITOR_H
+
+# include "virsh.h"
+
+char *vshGetDomainDescription(vshControl *ctl, virDomainPtr dom,
+ bool title, unsigned int flags)
+ ATTRIBUTE_NONNULL(1) ATTRIBUTE_NONNULL(2) ATTRIBUTE_RETURN_CHECK;
+
+extern const vshCmdDef domMonitoringCmds[];
+
+#endif /* VIRSH_DOMAIN_MONITOR_H */