summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/stomp-py')
-rw-r--r--dev-python/stomp-py/Manifest1
-rw-r--r--dev-python/stomp-py/metadata.xml2
-rw-r--r--dev-python/stomp-py/stomp-py-8.1.2.ebuild30
3 files changed, 32 insertions, 1 deletions
diff --git a/dev-python/stomp-py/Manifest b/dev-python/stomp-py/Manifest
index 7534972635f4..a870402f5087 100644
--- a/dev-python/stomp-py/Manifest
+++ b/dev-python/stomp-py/Manifest
@@ -1 +1,2 @@
DIST stomp.py-8.1.0.tar.gz 39808 BLAKE2B c6efb19fbee81142f251c4bf4114b445878b81fa457260a306cb82ef5e9c57f0b75e3dc8cd6035676e688f1d33081cdf936ac6ccc0628819722849d60f4d8602 SHA512 7385842a23fbe6022c386489641948932e805430ce71c09079d9484fe17d02241ee705d92a1bcdf873eebcbacf68f44bbf884ea103c8963944b84758073fdac7
+DIST stomp_py-8.1.2.tar.gz 39163 BLAKE2B 49d096369b427033cf1210638875cdd1501711a05183d7d186f8f926033e898c7323a8d96f319311999edc86a49515a92ba4c0ed0982712789f7ba78f4175e5e SHA512 2cbfaacdc5762b8db5c28721e01511c32a8991a866d6ced520a27cb82deacc4716cbaf5f298a8daea7f91c9038859d4c39069ad5b46ba6d0efe60e4c19ab09ae
diff --git a/dev-python/stomp-py/metadata.xml b/dev-python/stomp-py/metadata.xml
index 256ce6712373..d1b716fd203c 100644
--- a/dev-python/stomp-py/metadata.xml
+++ b/dev-python/stomp-py/metadata.xml
@@ -7,7 +7,7 @@
</maintainer>
<stabilize-allarches/>
<upstream>
- <remote-id type="pypi">stomp.py</remote-id>
+ <remote-id type="pypi">stomp-py</remote-id>
<remote-id type="github">jasonrbriggs/stomp.py</remote-id>
</upstream>
</pkgmetadata>
diff --git a/dev-python/stomp-py/stomp-py-8.1.2.ebuild b/dev-python/stomp-py/stomp-py-8.1.2.ebuild
new file mode 100644
index 000000000000..3a88a66c6b28
--- /dev/null
+++ b/dev-python/stomp-py/stomp-py-8.1.2.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Python client library for the STOMP messaging protocol"
+HOMEPAGE="https://pypi.org/project/stomp-py/ https://github.com/jasonrbriggs/stomp.py/"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ <dev-python/docopt-0.7.0[${PYTHON_USEDEP}]
+ dev-python/websocket-client[${PYTHON_USEDEP}]
+"
+
+# stomp.py test suite requires quite a few appropriately configured
+# messaging servers (as of 8.1.2: RabbitMQ, ActiveMQ, ActiveMQ Artemis,
+# stompserver). Upstream relies on Docker to provide those servers, however
+# doing the same in src_test would require both granting the portage user
+# extra permissions and packaging the base image (trying to download it
+# on the fly would violate the network sandbox).
+# Side note: PyPI tarballs do not include tests.
+RESTRICT="test"