summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2023-10-18 22:10:16 +0200
committerUlrich Müller <ulm@gentoo.org>2023-10-18 22:10:16 +0200
commit5bc222b026652ddc7aaf5427ef960a28468bbfd3 (patch)
tree00b0cbb75e1be42010877082ccb7bbe68fd78124
parenttamago removed 2012-12-25 bug 338535 (diff)
downloademacs-5bc222b026652ddc7aaf5427ef960a28468bbfd3.tar.gz
emacs-5bc222b026652ddc7aaf5427ef960a28468bbfd3.tar.bz2
emacs-5bc222b026652ddc7aaf5427ef960a28468bbfd3.zip
ghc-mod removed 2020-09-09
Signed-off-by: Ulrich Müller <ulm@gentoo.org>
-rw-r--r--app-emacs/ghc-mod/Manifest3
-rw-r--r--app-emacs/ghc-mod/files/50ghc-mod-gentoo.el3
-rw-r--r--app-emacs/ghc-mod/files/ghc-mod-5.6.0.0-gentoo.patch5
-rw-r--r--app-emacs/ghc-mod/ghc-mod-5.4.0.0.ebuild95
-rw-r--r--app-emacs/ghc-mod/ghc-mod-5.5.0.0-r1.ebuild97
-rw-r--r--app-emacs/ghc-mod/ghc-mod-5.7.0.0.ebuild92
-rw-r--r--app-emacs/ghc-mod/metadata.xml20
7 files changed, 315 insertions, 0 deletions
diff --git a/app-emacs/ghc-mod/Manifest b/app-emacs/ghc-mod/Manifest
new file mode 100644
index 0000000..a411df4
--- /dev/null
+++ b/app-emacs/ghc-mod/Manifest
@@ -0,0 +1,3 @@
+DIST ghc-mod-5.4.0.0.tar.gz 132546 BLAKE2B 6670df6b271527ee2a69c74b0522b94e78e799b62d260ca744a382312c815e904d516345c6258be0d9aa82f91866126b95cc4682bc1925616078ffef1a559905 SHA512 fabcc5ce2fb9e8790043faae2d42b3714fab96da1409d7f1c4736f332c6b74c76724dce253456fd787526d125cfaa1fe48c4725a0da16aabb35d5edf560f2415
+DIST ghc-mod-5.5.0.0.tar.gz 150774 BLAKE2B 87d2be174200f05da0f38a2947c4404c0b25ce77a03d3b456f8cde769e978bbe6fad6e2c04d1af61e05d61fb941c139c297baaeb4835c02390516a88bebbf539 SHA512 006f292394fc24766a2ae2c778635697a63e1b48ef96052af66dc35d1ef30eb600760cd2a517011a7a2b027a0c725ceb3b5e37cfe157741ba97f19068f1264e8
+DIST ghc-mod-5.7.0.0.tar.gz 146797 BLAKE2B b5d684dbb505001bfc061473cd62d00491bfe8ca5710cb69c72cb2544838a9a3b7d88d414be8123f9edf82cf96773f49439912a98efec843c167334d31caeaf8 SHA512 843cd0546c0a0cdf30dd9cde5e9148dabf391648bae6d7f2852c83a4cd5b8329f30d0cc578ba6afda02e8885b2ed63c7def4885e0dbaac199d311e476a0cc6e3
diff --git a/app-emacs/ghc-mod/files/50ghc-mod-gentoo.el b/app-emacs/ghc-mod/files/50ghc-mod-gentoo.el
new file mode 100644
index 0000000..402c84d
--- /dev/null
+++ b/app-emacs/ghc-mod/files/50ghc-mod-gentoo.el
@@ -0,0 +1,3 @@
+;;; ghc-mod site-lisp configuration
+
+(add-to-list 'load-path "@SITELISP@")
diff --git a/app-emacs/ghc-mod/files/ghc-mod-5.6.0.0-gentoo.patch b/app-emacs/ghc-mod/files/ghc-mod-5.6.0.0-gentoo.patch
new file mode 100644
index 0000000..f7e6e1c
--- /dev/null
+++ b/app-emacs/ghc-mod/files/ghc-mod-5.6.0.0-gentoo.patch
@@ -0,0 +1,5 @@
+--- a/ghc-mod.cabal
++++ b/ghc-mod.cabal
+@@ -29,2 +29,0 @@
+-Data-Files: elisp/Makefile
+- elisp/*.el
diff --git a/app-emacs/ghc-mod/ghc-mod-5.4.0.0.ebuild b/app-emacs/ghc-mod/ghc-mod-5.4.0.0.ebuild
new file mode 100644
index 0000000..25bf290
--- /dev/null
+++ b/app-emacs/ghc-mod/ghc-mod-5.4.0.0.ebuild
@@ -0,0 +1,95 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.6
+
+CABAL_FEATURES="bin lib profile haddock hoogle hscolour test-suite"
+inherit elisp-common haskell-cabal
+
+DESCRIPTION="Happy Haskell Programming"
+HOMEPAGE="http://www.mew.org/~kazu/proj/ghc-mod/"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
+
+LICENSE="AGPL-3"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="emacs"
+
+RESTRICT=test # doctests break on modules collisions: temporary / temporary-rc
+
+RDEPEND="dev-haskell/async:=[profile?]
+ >=dev-haskell/cabal-helper-0.6.0.0:=[profile?] <dev-haskell/cabal-helper-0.7:=[profile?]
+ >=dev-haskell/cereal-0.4:=[profile?]
+ dev-haskell/convertible:=[profile?]
+ >=dev-haskell/djinn-ghc-0.0.2.2:=[profile?]
+ >=dev-haskell/extra-1.4:2=[profile?] <dev-haskell/extra-1.5:2=[profile?]
+ >=dev-haskell/fclabels-2.0:=[profile?] <dev-haskell/fclabels-2.1:=[profile?]
+ dev-haskell/ghc-paths:=[profile?]
+ dev-haskell/ghc-syb-utils:=[profile?]
+ dev-haskell/haskell-src-exts:=[profile?]
+ >=dev-haskell/hlint-1.8.61:=[profile?]
+ >=dev-haskell/monad-control-1:=[profile?]
+ >=dev-haskell/monad-journal-0.4:=[profile?]
+ >=dev-haskell/mtl-2.0:=[profile?]
+ dev-haskell/old-time:=[profile?]
+ >=dev-haskell/pipes-4.1:=[profile?] <dev-haskell/pipes-4.2:=[profile?]
+ dev-haskell/random:=[profile?]
+ dev-haskell/split:=[profile?]
+ dev-haskell/syb:=[profile?]
+ dev-haskell/temporary:=[profile?]
+ dev-haskell/text:=[profile?]
+ dev-haskell/transformers:=[profile?]
+ dev-haskell/transformers-base:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+ emacs? ( >=app-editors/emacs-23.1:* )
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.14
+ test? ( >=dev-haskell/doctest-0.9.3
+ dev-haskell/executable-path
+ >=dev-haskell/hspec-2.0.0 )
+"
+SITEFILE=50${PN}-gentoo.el
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-5.6.0.0-gentoo.patch
+}
+
+src_compile() {
+ haskell-cabal_src_compile
+ if use emacs ; then
+ pushd elisp
+ elisp-compile *.el
+ popd
+ fi
+}
+
+src_install() {
+ haskell-cabal_src_install
+ if use emacs ; then
+ pushd "${S}"
+ elisp-install ghc-mod elisp/*.{el,elc}
+ elisp-site-file-install "${FILESDIR}"/${SITEFILE}
+ popd
+ fi
+}
+
+pkg_postinst() {
+ if use emacs ; then
+ elisp-site-regen
+ elog "To configure ghc-mod either add this line to ~/.emacs:"
+ elog "(autoload 'ghc-init \"ghc\" nil t)"
+ elog "and either this line:"
+ elog "(add-hook 'haskell-mode-hook (lambda () (ghc-init)))"
+ elog "or if you wish to use flymake:"
+ elog "(add-hook 'haskell-mode-hook (lambda () (ghc-init) (flymake-mode)))"
+ fi
+}
+
+pkg_postrm() {
+ if use emacs ; then
+ elisp-site-regen
+ fi
+}
diff --git a/app-emacs/ghc-mod/ghc-mod-5.5.0.0-r1.ebuild b/app-emacs/ghc-mod/ghc-mod-5.5.0.0-r1.ebuild
new file mode 100644
index 0000000..b650183
--- /dev/null
+++ b/app-emacs/ghc-mod/ghc-mod-5.5.0.0-r1.ebuild
@@ -0,0 +1,97 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.6
+
+CABAL_FEATURES="bin lib profile haddock hoogle hscolour test-suite"
+inherit elisp-common haskell-cabal
+
+DESCRIPTION="Happy Haskell Programming"
+HOMEPAGE="http://www.mew.org/~kazu/proj/ghc-mod/"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
+
+LICENSE="AGPL-3"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="emacs"
+
+RESTRICT=test # doctests break on modules collisions: temporary / temporary-rc
+
+RDEPEND=">=dev-haskell/binary-0.5.1.0:=[profile?] <dev-haskell/binary-0.8:=[profile?]
+ >=dev-haskell/cabal-helper-0.6.3.0:=[profile?] <dev-haskell/cabal-helper-0.7:=[profile?]
+ dev-haskell/convertible:=[profile?]
+ >=dev-haskell/djinn-ghc-0.0.2.2:=[profile?] <dev-haskell/djinn-ghc-0.1:=[profile?]
+ >=dev-haskell/extra-1.4:2=[profile?] <dev-haskell/extra-1.5:2=[profile?]
+ >=dev-haskell/fclabels-2.0:=[profile?] <dev-haskell/fclabels-2.1:=[profile?]
+ <dev-haskell/ghc-paths-0.2:=[profile?]
+ <dev-haskell/ghc-syb-utils-0.3:=[profile?]
+ <dev-haskell/haskell-src-exts-1.18:=[profile?]
+ >=dev-haskell/hlint-1.8.61:=[profile?] <dev-haskell/hlint-1.10:=[profile?]
+ >=dev-haskell/monad-control-1.0:=[profile?] <dev-haskell/monad-control-1.1:=[profile?]
+ >=dev-haskell/monad-journal-0.4:=[profile?] <dev-haskell/monad-journal-0.8:=[profile?]
+ >=dev-haskell/mtl-2.0:=[profile?] <dev-haskell/mtl-2.3:=[profile?]
+ <dev-haskell/old-time-1.2:=[profile?]
+ >=dev-haskell/optparse-applicative-0.11.0:=[profile?] <dev-haskell/optparse-applicative-0.13.0:=[profile?]
+ >=dev-haskell/pipes-4.1:=[profile?] <dev-haskell/pipes-4.2:=[profile?]
+ >=dev-haskell/safe-0.3.9:=[profile?] <dev-haskell/safe-0.4:=[profile?]
+ <dev-haskell/split-0.3:=[profile?]
+ <dev-haskell/syb-0.7:=[profile?]
+ <dev-haskell/temporary-1.3:=[profile?]
+ <dev-haskell/text-1.3:=[profile?]
+ <dev-haskell/transformers-0.5:=[profile?]
+ <dev-haskell/transformers-base-0.5:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+ emacs? ( >=app-editors/emacs-23.1:* )
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.14
+ test? ( >=dev-haskell/doctest-0.9.3
+ dev-haskell/executable-path
+ >=dev-haskell/hspec-2.0.0 )
+"
+SITEFILE=50${PN}-gentoo.el
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-5.6.0.0-gentoo.patch
+}
+
+src_compile() {
+ haskell-cabal_src_compile
+ if use emacs ; then
+ pushd elisp
+ elisp-compile *.el
+ popd
+ fi
+}
+
+src_install() {
+ haskell-cabal_src_install
+ if use emacs ; then
+ pushd "${S}"
+ elisp-install ghc-mod elisp/*.{el,elc}
+ elisp-site-file-install "${FILESDIR}"/${SITEFILE}
+ popd
+ fi
+}
+
+pkg_postinst() {
+ haskell-cabal_pkg_postinst
+ if use emacs ; then
+ elisp-site-regen
+ elog "To configure ghc-mod either add this line to ~/.emacs:"
+ elog "(autoload 'ghc-init \"ghc\" nil t)"
+ elog "and either this line:"
+ elog "(add-hook 'haskell-mode-hook (lambda () (ghc-init)))"
+ elog "or if you wish to use flymake:"
+ elog "(add-hook 'haskell-mode-hook (lambda () (ghc-init) (flymake-mode)))"
+ fi
+}
+
+pkg_postrm() {
+ haskell-cabal_pkg_postrm
+ if use emacs ; then
+ elisp-site-regen
+ fi
+}
diff --git a/app-emacs/ghc-mod/ghc-mod-5.7.0.0.ebuild b/app-emacs/ghc-mod/ghc-mod-5.7.0.0.ebuild
new file mode 100644
index 0000000..995c32f
--- /dev/null
+++ b/app-emacs/ghc-mod/ghc-mod-5.7.0.0.ebuild
@@ -0,0 +1,92 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+# ebuild generated by hackport 0.5.1.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit elisp-common haskell-cabal
+
+DESCRIPTION="Happy Haskell Programming"
+HOMEPAGE="http://www.mew.org/~kazu/proj/ghc-mod/"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
+
+LICENSE="AGPL-3"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="emacs"
+
+RESTRICT=test # doctests break on modules collisions: temporary / temporary-rc
+
+RDEPEND=">=dev-haskell/cabal-helper-0.7.3.0:=[profile?] <dev-haskell/cabal-helper-0.8:=[profile?]
+ >=dev-haskell/djinn-ghc-0.0.2.2:=[profile?] <dev-haskell/djinn-ghc-0.1:=[profile?]
+ >=dev-haskell/extra-1.4.0:=[profile?] <dev-haskell/extra-1.6:=[profile?]
+ >=dev-haskell/fclabels-2.0:=[profile?] <dev-haskell/fclabels-2.1:=[profile?]
+ >=dev-haskell/ghc-paths-0.1.0.9:=[profile?] <dev-haskell/ghc-paths-0.2:=[profile?]
+ >=dev-haskell/ghc-syb-utils-0.2.3:=[profile?] <dev-haskell/ghc-syb-utils-0.3:=[profile?]
+ >=dev-haskell/haskell-src-exts-1.16.0.1:=[profile?] <dev-haskell/haskell-src-exts-1.19:=[profile?]
+ >=dev-haskell/hlint-1.9.27:=[profile?] <dev-haskell/hlint-1.10:=[profile?]
+ >=dev-haskell/monad-control-1:=[profile?] <dev-haskell/monad-control-1.1:=[profile?]
+ >=dev-haskell/monad-journal-0.4:=[profile?] <dev-haskell/monad-journal-0.8:=[profile?]
+ >=dev-haskell/mtl-2.0:=[profile?] <dev-haskell/mtl-2.3:=[profile?]
+ <dev-haskell/old-time-1.2:=[profile?]
+ >=dev-haskell/optparse-applicative-0.11.0:=[profile?] <dev-haskell/optparse-applicative-0.14.0:=[profile?]
+ >=dev-haskell/pipes-4.1.0:=[profile?] <dev-haskell/pipes-4.4:=[profile?]
+ >=dev-haskell/safe-0.3.9:=[profile?] <dev-haskell/safe-0.4:=[profile?]
+ >=dev-haskell/semigroups-0.10.0:=[profile?] <dev-haskell/semigroups-0.19:=[profile?]
+ >=dev-haskell/split-0.2.2:=[profile?] <dev-haskell/split-0.3:=[profile?]
+ >=dev-haskell/syb-0.5.1:=[profile?] <dev-haskell/syb-0.7:=[profile?]
+ >=dev-haskell/temporary-1.2.0.3:=[profile?] <dev-haskell/temporary-1.3:=[profile?]
+ >=dev-haskell/text-1.2.1.3:=[profile?] <dev-haskell/text-1.3:=[profile?]
+ >=dev-haskell/transformers-base-0.4.4:=[profile?] <dev-haskell/transformers-base-0.5:=[profile?]
+ >=dev-lang/ghc-7.8.2:=
+ emacs? ( >=app-editors/emacs-23.1:* )
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.18.1.3 <dev-haskell/cabal-1.25
+ test? ( >=dev-haskell/doctest-0.9.3 <dev-haskell/doctest-0.12
+ >=dev-haskell/hspec-2.0.0 <dev-haskell/hspec-2.4 )
+"
+SITEFILE=50${PN}-gentoo.el
+
+PATCHES=("${FILESDIR}"/${PN}-5.6.0.0-gentoo.patch)
+
+src_compile() {
+ haskell-cabal_src_compile
+ if use emacs ; then
+ pushd elisp
+ elisp-compile *.el
+ popd
+ fi
+}
+
+src_install() {
+ haskell-cabal_src_install
+ if use emacs ; then
+ pushd "${S}"
+ elisp-install ghc-mod elisp/*.{el,elc}
+ elisp-site-file-install "${FILESDIR}"/${SITEFILE}
+ popd
+ fi
+}
+
+pkg_postinst() {
+ haskell-cabal_pkg_postinst
+ if use emacs ; then
+ elisp-site-regen
+ elog "To configure ghc-mod either add this line to ~/.emacs:"
+ elog "(autoload 'ghc-init \"ghc\" nil t)"
+ elog "and either this line:"
+ elog "(add-hook 'haskell-mode-hook (lambda () (ghc-init)))"
+ elog "or if you wish to use flymake:"
+ elog "(add-hook 'haskell-mode-hook (lambda () (ghc-init) (flymake-mode)))"
+ fi
+}
+
+pkg_postrm() {
+ haskell-cabal_pkg_postrm
+ if use emacs ; then
+ elisp-site-regen
+ fi
+}
diff --git a/app-emacs/ghc-mod/metadata.xml b/app-emacs/ghc-mod/metadata.xml
new file mode 100644
index 0000000..fc177fe
--- /dev/null
+++ b/app-emacs/ghc-mod/metadata.xml
@@ -0,0 +1,20 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>gnu-emacs@gentoo.org</email>
+ <name>Gentoo GNU Emacs project</name>
+</maintainer>
+<maintainer type="project">
+ <email>haskell@gentoo.org</email>
+ <name>Gentoo Haskell</name>
+</maintainer>
+<longdescription>
+ This packages includes Elisp files and a Haskell command, "ghc-mod".
+ "ghc*.el" enable completion of Haskell symbols on Emacs. Flymake is
+ also integrated. "ghc-mod" is a backend of "ghc*.el". It lists up
+ all installed modules or extracts names of functions, classes, and
+ data declarations.
+</longdescription>
+<stabilize-allarches/>
+</pkgmetadata>