summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-arcade')
-rw-r--r--games-arcade/methane/Manifest1
-rw-r--r--games-arcade/methane/files/methane-2.0.1-makefile.patch41
-rw-r--r--games-arcade/methane/metadata.xml1
-rw-r--r--games-arcade/methane/methane-2.0.1.ebuild43
4 files changed, 86 insertions, 0 deletions
diff --git a/games-arcade/methane/Manifest b/games-arcade/methane/Manifest
index e42c2a803ff2..fbfe7274cb36 100644
--- a/games-arcade/methane/Manifest
+++ b/games-arcade/methane/Manifest
@@ -1 +1,2 @@
DIST methane-1.5.1.tgz 1057881 BLAKE2B c783d8153e96cbf0f8f3593cd5ddccd0a9ec8222f61667d411cd3be7159ecf5a3364ad0212b77590b256fc33094e7ea73b83bdcb048aaea6d506e3e146b1412a SHA512 3506f288179a127f8508bd9d4225618d8dcd93794c559822ed2836bb46a318ce3c199f951f564064091b1125375118f2d64c50a27059dcd0e49c8379fa8c3155
+DIST methane-2.0.1.tar.gz 1058487 BLAKE2B 2fc450c03dbbd57439b22e8e6ac8eebd2db18f97a3338180decdc0a437207b581a00e664e6353595c9eb50c16f7d9fead96bddf6ca50b67326ecea6dd4bb935a SHA512 96b005eb5964185adea89aa43afda375c474db8088a132b2d46a843a1eca6ba91f83bf41277a3f3cfa24c4f9b9dae7098527414284fd0521e92a34c225e06bd9
diff --git a/games-arcade/methane/files/methane-2.0.1-makefile.patch b/games-arcade/methane/files/methane-2.0.1-makefile.patch
new file mode 100644
index 000000000000..0cf205041ed7
--- /dev/null
+++ b/games-arcade/methane/files/methane-2.0.1-makefile.patch
@@ -0,0 +1,41 @@
+From 7fa0b482546993d5279911a43ad6cb75c96ec1f0 Mon Sep 17 00:00:00 2001
+From: "Azamat H. Hackimov" <azamat.hackimov@gmail.com>
+Date: Wed, 14 Dec 2022 00:28:51 +0300
+Subject: [PATCH] Use portable variables in Makefile
+
+---
+ Makefile | 9 +++++----
+ 1 file changed, 5 insertions(+), 4 deletions(-)
+
+diff --git a/Makefile b/Makefile
+index 35c3eb1..f827efc 100644
+--- a/Makefile
++++ b/Makefile
+@@ -1,5 +1,6 @@
+-METHANE_FLAGS = `pkg-config --cflags clanCore-4.1 clanDisplay-4.1 clanApp-4.1 clanGL-4.1 clanSound-4.1 libmikmod` -Isources
+-METHANE_LIBS = `pkg-config --libs clanCore-4.1 clanDisplay-4.1 clanApp-4.1 clanGL-4.1 clanSound-4.1 libmikmod`
++PKG_CONFIG ?= pkg-config
++METHANE_FLAGS := $(shell ${PKG_CONFIG} --cflags clanCore-4.1 clanDisplay-4.1 clanApp-4.1 clanGL-4.1 clanSound-4.1 libmikmod) -Isources
++METHANE_LIBS := $(shell ${PKG_CONFIG} --libs clanCore-4.1 clanDisplay-4.1 clanApp-4.1 clanGL-4.1 clanSound-4.1 libmikmod)
+
+ OBJF = sources/precomp.o \
+ sources/player.o \
+@@ -37,7 +38,7 @@ message:
+ @echo "================================="
+
+ methane: ${OBJF}
+- g++ ${CXXFLAGS} ${OBJF} -o methane ${METHANE_LIBS}
++ $(CXX) ${CXXFLAGS} ${LDFLAGS} ${OBJF} -o methane ${METHANE_LIBS}
+
+ clean:
+ @rm -f sources/*.o
+@@ -49,5 +50,5 @@ distclean: clean
+ # The main source code
+ %.o:%.cpp
+ @echo " Compiling $<..."
+- gcc ${CXXFLAGS} ${METHANE_FLAGS} -c $< -o $@
++ $(CXX) ${CXXFLAGS} ${METHANE_FLAGS} -c $< -o $@
+
+--
+2.37.4
+
diff --git a/games-arcade/methane/metadata.xml b/games-arcade/methane/metadata.xml
index 8c93ac9be921..b826a80f7a10 100644
--- a/games-arcade/methane/metadata.xml
+++ b/games-arcade/methane/metadata.xml
@@ -6,6 +6,7 @@
<name>Gentoo Games Project</name>
</maintainer>
<upstream>
+ <remote-id type="github">rombust/Methane</remote-id>
<remote-id type="sourceforge">methane</remote-id>
</upstream>
</pkgmetadata>
diff --git a/games-arcade/methane/methane-2.0.1.ebuild b/games-arcade/methane/methane-2.0.1.ebuild
new file mode 100644
index 000000000000..24b1b2b6360d
--- /dev/null
+++ b/games-arcade/methane/methane-2.0.1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit desktop toolchain-funcs
+
+DESCRIPTION="Port from an old Amiga game"
+HOMEPAGE="https://methane.sourceforge.net/"
+SRC_URI="https://github.com/rombust/Methane/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+S="${WORKDIR}/Methane-${PV}"
+
+RDEPEND="
+ dev-games/clanlib:4.1[opengl]
+ media-libs/libmikmod
+"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}/${P}-makefile.patch"
+)
+
+src_prepare() {
+ default
+
+ tc-export PKG_CONFIG
+}
+
+src_install() {
+ dobin methane
+
+ insinto /usr/share/${PN}
+ doins resources/*
+
+ newicon docs/puff.gif ${PN}.gif
+ make_desktop_entry ${PN} "Super Methane Brothers" /usr/share/pixmaps/${PN}.gif
+ HTML_DOCS="docs/*" dodoc authors.txt history.txt readme.txt
+}