summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSardem FF7 <sardemff7.pub@gmail.com>2011-03-09 12:33:41 +0100
committerSardem FF7 <sardemff7.pub@gmail.com>2011-03-09 13:02:23 +0100
commit73431bdc43498bfc5c9bb57b4d6fe9fea1d15af0 (patch)
treedb882b8823901c5e4f931d6e800367fe03f82602
parentmozilla-scm: no make jobs filtering any more (diff)
downloadsardemff7-73431bdc43498bfc5c9bb57b4d6fe9fea1d15af0.tar.gz
sardemff7-73431bdc43498bfc5c9bb57b4d6fe9fea1d15af0.tar.bz2
sardemff7-73431bdc43498bfc5c9bb57b4d6fe9fea1d15af0.zip
Dependendies cleanup
-rw-r--r--eclass/mozilla-config.eclass19
-rw-r--r--eclass/mozilla-scm.eclass7
-rw-r--r--net-libs/xulrunner/Manifest2
-rw-r--r--net-libs/xulrunner/xulrunner-9999.ebuild4
-rw-r--r--www-client/firefox/Manifest2
-rw-r--r--www-client/firefox/files/firefox.desktop9
6 files changed, 20 insertions, 23 deletions
diff --git a/eclass/mozilla-config.eclass b/eclass/mozilla-config.eclass
index 16c7493..3a95fe4 100644
--- a/eclass/mozilla-config.eclass
+++ b/eclass/mozilla-config.eclass
@@ -13,18 +13,15 @@ inherit flag-o-matic
## Base common stuff
##
RDEPEND="
- x11-libs/libXrender
- x11-libs/libXt
- x11-libs/libXmu
virtual/jpeg
dev-libs/expat
app-arch/unzip
>=x11-libs/gtk+-2.8.6
- >=dev-libs/glib-2.8.2
+ >=dev-libs/glib-2.26
>=x11-libs/pango-1.10.1
>=dev-libs/libIDL-0.8.0
+ >=dev-libs/libevent-1.4.7
!<x11-base/xorg-x11-6.7.0-r2
- >=sys-libs/zlib-1.1.4
>=sys-devel/binutils-2.16.1
>=dev-libs/nss-3.12.9
@@ -36,7 +33,6 @@ RDEPEND="
alsa? ( media-libs/alsa-lib )
dbus? ( >=dev-libs/dbus-glib-0.72 )
- gnome? ( >=dev-libs/glib-2.25 )
libnotify? ( >=x11-libs/libnotify-0.4 )
startup-notification? ( >=x11-libs/startup-notification-0.8 )
system-sqlite? ( >=dev-db/sqlite-3.7.4[fts3,secure-delete,unlock-notify] )
@@ -48,7 +44,7 @@ DEPEND="${RDEPEND}
webm? ( dev-lang/yasm )
"
-IUSE="+alsa custom-optimization dbus +ipc gnome libnotify mozdom raw startup-notification +system-sqlite +webm wifi"
+IUSE="+alsa custom-optimization dbus +ipc libnotify mozdom raw startup-notification +system-sqlite +webm wifi"
# Set by configure (plus USE_AUTOCONF=1), but useful for NSPR
export MOZILLA_CLIENT=1
@@ -171,11 +167,13 @@ function mozconfig_configure {
--with-nspr-prefix="${EPREFIX}"/usr \
--with-system-nss \
--with-nss-prefix="${EPREFIX}"/usr \
+ --with-system-libevent="${EPREFIX}"/usr \
--x-includes="${EPREFIX}"/usr/include \
--x-libraries="${EPREFIX}"/usr/$(get_libdir) \
--with-distribution-id=org.gentoo
mozconfig_annotate 'Gentoo defaults' \
+ --enable-gio \
--enable-single-profile \
--disable-profilesharing \
--disable-profilelocking
@@ -204,7 +202,6 @@ function mozconfig_configure {
if ${IS_LIBXUL}; then
mozconfig_annotate 'Provide libmozjs' --enable-shared-js
- mozconfig_annotate 'Gentoo system' --with-system-libevent="${EPREFIX}"/usr
else
mozconfig_annotate 'libxul application' \
--enable-official-branding \
@@ -220,7 +217,6 @@ function mozconfig_configure {
mozconfig_use_enable alsa ogg
mozconfig_use_enable alsa wave
mozconfig_use_enable dbus
- mozconfig_use_enable gnome gio
mozconfig_use_enable ipc # +ipc, upstream default
mozconfig_use_enable libnotify
mozconfig_use_enable raw
@@ -233,8 +229,7 @@ function mozconfig_configure {
# NOTE: Uses internal copy of libvpx
if use webm && ! use alsa; then
- ewarn "USE=webm needs USE=alsa, disabling WebM support."
- mozconfig_annotate '+webm -alsa' --disable-webm
+ die "USE=webm needs USE=alsa"
fi
@@ -290,7 +285,7 @@ function mozconfig_configure {
function mozilla_application_install() {
# Install icon and .desktop for menu entry
- newicon "${S}"/other-licenses/branding/${PN}/content/icon48.png ${PN}-icon.png
+ newicon "${S}"/other-licenses/branding/${PN}/content/icon48.png ${PN}.png
newmenu "${FILESDIR}"/${PN}.desktop ${PN}.desktop
# Add StartupNotify=true bug 237317
diff --git a/eclass/mozilla-scm.eclass b/eclass/mozilla-scm.eclass
index 8b40bcc..de5f4f3 100644
--- a/eclass/mozilla-scm.eclass
+++ b/eclass/mozilla-scm.eclass
@@ -42,7 +42,7 @@ case "${PN}" in
esac
${IS_LIXBUL} || inherit fdo-mime
-EXPORT_FUNCTIONS pkg_setup src_unpack src_configure src_compile src_install pkg_postinst
+EXPORT_FUNCTIONS pkg_setup src_unpack src_configure src_install pkg_postinst
# @ECLASS-VARIABLE: EHG_REVISION
# @DESCRIPTION:
@@ -86,7 +86,11 @@ EXPORT_FUNCTIONS pkg_setup src_unpack src_configure src_compile src_install pkg_
## Base common stuff
##
RDEPEND="
+ x11-libs/libXrender
+ x11-libs/libXt
+ x11-libs/libXmu
>=dev-libs/nspr-4.8.7
+ >=sys-libs/zlib-1.1.4
"
${IS_LIBXUL} || RDEPEND+="~net-libs/xulrunner-9999[libnotify=,mozdom=,raw=,system-sqlite=,webm=,wifi=]"
@@ -94,6 +98,7 @@ DEPEND="${RDEPEND}
app-arch/zip
dev-vcs/mercurial
dev-util/pkgconfig
+ =dev-lang/python-2*[threads]
"
IUSE=""
diff --git a/net-libs/xulrunner/Manifest b/net-libs/xulrunner/Manifest
index 6605724..c7d596f 100644
--- a/net-libs/xulrunner/Manifest
+++ b/net-libs/xulrunner/Manifest
@@ -1,3 +1,3 @@
AUX default-prefs.js 709 RMD160 a4d062f75c17552545267ec3fe2f6b54073dafbd SHA1 580128e9edf8021fdbbca2c91abf63cb83bab2c7 SHA256 e6850b0a22f7d3889b49ec4a79a3c4d3d077edd98c8f0ffdc26e30bc70bb4b09
AUX gentoo-specific.patch 2957 RMD160 684dc2176769a56c2b1c206b59f999cd44d99c45 SHA1 35ff8e325e45b5384a404a4f99b12fdba9d5e0f3 SHA256 23d981e48a5308dd11ce2fc831071d138d54717bff9cb546dfc5467b0f4204c7
-EBUILD xulrunner-9999.ebuild 2362 RMD160 fd88b4be627a765a2f7de4c46b18fa2fc1e9a8c6 SHA1 dca9261c153ba3ae285d52ee2429745ff3ecdaed SHA256 085cdee6601bd4114669a8665d19f30a9d813c5a5d797cd51919d50b678f3c07
+EBUILD xulrunner-9999.ebuild 2284 RMD160 894538962e60ba815d67536bfc099a02da2888e5 SHA1 d5c25553c27bd54c7d7d7df74ffd5a93bfc3296f SHA256 cb9300a46d7e8675229a73b6493b207aa861d6b73f5d54bb72754a0d27871d3d
diff --git a/net-libs/xulrunner/xulrunner-9999.ebuild b/net-libs/xulrunner/xulrunner-9999.ebuild
index 8d27ab3..f05db6c 100644
--- a/net-libs/xulrunner/xulrunner-9999.ebuild
+++ b/net-libs/xulrunner/xulrunner-9999.ebuild
@@ -14,13 +14,9 @@ SLOT="1.9"
IUSE="debug"
RDEPEND="
- >=dev-libs/libevent-1.4.7
!www-plugins/weave
"
-DEPEND="${RDEPEND}
- =dev-lang/python-2*[threads]"
-
src_prepare() {
# Gentoo specific stuff
epatch "${FILESDIR}"/gentoo-specific.patch
diff --git a/www-client/firefox/Manifest b/www-client/firefox/Manifest
index 59255d0..c433a17 100644
--- a/www-client/firefox/Manifest
+++ b/www-client/firefox/Manifest
@@ -1,4 +1,4 @@
AUX default-prefs.js 95 RMD160 805cdfec6fb31c224322cb71125547ad7a515f49 SHA1 7fab69d85b12a9f1b0c87fbb1821bdafd7485ac9 SHA256 8bc4cb870bc402db1f20b135a689f8c5dbfa5de8f1755b1926198d627c12c5f1
-AUX firefox.desktop 255 RMD160 4ef1cf548f11057274620b82f0728958a3424bea SHA1 6a440f817072fb60516c1a1d999dffb6d3fa1583 SHA256 9bf6e1264d986c68d64831d166ed6b506bff6df8b56d21bfc166aee09cbc753f
+AUX firefox.desktop 306 RMD160 3b24c918e3dd7c6ed935a748271e44894625b6aa SHA1 53f7f45eed895fcb1355609fcc3a994d6a8a7142 SHA256 26e8b5875faed9bde3620d346569af341d36519261fc3c85151f3120b711a51e
AUX gentoo-specific.patch 3937 RMD160 d167b98c03ff88d955e865aee78203d396620cf7 SHA1 92a372a945734b737ed2d4b534fc8a6ef9e39bbf SHA256 dd6115dcca2972d637f966c6c7faef6d19d8e2622e3c44a0950e98c8f18ec747
EBUILD firefox-9999.ebuild 1162 RMD160 73140caf6466377616004c216cdaedbec7b9daf0 SHA1 40efde75af4b8738de15e7a9d7ab8a4b1dd85ab3 SHA256 902211063f52b3a5fc3d24ab5ad6673f377387127002a372525e9d14eb62aeff
diff --git a/www-client/firefox/files/firefox.desktop b/www-client/firefox/files/firefox.desktop
index 98d5fdf..5ea9936 100644
--- a/www-client/firefox/files/firefox.desktop
+++ b/www-client/firefox/files/firefox.desktop
@@ -1,9 +1,10 @@
[Desktop Entry]
Name=Mozilla Firefox
-Comment=Web Browser
-Exec=/usr/bin/firefox %U
-Icon=firefox-icon
+GenericName=Web Browser
+TryExec=firefox
+Exec=firefox %U
+Icon=firefox
Terminal=false
Type=Application
-MimeType=text/html;text/xml;application/xhtml+xml;application/vnd.mozilla.xul+xml;text/mml;
+MimeType=text/html;text/xml;application/xhtml+xml;application/vnd.mozilla.xul+xml;text/mml;x-scheme-handler/http;x-scheme-handler/https;
Categories=Network;WebBrowser;