summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSardem FF7 <sardemff7.pub@gmail.com>2011-03-06 17:57:56 +0100
committerSardem FF7 <sardemff7.pub@gmail.com>2011-03-06 17:57:56 +0100
commit7d757878b009e161fd33f7330f005cb294cfb02a (patch)
treec4e435b60aef8df2ae039fe0f92859d0ec97854e
parentUpdate categories (diff)
downloadsardemff7-7d757878b009e161fd33f7330f005cb294cfb02a.tar.gz
sardemff7-7d757878b009e161fd33f7330f005cb294cfb02a.tar.bz2
sardemff7-7d757878b009e161fd33f7330f005cb294cfb02a.zip
Cleanup in eclasses for Mozilla stuff
-rw-r--r--eclass/mozilla-config.eclass300
-rw-r--r--eclass/mozilla-scm.eclass320
-rw-r--r--net-libs/xulrunner/Manifest2
-rw-r--r--net-libs/xulrunner/xulrunner-9999.ebuild18
-rw-r--r--www-client/firefox/Manifest2
-rw-r--r--www-client/firefox/firefox-9999.ebuild9
6 files changed, 342 insertions, 309 deletions
diff --git a/eclass/mozilla-config.eclass b/eclass/mozilla-config.eclass
new file mode 100644
index 0000000..816f1e2
--- /dev/null
+++ b/eclass/mozilla-config.eclass
@@ -0,0 +1,300 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+# @ECLASS: mozilla-config.eclass
+# @MAINTAINER:
+# Sardem FF7 <sardemff7.pub@gmail.com>
+# @BLURB: This eclass provides Mozilla config support
+
+inherit flag-o-matic
+
+##
+## Base common stuff
+##
+RDEPEND="
+ x11-libs/libXrender
+ x11-libs/libXt
+ x11-libs/libXmu
+ virtual/jpeg
+ dev-libs/expat
+ app-arch/unzip
+ >=x11-libs/gtk+-2.8.6
+ >=dev-libs/glib-2.8.2
+ >=x11-libs/pango-1.10.1
+ >=dev-libs/libIDL-0.8.0
+ !<x11-base/xorg-x11-6.7.0-r2
+ >=sys-libs/zlib-1.1.4
+
+ >=sys-devel/binutils-2.16.1
+ >=dev-libs/nss-3.12.9
+ >=app-text/hunspell-1.2
+ >=x11-libs/cairo-1.10.2[X]
+ x11-libs/pixman
+ x11-libs/pango[X]
+ media-libs/libpng[apng]
+
+ alsa? ( media-libs/alsa-lib )
+ dbus? ( >=dev-libs/dbus-glib-0.72 )
+ gnome? ( >=dev-libs/glib-2.25 )
+ libnotify? ( >=x11-libs/libnotify-0.4 )
+ startup-notification? ( >=x11-libs/startup-notification-0.8 )
+ system-sqlite? ( >=dev-db/sqlite-3.7.4[fts3,secure-delete,unlock-notify] )
+ webm? ( media-libs/libvpx )
+ wifi? ( net-wireless/wireless-tools )
+ "
+
+DEPEND="${RDEPEND}
+ webm? ( dev-lang/yasm )
+ "
+
+IUSE="+alsa custom-optimization dbus +ipc gnome libnotify mozdom raw startup-notification +system-sqlite +webm wifi"
+
+# Set by configure (plus USE_AUTOCONF=1), but useful for NSPR
+export MOZILLA_CLIENT=1
+export BUILD_OPT=1
+export NO_STATIC_LIB=1
+export USE_PTHREADS=1
+
+mozconfig_annotate() {
+ declare reason=$1 x ; shift
+ [[ $# -gt 0 ]] || die "mozconfig_annotate missing flags for ${reason}\!"
+ for x in ${*}; do
+ echo "ac_add_options ${x} # ${reason}" >>.mozconfig
+ done
+}
+
+mozconfig_flag() {
+ mozconfig_annotate "USE-flag: $(useq $1 && echo +$1 || echo -$1)" "$2"
+}
+
+mozconfig_use_enable() {
+ mozconfig_flag "$1" "$(use_enable "$@")"
+}
+
+mozconfig_use_with() {
+ mozconfig_flag "$1" "$(use_with "$@")"
+}
+
+##
+## mozconfig_configure
+##
+function mozconfig_configure {
+ ####################################
+ #
+ # Setup the initial .mozconfig
+ # See https://developer.mozilla.org/en/Configuring_Build_Options
+ #
+ ####################################
+
+ cp ${MOZ_APPLICATION}/config/mozconfig .mozconfig \
+ || die "cp mozconfig failed"
+
+ ####################################
+ #
+ # CFLAGS setup and ARCH support
+ #
+ ####################################
+
+ # Set optimization level
+ if [[ ${ARCH} == x86 ]]; then
+ mozconfig_annotate "less then -O2 causes a segfault on x86" --enable-optimize=-O2
+ elif use custom-optimization; then
+ # Set optimization level based on CFLAGS
+ if is-flag -O0; then
+ mozconfig_annotate 'CFLAGS optimization' --enable-optimize=-O0
+ elif is-flag -O1; then
+ mozconfig_annotate 'CFLAGS optimization' --enable-optimize=-O1
+ elif is-flag -Os; then
+ mozconfig_annotate 'CFLAGS optimization' --enable-optimize=-Os
+ else
+ mozconfig_annotate 'Default optimization: Gentoo' --enable-optimize=-O2
+ fi
+ else
+ # Enable Mozilla's default
+ mozconfig_annotate 'Default optimization: Mozilla' --enable-optimize
+ fi
+
+ # Now strip optimization from CFLAGS so it doesn't end up in the
+ # compile string
+ filter-flags '-O*'
+
+ # Strip over-aggressive CFLAGS - Mozilla supplies its own
+ # fine-tuned CFLAGS and shouldn't be interfered with.. Do this
+ # AFTER setting optimization above since strip-flags only allows
+ # -O -O1 and -O2
+ strip-flags
+
+ if [[ $(gcc-major-version) -eq 3 ]]; then
+ # Enable us to use flash, etc plugins compiled with gcc-2.95.3
+ mozconfig_annotate "building with >=gcc-3" --enable-old-abi-compat-wrappers
+
+ # Needed to build without warnings on gcc-3
+ CXXFLAGS="${CXXFLAGS} -Wno-deprecated"
+
+ if [[ "${ARCH}" == x86 &&
+ ( $(gcc-minor-version) -lt 2 ||
+ ( $(gcc-minor-version) -eq 2 && $(gcc-micro-version) -lt 3 )
+ ) ]]
+ then
+ replace-flags -march=pentium4 -march=pentium3
+ filter-flags -msse2
+ fi
+ elif [[ $(gcc-major-version) -lt 4 ]]; then
+ append-flags -fno-stack-protector
+ fi
+
+ # Go a little faster; use less RAM
+ append-flags "$MAKEEDIT_FLAGS"
+
+ ####################################
+ #
+ # mozconfig setup
+ #
+ ####################################
+
+ mozconfig_annotate 'Gentoo system' \
+ --disable-installer \
+ --disable-pedantic \
+ --with-system-png \
+ --with-system-jpeg \
+ --with-system-bz2 \
+ --with-system-zlib \
+ --disable-updater \
+ --enable-system-cairo \
+ --enable-system-hunspell \
+ --disable-strip \
+ --enable-default-toolkit=cairo-gtk2 \
+ --disable-strip-libs \
+ --disable-install-strip \
+ --with-system-nspr \
+ --with-nspr-prefix="${EPREFIX}"/usr \
+ --with-system-nss \
+ --with-nss-prefix="${EPREFIX}"/usr \
+ --x-includes="${EPREFIX}"/usr/include \
+ --x-libraries="${EPREFIX}"/usr/$(get_libdir) \
+ --with-distribution-id=org.gentoo
+
+ mozconfig_annotate 'Gentoo defaults' \
+ --enable-single-profile \
+ --disable-profilesharing \
+ --disable-profilelocking
+
+ sed -i \
+ -e '/--enable-application=/d' \
+ -e '/--enable-extensions=/d'\
+ .mozconfig
+ local extensions="default"
+ use mozdom && extensions+=",inspector"
+ mozconfig_annotate 'Application defaults' \
+ --enable-application=${MOZ_APPLICATION} \
+ --with-default-mozilla-five-home="${MOZILLA_FIVE_HOME}" \
+ --enable-extensions="${extensions}"
+
+ mozconfig_annotate 'Basic features' \
+ --enable-crypto \
+ --enable-tracejit \
+ --enable-pango \
+ --enable-mathml \
+ --enable-safe-browsing \
+ --enable-storage
+
+ # jemalloc won't build with older glibc
+ ! has_version ">=sys-libs/glibc-2.4" && mozconfig_annotate 'old glibc' --disable-jemalloc
+
+ if ${IS_LIBXUL}; then
+ mozconfig_annotate 'Provide libmozjs' --enable-shared-js
+ mozconfig_annotate 'Gentoo system' --with-system-libevent="${EPREFIX}"/usr
+ else
+ mozconfig_annotate 'libxul application' \
+ --enable-official-branding \
+ --with-system-libxul \
+ --with-libxul-sdk="${EPREFIX}"${MOZDEVELDIR}
+ fi
+
+ [[ $# -gt 0 ]] && \
+ mozconfig_annotate 'Ebuild specific option: '"${P}" \
+ ${*}
+
+ # Use system libraries
+ mozconfig_use_enable alsa ogg
+ mozconfig_use_enable alsa wave
+ mozconfig_use_enable dbus
+ mozconfig_use_enable gnome gio
+ mozconfig_use_enable ipc # +ipc, upstream default
+ mozconfig_use_enable libnotify
+ mozconfig_use_enable raw
+ mozconfig_use_enable startup-notification
+ mozconfig_use_enable system-sqlite
+ mozconfig_use_enable webm
+ mozconfig_use_with webm system-libvpx
+ mozconfig_use_enable wifi necko-wifi
+
+
+ # NOTE: Uses internal copy of libvpx
+ if use webm && ! use alsa; then
+ ewarn "USE=webm needs USE=alsa, disabling WebM support."
+ mozconfig_annotate '+webm -alsa' --disable-webm
+ fi
+
+
+ # Debug
+ if use debug ; then
+ mozconfig_annotate 'Debug activated' \
+ --disable-optimize \
+ --enable-valgrind \
+ --enable-debug=-ggdb \
+ --enable-debug-modules=all \
+ --enable-debugger-info-modules
+ else
+ mozconfig_annotate 'Debug deactivated' \
+ --disable-debug \
+ --disable-tests
+ fi
+
+ # omni.jar breaks ff on xr
+ # Bug 60668: Galeon doesn't build without oji enabled, so enable it
+ # regardless of java setting.--enable-oji
+ mozconfig_annotate 'Broken' \
+ --disable-crashreporter \
+ --enable-chrome-format=jar \
+ --enable-oji
+
+ mozconfig_annotate 'Deprecated' \
+ --disable-gnomeui \
+ --disable-gnomevfs
+
+
+ # Currently --enable-elf-dynstr-gc only works for x86 and ppc,
+ # thanks to Jason Wever <weeve@gentoo.org> for the fix.
+ # -- This breaks now on ppc, no idea why
+# if use x86 || use ppc && [[ ${enable_optimize} != -O0 ]]; then
+ if use x86 && [[ ${enable_optimize} != -O0 ]]; then
+ mozconfig_annotate "${ARCH} optimized build" --enable-elf-dynstr-gc
+ fi
+# fi
+
+ echo
+ echo '=========================================================='
+ echo "Building ${PF} with the following configuration"
+ grep '^ac_add_options' .mozconfig | while read ac opt hash reason; do
+ [[ -z ${hash} || ${hash} == \# ]] \
+ || die "error reading mozconfig: ${ac} ${opt} ${hash} ${reason}"
+ printf ' %-60s %s\n' "${opt}" "${reason:-mozilla.org default}"
+ done
+ echo '=========================================================='
+ echo
+
+ mozilla-scm_src_configure
+}
+
+function mozilla_application_install() {
+ # Install icon and .desktop for menu entry
+ newicon "${S}"/other-licenses/branding/${PN}/content/icon48.png ${PN}-icon.png
+ newmenu "${FILESDIR}"/${PN}.desktop
+
+ # Add StartupNotify=true bug 237317
+ if use startup-notification ; then
+ echo "StartupNotify=true" >> "${ED}"/usr/share/applications/${PN}.desktop
+ fi
+}
diff --git a/eclass/mozilla-scm.eclass b/eclass/mozilla-scm.eclass
index 096c47c..852d559 100644
--- a/eclass/mozilla-scm.eclass
+++ b/eclass/mozilla-scm.eclass
@@ -5,12 +5,12 @@
# @ECLASS: mozilla-scm.eclass
# @MAINTAINER:
# Sardem FF7 <sardemff7.pub@gmail.com>
-# @BLURB: This eclass provides Mozilla specific SCM support
+# @BLURB: This eclass provides Mozilla SCM support
WANT_AUTOCONF="2.1"
EAPI="3"
-inherit eutils multilib flag-o-matic toolchain-funcs autotools prefix makeedit pax-utils python
+inherit eutils multilib toolchain-funcs autotools python
MAJ_XUL_PV="2.0"
@@ -42,7 +42,7 @@ case "${PN}" in
esac
${IS_LIXBUL} || inherit fdo-mime
-EXPORT_FUNCTIONS pkg_setup src_unpack src_compile src_install pkg_postinst
+EXPORT_FUNCTIONS pkg_setup src_unpack src_configure src_compile src_install pkg_postinst
# @ECLASS-VARIABLE: EHG_REVISION
# @DESCRIPTION:
@@ -86,73 +86,17 @@ EXPORT_FUNCTIONS pkg_setup src_unpack src_compile src_install pkg_postinst
## Base common stuff
##
RDEPEND="
- x11-libs/libXrender
- x11-libs/libXt
- x11-libs/libXmu
- virtual/jpeg
- dev-libs/expat
- app-arch/zip
- app-arch/unzip
- >=x11-libs/gtk+-2.8.6
- >=dev-libs/glib-2.8.2
- >=x11-libs/pango-1.10.1
- >=dev-libs/libIDL-0.8.0
- !<x11-base/xorg-x11-6.7.0-r2
- >=sys-libs/zlib-1.1.4
-
- >=sys-devel/binutils-2.16.1
- >=dev-libs/nss-3.12.9
>=dev-libs/nspr-4.8.7
- >=app-text/hunspell-1.2
- >=x11-libs/cairo-1.10.2[X]
- x11-libs/pixman
- x11-libs/pango[X]
- media-libs/libpng[apng]
-
- alsa? ( media-libs/alsa-lib )
- dbus? ( >=dev-libs/dbus-glib-0.72 )
- gnome? ( >=dev-libs/glib-2.25 )
- libnotify? ( >=x11-libs/libnotify-0.4 )
- startup-notification? ( >=x11-libs/startup-notification-0.8 )
- system-sqlite? ( >=dev-db/sqlite-3.7.4[fts3,secure-delete,unlock-notify] )
- webm? ( media-libs/libvpx )
- wifi? ( net-wireless/wireless-tools )
"
${IS_LIBXUL} || RDEPEND+="~net-libs/xulrunner-9999[libnotify=,mozdom=,raw=,system-sqlite=,webm=,wifi=]"
DEPEND="${RDEPEND}
+ app-arch/zip
dev-vcs/mercurial
dev-util/pkgconfig
- webm? ( dev-lang/yasm )
"
-IUSE="+alsa custom-optimization dbus +ipc gnome libnotify mozdom raw startup-notification +system-sqlite +webm wifi"
-
-# Set by configure (plus USE_AUTOCONF=1), but useful for NSPR
-export MOZILLA_CLIENT=1
-export BUILD_OPT=1
-export NO_STATIC_LIB=1
-export USE_PTHREADS=1
-
-mozconfig_annotate() {
- declare reason=$1 x ; shift
- [[ $# -gt 0 ]] || die "mozconfig_annotate missing flags for ${reason}\!"
- for x in ${*}; do
- echo "ac_add_options ${x} # ${reason}" >>.mozconfig
- done
-}
-
-mozconfig_flag() {
- mozconfig_annotate "USE-flag: $(useq $1 && echo +$1 || echo -$1)" "$2"
-}
-
-mozconfig_use_enable() {
- mozconfig_flag "$1" "$(use_enable "$@")"
-}
-
-mozconfig_use_with() {
- mozconfig_flag "$1" "$(use_with "$@")"
-}
+IUSE=""
function mercurial_fetch {
debug-print-function ${FUNCNAME} ${*}
@@ -188,7 +132,7 @@ function mercurial_fetch {
die "failed to clone ${repo}"
}
cd "${module}"
- elif [[ "${PN}" == "xulrunner" && -z "${EHG_OFFLINE}" ]]; then
+ elif ${IS_LIBXUL} && [[ -z "${EHG_OFFLINE}" ]]; then
einfo "Updating ${EHG_STORE_DIR}/mozilla/${module} from ${repo}"
cd "${module}" || die "failed to cd to ${module}"
${EHG_PULL_CMD} || die "update failed"
@@ -237,241 +181,11 @@ function mozilla-scm_pkg_setup {
}
##
-## ozconfig_configure
-##
-function mozconfig_configure {
- ####################################
- #
- # Setup the initial .mozconfig
- # See https://developer.mozilla.org/en/Configuring_Build_Options
- #
- ####################################
-
- cp ${MOZ_APPLICATION}/config/mozconfig .mozconfig \
- || die "cp mozconfig failed"
-
- ####################################
- #
- # CFLAGS setup and ARCH support
- #
- ####################################
-
- # Set optimization level
- if [[ ${ARCH} == x86 ]]; then
- mozconfig_annotate "less then -O2 causes a segfault on x86" --enable-optimize=-O2
- elif use custom-optimization; then
- # Set optimization level based on CFLAGS
- if is-flag -O0; then
- mozconfig_annotate 'CFLAGS optimization' --enable-optimize=-O0
- elif is-flag -O1; then
- mozconfig_annotate 'CFLAGS optimization' --enable-optimize=-O1
- elif is-flag -Os; then
- mozconfig_annotate 'CFLAGS optimization' --enable-optimize=-Os
- else
- mozconfig_annotate 'Default optimization: Gentoo' --enable-optimize=-O2
- fi
- else
- # Enable Mozilla's default
- mozconfig_annotate 'Default optimization: Mozilla' --enable-optimize
- fi
-
- # Now strip optimization from CFLAGS so it doesn't end up in the
- # compile string
- filter-flags '-O*'
-
- # Strip over-aggressive CFLAGS - Mozilla supplies its own
- # fine-tuned CFLAGS and shouldn't be interfered with.. Do this
- # AFTER setting optimization above since strip-flags only allows
- # -O -O1 and -O2
- strip-flags
-
- if [[ $(gcc-major-version) -eq 3 ]]; then
- # Enable us to use flash, etc plugins compiled with gcc-2.95.3
- mozconfig_annotate "building with >=gcc-3" --enable-old-abi-compat-wrappers
-
- # Needed to build without warnings on gcc-3
- CXXFLAGS="${CXXFLAGS} -Wno-deprecated"
-
- if [[ "${ARCH}" == x86 &&
- ( $(gcc-minor-version) -lt 2 ||
- ( $(gcc-minor-version) -eq 2 && $(gcc-micro-version) -lt 3 )
- ) ]]
- then
- replace-flags -march=pentium4 -march=pentium3
- filter-flags -msse2
- fi
- elif [[ $(gcc-major-version) -lt 4 ]]; then
- append-flags -fno-stack-protector
- fi
-
- # Go a little faster; use less RAM
- append-flags "$MAKEEDIT_FLAGS"
-
- ####################################
- #
- # mozconfig setup
- #
- ####################################
-
- mozconfig_annotate 'Gentoo system' \
- --disable-installer \
- --disable-pedantic \
- --with-system-png \
- --with-system-jpeg \
- --with-system-bz2 \
- --with-system-zlib \
- --disable-updater \
- --enable-system-cairo \
- --enable-system-hunspell \
- --disable-strip \
- --enable-default-toolkit=cairo-gtk2 \
- --disable-strip-libs \
- --disable-install-strip \
- --with-system-nspr \
- --with-nspr-prefix="${EPREFIX}"/usr \
- --with-system-nss \
- --with-nss-prefix="${EPREFIX}"/usr \
- --x-includes="${EPREFIX}"/usr/include \
- --x-libraries="${EPREFIX}"/usr/$(get_libdir) \
- --with-distribution-id=org.gentoo
-
- mozconfig_annotate 'Gentoo defaults' \
- --enable-single-profile \
- --disable-profilesharing \
- --disable-profilelocking
-
- sed -i \
- -e '/--enable-application=/d' \
- -e '/--enable-extensions=/d'\
- .mozconfig
- local extensions="default"
- use mozdom && extensions+=",inspector"
- mozconfig_annotate 'Application defaults' \
- --enable-application=${MOZ_APPLICATION} \
- --with-default-mozilla-five-home="${MOZILLA_FIVE_HOME}" \
- --enable-extensions="${extensions}"
-
- mozconfig_annotate 'Basic features' \
- --enable-crypto \
- --enable-tracejit \
- --enable-pango \
- --enable-mathml \
- --enable-safe-browsing \
- --enable-storage
-
- # jemalloc won't build with older glibc
- ! has_version ">=sys-libs/glibc-2.4" && mozconfig_annotate 'old glibc' --disable-jemalloc
-
- if ${IS_LIBXUL}; then
- mozconfig_annotate 'Provide libmozjs' --enable-shared-js
- mozconfig_annotate 'Gentoo system' --with-system-libevent="${EPREFIX}"/usr
- else
- mozconfig_annotate 'libxul application' \
- --enable-official-branding \
- --with-system-libxul \
- --with-libxul-sdk="${EPREFIX}"${MOZDEVELDIR}
- fi
-
- [[ $# -gt 0 ]] && \
- mozconfig_annotate 'Ebuild specific option: '"${P}" \
- ${*}
-
- # Use system libraries
- mozconfig_use_enable alsa ogg
- mozconfig_use_enable alsa wave
- mozconfig_use_enable dbus
- mozconfig_use_enable gnome gio
- mozconfig_use_enable ipc # +ipc, upstream default
- mozconfig_use_enable libnotify
- mozconfig_use_enable raw
- mozconfig_use_enable startup-notification
- mozconfig_use_enable system-sqlite
- mozconfig_use_enable webm
- mozconfig_use_with webm system-libvpx
- mozconfig_use_enable wifi necko-wifi
-
-
- # NOTE: Uses internal copy of libvpx
- if use webm && ! use alsa; then
- ewarn "USE=webm needs USE=alsa, disabling WebM support."
- mozconfig_annotate '+webm -alsa' --disable-webm
- fi
-
-
- # Debug
- if use debug ; then
- mozconfig_annotate 'Debug activated' \
- --disable-optimize \
- --enable-valgrind \
- --enable-debug=-ggdb \
- --enable-debug-modules=all \
- --enable-debugger-info-modules
- else
- mozconfig_annotate 'Debug deactivated' \
- --disable-debug \
- --disable-tests
- fi
-
- # omni.jar breaks ff on xr
- # Bug 60668: Galeon doesn't build without oji enabled, so enable it
- # regardless of java setting.--enable-oji
- mozconfig_annotate 'Broken' \
- --disable-crashreporter \
- --enable-chrome-format=jar \
- --enable-oji
-
- mozconfig_annotate 'Deprecated' \
- --disable-gnomeui \
- --disable-gnomevfs
-
-
- # Currently --enable-elf-dynstr-gc only works for x86 and ppc,
- # thanks to Jason Wever <weeve@gentoo.org> for the fix.
- # -- This breaks now on ppc, no idea why
-# if use x86 || use ppc && [[ ${enable_optimize} != -O0 ]]; then
- if use x86 && [[ ${enable_optimize} != -O0 ]]; then
- mozconfig_annotate "${ARCH} optimized build" --enable-elf-dynstr-gc
- fi
-# fi
-
- echo
- echo '=========================================================='
- echo "Building ${PF} with the following configuration"
- grep '^ac_add_options' .mozconfig | while read ac opt hash reason; do
- [[ -z ${hash} || ${hash} == \# ]] \
- || die "error reading mozconfig: ${ac} ${opt} ${hash} ${reason}"
- printf ' %-60s %s\n' "${opt}" "${reason:-mozilla.org default}"
- done
- echo '=========================================================='
- echo
-
- CC="$(tc-getCC)" CXX="$(tc-getCXX)" LD="$(tc-getLD)" PYTHON="$(PYTHON)" econf
-}
-
-##
## eclass exported function
-## src_install
+## src_configure
##
-function mozilla-scm_src_install {
- if ! ${IS_LIBXUL}; then
- # Install icon and .desktop for menu entry
- newicon "${S}"/other-licenses/branding/${PN}/content/icon48.png ${PN}-icon.png
- newmenu "${FILESDIR}"/${PN}.desktop \
- ${PN}.desktop
-
- # Add StartupNotify=true bug 237317
- if use startup-notification ; then
- echo "StartupNotify=true" >> "${ED}"/usr/share/applications/${PN}.desktop
- fi
- fi
-
- emake DESTDIR="${ED}" install || die "emake install failed"
-
- local prefdir="${ED}/${MOZILLA_FIVE_HOME}/defaults/pref"
- [[ -d "${prefdir}erences" ]] && prefdir+="erences"
- cp "${FILESDIR}"/default-prefs.js \
- "${prefdir}/all-gentoo.js" || \
- die "failed to cp -default-prefs.js"
+function mozilla-scm_src_configure {
+ CC="$(tc-getCC)" CXX="$(tc-getCXX)" LD="$(tc-getLD)" PYTHON="$(PYTHON)" econf "$@"
}
##
@@ -486,6 +200,22 @@ function mozilla-scm_src_compile {
##
## eclass exported function
+## src_install
+##
+function mozilla-scm_src_install {
+ emake DESTDIR="${ED}" install || die "emake install failed"
+
+ if ! ${IS_LIBXUL}; then
+ local prefdir="${ED}/${MOZILLA_FIVE_HOME}/defaults/pref"
+ [[ -d "${prefdir}erences" ]] && prefdir+="erences"
+ cp "${FILESDIR}"/default-prefs.js \
+ "${prefdir}/all-gentoo.js" || \
+ die "failed to cp -default-prefs.js"
+ fi
+}
+
+##
+## eclass exported function
## pkg_postinst
##
function mozilla-scm_pkg_postinst {
diff --git a/net-libs/xulrunner/Manifest b/net-libs/xulrunner/Manifest
index 6a8e0e5..6605724 100644
--- a/net-libs/xulrunner/Manifest
+++ b/net-libs/xulrunner/Manifest
@@ -1,3 +1,3 @@
AUX default-prefs.js 709 RMD160 a4d062f75c17552545267ec3fe2f6b54073dafbd SHA1 580128e9edf8021fdbbca2c91abf63cb83bab2c7 SHA256 e6850b0a22f7d3889b49ec4a79a3c4d3d077edd98c8f0ffdc26e30bc70bb4b09
AUX gentoo-specific.patch 2957 RMD160 684dc2176769a56c2b1c206b59f999cd44d99c45 SHA1 35ff8e325e45b5384a404a4f99b12fdba9d5e0f3 SHA256 23d981e48a5308dd11ce2fc831071d138d54717bff9cb546dfc5467b0f4204c7
-EBUILD xulrunner-9999.ebuild 2318 RMD160 476d255d83a50c609bd1dca2b771498b23e27831 SHA1 f7b14deec3b934877c58a5f9b93ec04ee52b75e3 SHA256 5e984262843dc414ebbd3d7490b316b72d0a908a181787f245960602bf67ccb0
+EBUILD xulrunner-9999.ebuild 2362 RMD160 fd88b4be627a765a2f7de4c46b18fa2fc1e9a8c6 SHA1 dca9261c153ba3ae285d52ee2429745ff3ecdaed SHA256 085cdee6601bd4114669a8665d19f30a9d813c5a5d797cd51919d50b678f3c07
diff --git a/net-libs/xulrunner/xulrunner-9999.ebuild b/net-libs/xulrunner/xulrunner-9999.ebuild
index 9066804..8d27ab3 100644
--- a/net-libs/xulrunner/xulrunner-9999.ebuild
+++ b/net-libs/xulrunner/xulrunner-9999.ebuild
@@ -4,7 +4,7 @@
-inherit mozilla-scm
+inherit mozilla-scm mozilla-config prefix pax-utils
DESCRIPTION="Mozilla runtime package that can be used to bootstrap XUL+XPCOM applications"
HOMEPAGE="http://developer.mozilla.org/en/docs/XULRunner"
@@ -32,17 +32,23 @@ src_prepare() {
xulrunner/app/nsRegisterGREUnix.cpp
# fix double symbols due to double -ljemalloc
- sed -i -e '/^LIBS += $(JEMALLOC_LIBS)/s/^/#/' \
- xulrunner/stub/Makefile.in || die
+ sed -i \
+ -e '/^LIBS += $(JEMALLOC_LIBS)/s/^/#/' \
+ xulrunner/stub/Makefile.in \
+ || die
# Gentoo install dirs
- sed -i -e 's:$(MOZ_APP_VERSION):'"${MAJ_XUL_PV}:" "${S}"/config/autoconf.mk.in \
+ sed -i \
+ -e 's:$(MOZ_APP_VERSION):'"${MAJ_XUL_PV}:" \
+ config/autoconf.mk.in \
|| die "${MAJ_XUL_PV} sed failed!"
# Enable gnomebreakpad
if use debug ; then
- sed -i -e "s:GNOME_DISABLE_CRASH_DIALOG=1:GNOME_DISABLE_CRASH_DIALOG=0:g" \
- "${S}"/build/unix/run-mozilla.sh || die "sed failed!"
+ sed -i \
+ -e "s:GNOME_DISABLE_CRASH_DIALOG=1:GNOME_DISABLE_CRASH_DIALOG=0:g" \
+ build/unix/run-mozilla.sh \
+ || die "sed failed!"
fi
eautoreconf
diff --git a/www-client/firefox/Manifest b/www-client/firefox/Manifest
index c2a89c0..59255d0 100644
--- a/www-client/firefox/Manifest
+++ b/www-client/firefox/Manifest
@@ -1,4 +1,4 @@
AUX default-prefs.js 95 RMD160 805cdfec6fb31c224322cb71125547ad7a515f49 SHA1 7fab69d85b12a9f1b0c87fbb1821bdafd7485ac9 SHA256 8bc4cb870bc402db1f20b135a689f8c5dbfa5de8f1755b1926198d627c12c5f1
AUX firefox.desktop 255 RMD160 4ef1cf548f11057274620b82f0728958a3424bea SHA1 6a440f817072fb60516c1a1d999dffb6d3fa1583 SHA256 9bf6e1264d986c68d64831d166ed6b506bff6df8b56d21bfc166aee09cbc753f
AUX gentoo-specific.patch 3937 RMD160 d167b98c03ff88d955e865aee78203d396620cf7 SHA1 92a372a945734b737ed2d4b534fc8a6ef9e39bbf SHA256 dd6115dcca2972d637f966c6c7faef6d19d8e2622e3c44a0950e98c8f18ec747
-EBUILD firefox-9999.ebuild 1134 RMD160 4320d6ba2b97ab51277e8acb09211b7daea25b2a SHA1 5e7e145dfd6d5dc8292b6bc373aba4b4c91b7bb0 SHA256 4ce80cf5d9f15169e78000c8990bd1d5ce6978afde84e6b53041ea78e5061510
+EBUILD firefox-9999.ebuild 1162 RMD160 73140caf6466377616004c216cdaedbec7b9daf0 SHA1 40efde75af4b8738de15e7a9d7ab8a4b1dd85ab3 SHA256 902211063f52b3a5fc3d24ab5ad6673f377387127002a372525e9d14eb62aeff
diff --git a/www-client/firefox/firefox-9999.ebuild b/www-client/firefox/firefox-9999.ebuild
index bac7ea3..083ac46 100644
--- a/www-client/firefox/firefox-9999.ebuild
+++ b/www-client/firefox/firefox-9999.ebuild
@@ -4,7 +4,7 @@
-inherit mozilla-scm
+inherit mozilla-scm mozilla-config prefix pax-utils
DESCRIPTION="Firefox Web Browser"
HOMEPAGE="http://www.mozilla.com/en-US/firefox"
@@ -26,13 +26,10 @@ src_prepare() {
-e 's:$(datadir)/idl/$(MOZ_APP_NAME)-$(MOZ_APP_VERSION):$(includedir)/idl:' \
-e 's:$(MOZ_APP_NAME)-$(MOZ_APP_VERSION):firefox:' \
-e 's:$(MOZ_APP_NAME)-devel-$(MOZ_APP_VERSION):firefox:' \
- "${S}"/config/autoconf.mk.in \
+ config/autoconf.mk.in \
|| die "${MAJ_XUL_PV} sed failed!"
eautoreconf
-
- cd js/src
- eautoreconf
}
src_configure() {
@@ -41,10 +38,10 @@ src_configure() {
src_install() {
mozilla-scm_src_install
+ mozilla_application_install
pax-mark m "${ED}"/${MOZILLA_FIVE_HOME}/firefox
-
# Plugins dir
dosym ../nsbrowser/plugins "${MOZILLA_FIVE_HOME}"/plugins \
|| die "failed to symlink"