summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2013-02-28 02:00:17 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2013-02-28 02:00:17 +0000
commitfa105518e2960be93b2bee6a5f4b4198f03f85af (patch)
treef182ec6b76e71d36f7e4a7dcacf53cf70697f684 /dev-embedded
parentold (diff)
downloadgentoo-2-fa105518e2960be93b2bee6a5f4b4198f03f85af.tar.gz
gentoo-2-fa105518e2960be93b2bee6a5f4b4198f03f85af.tar.bz2
gentoo-2-fa105518e2960be93b2bee6a5f4b4198f03f85af.zip
old
(Portage version: 2.1.11.50/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'dev-embedded')
-rw-r--r--dev-embedded/tigcc/ChangeLog9
-rw-r--r--dev-embedded/tigcc/files/a68k-fix.patch11
-rw-r--r--dev-embedded/tigcc/tigcc-0.95_p3.ebuild229
3 files changed, 6 insertions, 243 deletions
diff --git a/dev-embedded/tigcc/ChangeLog b/dev-embedded/tigcc/ChangeLog
index 25d9cef3b36c..f4c854e0dfe9 100644
--- a/dev-embedded/tigcc/ChangeLog
+++ b/dev-embedded/tigcc/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-embedded/tigcc
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-embedded/tigcc/ChangeLog,v 1.23 2012/04/30 02:54:59 vapier Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-embedded/tigcc/ChangeLog,v 1.24 2013/02/28 02:00:16 mr_bones_ Exp $
+
+ 28 Feb 2013; Michael Sterrett <mr_bones_@gentoo.org> -files/a68k-fix.patch,
+ -tigcc-0.95_p3.ebuild:
+ old
*tigcc-0.96_beta8 (30 Apr 2012)
@@ -100,4 +104,3 @@
+tigcc-0.95_beta19-r1.ebuild, +files/a68k-fix.patch:
Initial import as per bug #51162. Ebuild by Robert Führicht
<the_master_of_disaster@gmx.at>
-
diff --git a/dev-embedded/tigcc/files/a68k-fix.patch b/dev-embedded/tigcc/files/a68k-fix.patch
deleted file mode 100644
index 3330866af56f..000000000000
--- a/dev-embedded/tigcc/files/a68k-fix.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- sources/a68k/src/A68kdef.h.org 2004-05-19 15:21:48.555233864 +0200
-+++ sources/a68k/src/A68kdef.h 2004-05-19 15:22:12.527589512 +0200
-@@ -35,7 +35,7 @@
- #include <fcntl.h> */
- #else
- /* extern char *malloc(); */ /* (2.71.F3d) should be declared in stdlib.h */
--extern int open(), creat(), read(), write(), close(), unlink();
-+/* extern int open(), creat(), read(), write(), close(), unlink(); */
- #if defined(__MACH__) && defined(__APPLE__) /* Darwin / OS X */
- /* On Darwin, the implicit declaration below won't work, so we need to include
- <unistd.h>. - v.2.71.F3j, Kevin Kofler (reported by Christian Walther) */
diff --git a/dev-embedded/tigcc/tigcc-0.95_p3.ebuild b/dev-embedded/tigcc/tigcc-0.95_p3.ebuild
deleted file mode 100644
index 42be5610a399..000000000000
--- a/dev-embedded/tigcc/tigcc-0.95_p3.ebuild
+++ /dev/null
@@ -1,229 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-embedded/tigcc/tigcc-0.95_p3.ebuild,v 1.8 2012/04/30 02:53:44 vapier Exp $
-
-inherit eutils
-
-BASE_GCC="3.3.3"
-BASE_BINUTILS="2.14"
-GCC_VER=${BASE_GCC:0:3}
-BIN_VER=${BASE_BINUTILS:0:4}
-S=${WORKDIR}
-DESCRIPTION="Cross compiler for Texas Instruments TI-89, TI-92(+) and V200 calculators"
-HOMEPAGE="http://tigcc.ticalc.org"
-
-# mirror://gentoo/${P}.tar.bz2 comes from http://tigcc.ticalc.org/linux/tigcc_src.tar.bz2
-# which isn't that reliable
-
-#All kernel mirrors in gentoo didn't have 2.14
-# mirror://kernel/linux/devel/binutils/binutils-${BASE_BINUTILS}.tar.bz2
-
-SRC_URI="mirror://gentoo/${P}.tar.bz2
- mirror://gnu/gcc/releases/gcc-${BASE_GCC}/gcc-core-${BASE_GCC}.tar.bz2
- http://cdn.mirror.garr.it/mirrors/gnuftp/binutils/binutils-${BASE_BINUTILS}.tar.bz2
- http://members.chello.at/gerhard.kofler/kevin/ti89prog/libfargo.zip
- http://members.chello.at/gerhard.kofler/kevin/ti89prog/flashosa.zip"
-
-LICENSE="GPL-2"
-
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86"
-IUSE=""
-
-RDEPEND=">=sys-devel/binutils-2.14.90.0.6-r1"
-DEPEND="${RDEPEND}
- app-arch/unzip
- >=sys-devel/bison-1.875"
-
-src_unpack() {
- unpack ${A}
- # start by patching binutils and gcc
- cd ${WORKDIR}/binutils-${BASE_BINUTILS}
- epatch ${S}/sources/gcc/gas-${BIN_VER}-tigcc-*.diff
-
- cd ${WORKDIR}/gcc-${BASE_GCC}
- epatch ${S}/sources/gcc/gcc-${BASE_GCC}-tigcc-*.diff
-
- # a68k didn't compile, this should fix it.
- cd ${S}
- epatch ${FILESDIR}/a68k-fix.patch
-
- # fixes a bug in tprbuilder, needed for 0.95_beta8-r1
- # epatch ${FILESDIR}/tprbuilder-fix.patch
-
- # make build directories for binutils and gcc
- mkdir -p ${WORKDIR}/build/binutils
- mkdir ${WORKDIR}/build/gcc
-}
-
-src_compile() {
- # build binutils
- cd ${WORKDIR}/build/binutils
- CFLAGS="$CFLAGS" ${WORKDIR}/binutils-${BASE_BINUTILS}/configure \
- --disable-serial-configure --target=m68k-coff --disable-shared \
- --enable-static --disable-multilib --disable-nls \
- || die
- emake || die
-
- # build gcc
- cd ${WORKDIR}/build/gcc
-
- # --with-headers=${S}/tigcclib/include/c \
- CFLAGS="$CFLAGS" ${WORKDIR}/gcc-${BASE_GCC}/configure --target=m68k-coff \
- --with-gnu-as --with-as=${WORKDIR}/build/binutils/gas/as-new --with-gnu-ld \
- --disable-nls --disable-multilib --disable-shared --enable-static \
- --disable-threads \
- || die
- # GCC compilations _is intended_ to fail on a certain point, don't worry about that.
- emake
-
- # build a68k assembler
- cd ${S}/sources/a68k/src
- emake -e || die
-
- # build ld-tigcc linker
- cd ${S}/sources/ld-tigcc
- emake -e || die
-
- # build tigcc front-end
- cd ${S}/sources/tigcc/src
- emake -e || die
-
- # build tprbuilder (TIGCC project builder)
- cd ${S}/sources/tprbuilder/src
- emake -e || die
-
- # build patcher (object file patcher)
- cd ${S}/sources/patcher/src
- emake -e || die
-
- # build parser
- cd ${S}/sources/parser/src
- emake -e || die
-
- # build tict tool suite
- cd ${S}/tt
- CFLAGS="$CFLAGS" ./makelinux.sh || die
-
- # patch the script that launches the documentation browser to point to the correct location
- sed "s:\$TIGCC/doc:/usr/share/doc/${P}:g" ${S}/tigcclib/doc/converter/tigccdoc > ${S}/tigcclib/doc/converter/tigccdoc.new
-}
-
-src_install() {
- #ENV_FILE=${D}/etc/env.d/gcc/ti-linux-gnu-${GCC_VER}
- ENV_FILE=${D}/etc/env.d/99tigcc
-
- # install documentation
-
- cd ${S}/tigcclib/doc/converter
- into /usr
- dodir /usr/bin
- newbin tigccdoc.new tigccdoc
-
- dodir /usr/share/doc/${PF}
- cd ${S}
- dodoc AUTHORS BUGS CHANGELOG COPYING DIRECTORIES HOWTO INSTALL README README.linux README.osX
-
- cd ${S}/tigcclib/doc
- dohtml -r html/*.html
- cp html/qt-assistant.adp ${D}/usr/share/doc/${PF}/html
-
- cd ${S}/sources/a68k
- docinto a68k
- dodoc docs/*.txt
-
- cd ${S}/sources/tigcc
- docinto tigcc
- dodoc AUTHORS COPYING ChangeLog README
-
- cd ${S}/sources/tprbuilder
- docinto tprbuilder
- dodoc AUTHORS COPYING ChangeLog README
-
- cd ${S}/sources/patcher
- docinto patcher
- dodoc AUTHORS COPYING ChangeLog README
-
- cd ${S}/sources/parser
- docinto parser
- dodoc AUTHORS COPYING ChangeLog README
-
- cd ${S}/tt
- docinto tools
- dodoc history.txt linux_readme.txt readme.txt tooldocs.txt
-
- exeinto /usr/ti-linux-gnu/tigcc-bin/${GCC_VER}
- # install gcc
- cd ${WORKDIR}/build/gcc
- doexe gcc/cc1
- newexe gcc/xgcc gcc
- dosym /usr/ti-linux-gnu/tigcc-bin/${GCC_VER}/gcc /usr/ti-linux-gnu/tigcc-bin/${GCC_VER}/ti-linux-gnu-gcc
-
- # install gas
- # exeinto /usr/ti-linux-gnu/bin <-- a symlink will be created so that gas resides in /usr/ti-linux-gnu/bin too
- cd ${WORKDIR}/build/binutils
- newexe gas/as-new as
-
- # install a68k
- cd ${S}/sources/a68k/src
- newexe A68k a68k
-
- # install ld-tigcc
- cd ${S}/sources/ld-tigcc
- doexe ld-tigcc
- doexe ar-tigcc
-
- # install tigcc
- cd ${S}/sources/tigcc/src
- doexe tigcc
- dosym /usr/ti-linux-gnu/tigcc-bin/${GCC_VER}/tigcc /usr/ti-linux-gnu/tigcc-bin/${GCC_VER}/ti-linux-gnu-tigcc
-
- # install tprbuilder
- cd ${S}/sources/tprbuilder/src
- doexe tprbuilder
-
- # install patcher
- cd ${S}/sources/patcher/src
- doexe patcher
-
- # install parser
- cd ${S}/sources/parser/src
- doexe parser
-
- # install tict tool suite
- cd ${S}/tt
- doexe linuxbin/*
-
- # install header files
- dodir /usr/include/tigcc
- cp -R ${S}/tigcclib/include/* ${D}/usr/include/tigcc
- dosym /usr/include/tigcc/asm/os.h /usr/include/tigcc/asm/OS.h
-
- insinto /usr/lib/gcc-lib/ti-linux-gnu/${GCC_VER}
- # install library
- cd ${S}/tigcclib
- doins lib/*
- cd ${WORKDIR}
- doins flashosa/flashos.a
- doins fargo.a
-
- dodir /usr/share/tigcc
- # copy example programs
- cp -r ${S}/examples ${D}/usr/share/tigcc
-
- # create TIGCC env variable
- dodir /etc/env.d/gcc
- # echo -e "TIGCC=\"/usr/ti-linux-gnu/tigcc-bin/${GCC_VER}\"" >> ${ENV_FILE}
- # echo -e "CC=\"tigcc\"" >> ${ENV_FILE}
- echo -e "TIGCC=\"/usr/ti-linux-gnu\"" >> ${ENV_FILE}
- echo -e "PATH=\"/usr/ti-linux-gnu/tigcc-bin/${GCC_VER}:/usr/ti-linux-gnu/bin\"" >> ${ENV_FILE}
- echo -e "ROOTPATH=\"/usr/ti-linux-gnu/tigcc-bin/${GCC_VER}:/usr/ti-linux-gnu/bin\"" >> ${ENV_FILE}
- echo -e "LDPATH=\"/usr/lib/gcc-lib/ti-linux-gnu/${GCC_VER}\"" >> ${ENV_FILE}
-
- # a cross-compiling gcc with hard-coded names has been built.
- # therefore, we must place some symlinks.
- dosym /usr/include/tigcc /usr/ti-linux-gnu/include
- dosym /usr/lib/gcc-lib/ti-linux-gnu/${GCC_VER} /usr/ti-linux-gnu/lib
- dosym /usr/share/doc/${PF} /usr/ti-linux-gnu/doc
- dosym /usr/ti-linux-gnu/tigcc-bin/${GCC_VER} /usr/ti-linux-gnu/bin
-}