summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2015-05-23 23:57:52 +0000
committerManuel Rüger <mrueg@gentoo.org>2015-05-23 23:57:52 +0000
commit9c26979fc35fb53ac2b2cd92f103718d34a1e9ed (patch)
tree5bae6b99a4acabb63091bfe813b31a0a8fb4f547 /dev-ruby/posix-spawn
parent~arm (7) and ~ppc (6 and 7) keywords. Unfortunately patchelf doesn't (diff)
downloadgentoo-2-9c26979fc35fb53ac2b2cd92f103718d34a1e9ed.tar.gz
gentoo-2-9c26979fc35fb53ac2b2cd92f103718d34a1e9ed.tar.bz2
gentoo-2-9c26979fc35fb53ac2b2cd92f103718d34a1e9ed.zip
Version bump.
(Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key )
Diffstat (limited to 'dev-ruby/posix-spawn')
-rw-r--r--dev-ruby/posix-spawn/ChangeLog7
-rw-r--r--dev-ruby/posix-spawn/posix-spawn-0.3.11.ebuild33
2 files changed, 39 insertions, 1 deletions
diff --git a/dev-ruby/posix-spawn/ChangeLog b/dev-ruby/posix-spawn/ChangeLog
index 5f568437febe..83c0a9057e1f 100644
--- a/dev-ruby/posix-spawn/ChangeLog
+++ b/dev-ruby/posix-spawn/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/posix-spawn
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/posix-spawn/ChangeLog,v 1.11 2015/02/18 07:10:53 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/posix-spawn/ChangeLog,v 1.12 2015/05/23 23:57:52 mrueg Exp $
+
+*posix-spawn-0.3.11 (23 May 2015)
+
+ 23 May 2015; Manuel Rüger <mrueg@gentoo.org> +posix-spawn-0.3.11.ebuild:
+ Version bump.
*posix-spawn-0.3.10 (18 Feb 2015)
diff --git a/dev-ruby/posix-spawn/posix-spawn-0.3.11.ebuild b/dev-ruby/posix-spawn/posix-spawn-0.3.11.ebuild
new file mode 100644
index 000000000000..efffbf161823
--- /dev/null
+++ b/dev-ruby/posix-spawn/posix-spawn-0.3.11.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/posix-spawn/posix-spawn-0.3.11.ebuild,v 1.1 2015/05/23 23:57:52 mrueg Exp $
+
+EAPI=5
+
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+KEYWORDS="~amd64"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="README.md TODO HACKING"
+
+inherit ruby-fakegem
+
+DESCRIPTION="The posix-spawn library aims to implement a subset of the Ruby 1.9 Process::spawn"
+HOMEPAGE="https://github.com/rtomayko/posix-spawn/"
+
+LICENSE="MIT LGPL-2.1"
+SLOT="0"
+IUSE="test"
+
+each_ruby_configure() {
+ ${RUBY} -Cext extconf.rb || die
+}
+
+each_ruby_compile() {
+ emake V=1 -Cext
+ cp ext/*$(get_modname) lib/ || die
+}
+
+each_ruby_test() {
+ ${RUBY} -Ilib:.:test -e 'Dir["test/test_*.rb"].each {|f| require f}' || die
+}