summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2013-06-25 21:20:39 +0000
committerAlexis Ballier <aballier@gentoo.org>2013-06-25 21:20:39 +0000
commit96abdeb229928965b241332902ca83cb7f46ad61 (patch)
treeafe5bd51926990c44f571140afa39209891f5e31 /dev-tex
parentversion bump, bug #460054 (diff)
downloadgentoo-2-96abdeb229928965b241332902ca83cb7f46ad61.tar.gz
gentoo-2-96abdeb229928965b241332902ca83cb7f46ad61.tar.bz2
gentoo-2-96abdeb229928965b241332902ca83cb7f46ad61.zip
version bump
(Portage version: 2.2.0_alpha185/cvs/Linux x86_64, signed Manifest commit with key 160F534A)
Diffstat (limited to 'dev-tex')
-rw-r--r--dev-tex/metapost/ChangeLog7
-rw-r--r--dev-tex/metapost/metapost-1.803.ebuild74
2 files changed, 80 insertions, 1 deletions
diff --git a/dev-tex/metapost/ChangeLog b/dev-tex/metapost/ChangeLog
index b19559d59bf8..929950a6af27 100644
--- a/dev-tex/metapost/ChangeLog
+++ b/dev-tex/metapost/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-tex/metapost
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-tex/metapost/ChangeLog,v 1.4 2013/01/14 10:48:16 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-tex/metapost/ChangeLog,v 1.5 2013/06/25 21:20:39 aballier Exp $
+
+*metapost-1.803 (25 Jun 2013)
+
+ 25 Jun 2013; Alexis Ballier <aballier@gentoo.org> +metapost-1.803.ebuild:
+ version bump
*metapost-1.780 (14 Jan 2013)
diff --git a/dev-tex/metapost/metapost-1.803.ebuild b/dev-tex/metapost/metapost-1.803.ebuild
new file mode 100644
index 000000000000..2e70f7c1af36
--- /dev/null
+++ b/dev-tex/metapost/metapost-1.803.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-tex/metapost/metapost-1.803.ebuild,v 1.1 2013/06/25 21:20:39 aballier Exp $
+
+EAPI=5
+
+DESCRIPTION="System for producing graphics"
+HOMEPAGE="http://tug.org/metapost.html"
+SRC_URI="https://foundry.supelec.fr/frs/download.php/file/15750/${P}-src.tar.bz2"
+
+LICENSE="GPL-2 LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND=">=dev-libs/kpathsea-6.1.0_p20120701
+ >=app-admin/eselect-mpost-0.3
+ x11-libs/cairo
+ x11-libs/pixman
+ media-libs/libpng:0="
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+S=${WORKDIR}/${P}/source/texk/web2c
+
+src_configure() {
+ econf \
+ --disable-all-pkgs \
+ --enable-shared \
+ --disable-largefile \
+ --disable-ptex \
+ --enable-mp \
+ --with-system-cairo \
+ --with-system-libpng \
+ --without-ptexenc \
+ --with-system-kpathsea \
+ --with-system-xpdf \
+ --with-system-freetype \
+ --with-system-freetype2 \
+ --with-system-gd \
+ --with-system-teckit \
+ --with-system-t1lib \
+ --with-system-icu \
+ --with-system-graphite \
+ --with-system-zziplib \
+ --with-system-poppler \
+ --with-system-zlib \
+ --with-system-pixman \
+ --disable-native-texlive-build \
+ --without-mf-x-toolkit --without-x
+}
+
+src_compile() {
+ emake mpost
+}
+
+src_install() {
+ emake DESTDIR="${D}" \
+ SUBDIRS="" \
+ bin_PROGRAMS="mpost" \
+ nodist_man_MANS="" \
+ dist_man_MANS="" \
+ install-binPROGRAMS
+ # Rename it
+ mv "${D}/usr/bin/mpost" "${D}/usr/bin/mpost-${P}" || die "renaming failed"
+
+ cd "${WORKDIR}/${P}"
+ dodoc README CHANGES
+}
+
+pkg_postinst(){
+ einfo "Calling eselect mpost update"
+ eselect mpost update
+}