summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2012-11-26 03:09:13 +0000
committerAnthony G. Basile <blueness@gentoo.org>2012-11-26 03:09:13 +0000
commit9afeb8342405e695a24bfcab96f6fada6e35011b (patch)
tree9e8a6aea3b0c98069322337f887cc42b179bbfa5 /dev-util/comparator
parentAdding missing asciidoc build dep (diff)
downloadgentoo-2-9afeb8342405e695a24bfcab96f6fada6e35011b.tar.gz
gentoo-2-9afeb8342405e695a24bfcab96f6fada6e35011b.tar.bz2
gentoo-2-9afeb8342405e695a24bfcab96f6fada6e35011b.zip
Version bump
(Portage version: 2.1.11.31/cvs/Linux x86_64, signed Manifest commit with key 0xF52D4BBA)
Diffstat (limited to 'dev-util/comparator')
-rw-r--r--dev-util/comparator/ChangeLog7
-rw-r--r--dev-util/comparator/comparator-2.9.ebuild52
2 files changed, 58 insertions, 1 deletions
diff --git a/dev-util/comparator/ChangeLog b/dev-util/comparator/ChangeLog
index e313c5e8fa5f..a6ce500dc220 100644
--- a/dev-util/comparator/ChangeLog
+++ b/dev-util/comparator/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-util/comparator
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/comparator/ChangeLog,v 1.20 2012/10/28 15:11:13 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/comparator/ChangeLog,v 1.21 2012/11/26 03:09:13 blueness Exp $
+
+*comparator-2.9 (26 Nov 2012)
+
+ 26 Nov 2012; Anthony G. Basile <blueness@gentoo.org> +comparator-2.9.ebuild:
+ Version bump
28 Oct 2012; Anthony G. Basile <blueness@gentoo.org> metadata.xml:
Added myself as maintainer
diff --git a/dev-util/comparator/comparator-2.9.ebuild b/dev-util/comparator/comparator-2.9.ebuild
new file mode 100644
index 000000000000..656ed433dd35
--- /dev/null
+++ b/dev-util/comparator/comparator-2.9.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/comparator/comparator-2.9.ebuild,v 1.1 2012/11/26 03:09:13 blueness Exp $
+
+EAPI="4"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.*"
+
+inherit distutils toolchain-funcs
+
+DESCRIPTION="ESR's utility for making fast comparisons among large source trees"
+HOMEPAGE="http://www.catb.org/~esr/comparator/"
+SRC_URI="http://www.catb.org/~esr/comparator/${P}.tar.gz"
+
+LICENSE="as-is GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~mips ~ppc ~sparc ~x86"
+IUSE=""
+
+RDEPEND=""
+DEPEND="=app-text/docbook-xml-dtd-4.1.2*
+ app-text/xmlto"
+
+PYTHON_MODNAME="comparator.py"
+
+src_prepare() {
+ sed \
+ -e '/install -m 755 -o 0 -g 0 filterator/d' \
+ -e '/python setup.py install/d' \
+ -i Makefile || die "sed failed"
+}
+
+src_compile() {
+ distutils_src_compile
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}"
+ emake comparator.html scf-standard.html
+}
+
+src_install() {
+ distutils_src_install
+ emake ROOT="${D}" install
+
+ install_filterator() {
+ newbin filterator filterator-${PYTHON_ABI} || return 1
+ python_convert_shebangs ${PYTHON_ABI} "${ED}usr/bin/filterator-${PYTHON_ABI}"
+ }
+ python_execute_function -q install_filterator
+ python_generate_wrapper_scripts "${ED}usr/bin/filterator"
+
+ dohtml *.html
+}