summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuca Barbato <lu_zero@gentoo.org>2014-05-17 09:24:48 +0000
committerLuca Barbato <lu_zero@gentoo.org>2014-05-17 09:24:48 +0000
commit7d3c7ab6f658c3a10af8229d515369330181c5a1 (patch)
treee2d3ff5f4061564407e8a0c780f9d9618273e656 /media-libs/libpostproc
parentFix typo for --enable-usb_blaster_libftdi thanks to Paul Fertser <fercerpav@g... (diff)
downloadgentoo-2-7d3c7ab6f658c3a10af8229d515369330181c5a1.tar.gz
gentoo-2-7d3c7ab6f658c3a10af8229d515369330181c5a1.tar.bz2
gentoo-2-7d3c7ab6f658c3a10af8229d515369330181c5a1.zip
New snapshot
(Portage version: 2.2.10/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'media-libs/libpostproc')
-rw-r--r--media-libs/libpostproc/ChangeLog8
-rw-r--r--media-libs/libpostproc/libpostproc-10.20140517.ebuild88
2 files changed, 95 insertions, 1 deletions
diff --git a/media-libs/libpostproc/ChangeLog b/media-libs/libpostproc/ChangeLog
index f2e944e3b623..82cfcfb17b61 100644
--- a/media-libs/libpostproc/ChangeLog
+++ b/media-libs/libpostproc/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-libs/libpostproc
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libpostproc/ChangeLog,v 1.23 2014/05/12 17:03:20 lu_zero Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libpostproc/ChangeLog,v 1.24 2014/05/17 09:24:48 lu_zero Exp $
+
+*libpostproc-10.20140517 (17 May 2014)
+
+ 17 May 2014; Luca Barbato <lu_zero@gentoo.org>
+ +libpostproc-10.20140517.ebuild:
+ New snapshot
12 May 2014; Luca Barbato <lu_zero@gentoo.org> libpostproc-9999.ebuild:
Change main repository
diff --git a/media-libs/libpostproc/libpostproc-10.20140517.ebuild b/media-libs/libpostproc/libpostproc-10.20140517.ebuild
new file mode 100644
index 000000000000..a3f134efb7e2
--- /dev/null
+++ b/media-libs/libpostproc/libpostproc-10.20140517.ebuild
@@ -0,0 +1,88 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libpostproc/libpostproc-10.20140517.ebuild,v 1.1 2014/05/17 09:24:48 lu_zero Exp $
+
+EAPI="4"
+
+SCM=""
+if [ "${PV#9999}" != "${PV}" ] ; then
+ SCM="git-2"
+ EGIT_REPO_URI="git://github.com/lu-zero/postproc.git"
+fi
+
+inherit eutils flag-o-matic multilib toolchain-funcs ${SCM}
+
+DESCRIPTION="Video post processing library"
+HOMEPAGE="https://github.com/lu-zero/postproc"
+if [ "${PV#9999}" != "${PV}" ] ; then
+ SRC_URI=""
+elif [ "${PV%_p*}" != "${PV}" ] ; then # Snapshot
+ SRC_URI="mirror://gentoo/${P}.tar.xz"
+else # Release
+ SRC_URI="http://dev.gentoo.org/~lu_zero/distfiles/${P}.tar.xz"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+if [ "${PV#9999}" = "${PV}" ] ; then
+ KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux"
+fi
+IUSE="pic static-libs"
+
+# String for CPU features in the useflag[:configure_option] form
+# if :configure_option isn't set, it will use 'useflag' as configure option
+CPU_FEATURES="3dnow:amd3dnow altivec mmx mmxext"
+for i in ${CPU_FEATURES}; do
+ IUSE="${IUSE} ${i%:*}"
+done
+
+DEPEND=">=virtual/ffmpeg-0.10.2-r2"
+RDEPEND="${DEPEND}
+ !<media-video/libav-0.8.2-r2
+ !media-video/ffmpeg:0
+"
+
+src_configure() {
+ local myconf="${EXTRA_LIBPOSTPROC_CONF}"
+ for i in $(get-flag march) $(get-flag mcpu) $(get-flag mtune) ; do
+ [ "${i}" = "native" ] && i="host" # bug #273421
+ myconf="${myconf} --cpu=${i}"
+ break
+ done
+
+ if use pic ; then
+ myconf="${myconf} --enable-pic"
+ # disable asm code if PIC is required
+ # as the provided asm decidedly is not PIC for x86.
+ use x86 && myconf="${myconf} --disable-asm"
+ fi
+
+ # cross compile support
+ if tc-is-cross-compiler ; then
+ myconf="${myconf} --enable-cross-compile --arch=$(tc-arch-kernel) --cross-prefix=${CHOST}-"
+ case ${CHOST} in
+ *freebsd*)
+ myconf="${myconf} --target-os=freebsd"
+ ;;
+ mingw32*)
+ myconf="${myconf} --target-os=mingw32"
+ ;;
+ *linux*)
+ myconf="${myconf} --target-os=linux"
+ ;;
+ esac
+ fi
+
+ cd "${S}"
+ ./configure \
+ --prefix="${EPREFIX}/usr" \
+ --libdir="${EPREFIX}/usr/$(get_libdir)" \
+ --shlibdir="${EPREFIX}/usr/$(get_libdir)" \
+ --enable-shared \
+ --cc="$(tc-getCC)" \
+ --ar="$(tc-getAR)" \
+ --optflags="${CFLAGS}" \
+ --extra-cflags="${CFLAGS}" \
+ $(use_enable static-libs static) \
+ ${myconf} || die
+}