summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2014-01-18 12:18:36 +0000
committerAlexis Ballier <aballier@gentoo.org>2014-01-18 12:18:36 +0000
commite778afc7593cb8cc5eaf4459a0195870ddbe960a (patch)
tree3258f1173907374d7d41e905ad9e0cd874c062c7 /media-libs/sratom
parentAdd arm64 love. (diff)
downloadgentoo-2-e778afc7593cb8cc5eaf4459a0195870ddbe960a.tar.gz
gentoo-2-e778afc7593cb8cc5eaf4459a0195870ddbe960a.tar.bz2
gentoo-2-e778afc7593cb8cc5eaf4459a0195870ddbe960a.zip
version bump"
(Portage version: 2.2.8/cvs/Linux x86_64, signed Manifest commit with key 160F534A)
Diffstat (limited to 'media-libs/sratom')
-rw-r--r--media-libs/sratom/ChangeLog9
-rw-r--r--media-libs/sratom/sratom-0.4.4.ebuild41
2 files changed, 48 insertions, 2 deletions
diff --git a/media-libs/sratom/ChangeLog b/media-libs/sratom/ChangeLog
index fcc58b8f7953..f00599849911 100644
--- a/media-libs/sratom/ChangeLog
+++ b/media-libs/sratom/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-libs/sratom
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/sratom/ChangeLog,v 1.7 2013/02/21 10:13:24 aballier Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/sratom/ChangeLog,v 1.8 2014/01/18 12:18:36 aballier Exp $
+
+*sratom-0.4.4 (18 Jan 2014)
+
+ 18 Jan 2014; Alexis Ballier <aballier@gentoo.org> +sratom-0.4.4.ebuild:
+ version bump"
*sratom-0.4.2 (21 Feb 2013)
diff --git a/media-libs/sratom/sratom-0.4.4.ebuild b/media-libs/sratom/sratom-0.4.4.ebuild
new file mode 100644
index 000000000000..22585c9f5506
--- /dev/null
+++ b/media-libs/sratom/sratom-0.4.4.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/sratom/sratom-0.4.4.ebuild,v 1.1 2014/01/18 12:18:36 aballier Exp $
+
+EAPI=4
+
+inherit waf-utils
+
+DESCRIPTION="Library for serialising LV2 atoms to/from RDF, particularly the Turtle syntax"
+HOMEPAGE="http://drobilla.net/software/sratom/"
+SRC_URI="http://download.drobilla.net/${P}.tar.bz2"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="doc static-libs test"
+
+RDEPEND="media-libs/lv2
+ >=dev-libs/serd-0.14.0
+ >=dev-libs/sord-0.12.0"
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )
+ virtual/pkgconfig"
+
+DOCS=( "NEWS" "README" )
+
+src_prepare() {
+ sed -i -e 's/^.*run_ldconfig/#\0/' wscript || die
+}
+
+src_configure() {
+ waf-utils_src_configure \
+ --docdir=/usr/share/doc/${PF} \
+ $(use test && echo "--test") \
+ $(use doc && echo "--docs") \
+ $(use static-libs && echo "--static")
+}
+
+src_test() {
+ ./waf test || die
+}