summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2009-09-07 12:42:31 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2009-09-07 12:42:31 +0000
commitedf0ef3573b83fcd4446cf8250b2453f950ecd51 (patch)
tree22891f57773b03fa03a2a34004c27ba5d737d0d7 /media-sound/exaile
parentUse sane USE defaults, not every x86 is a sse one. (diff)
downloadgentoo-2-edf0ef3573b83fcd4446cf8250b2453f950ecd51.tar.gz
gentoo-2-edf0ef3573b83fcd4446cf8250b2453f950ecd51.tar.bz2
gentoo-2-edf0ef3573b83fcd4446cf8250b2453f950ecd51.zip
Remove USE doc wrt #283440.
(Portage version: 2.2_rc40/cvs/Linux x86_64)
Diffstat (limited to 'media-sound/exaile')
-rw-r--r--media-sound/exaile/ChangeLog7
-rw-r--r--media-sound/exaile/exaile-0.3.0.ebuild22
-rw-r--r--media-sound/exaile/exaile-0.3.0_alpha3-r1.ebuild80
-rw-r--r--media-sound/exaile/files/exaile-0.3.0_alpha3-Makefile.patch18
4 files changed, 12 insertions, 115 deletions
diff --git a/media-sound/exaile/ChangeLog b/media-sound/exaile/ChangeLog
index 508446fd0abe..1a965540a196 100644
--- a/media-sound/exaile/ChangeLog
+++ b/media-sound/exaile/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-sound/exaile
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/exaile/ChangeLog,v 1.61 2009/08/27 19:32:13 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/exaile/ChangeLog,v 1.62 2009/09/07 12:42:31 ssuominen Exp $
+
+ 07 Sep 2009; Samuli Suominen <ssuominen@gentoo.org>
+ -exaile-0.3.0_alpha3-r1.ebuild, exaile-0.3.0.ebuild,
+ -files/exaile-0.3.0_alpha3-Makefile.patch:
+ Remove USE doc wrt #283440.
*exaile-0.3.0 (27 Aug 2009)
diff --git a/media-sound/exaile/exaile-0.3.0.ebuild b/media-sound/exaile/exaile-0.3.0.ebuild
index 6af31d7de5ce..b6cc755887b4 100644
--- a/media-sound/exaile/exaile-0.3.0.ebuild
+++ b/media-sound/exaile/exaile-0.3.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/exaile/exaile-0.3.0.ebuild,v 1.1 2009/08/27 19:32:13 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/exaile/exaile-0.3.0.ebuild,v 1.2 2009/09/07 12:42:31 ssuominen Exp $
EAPI=2
inherit eutils fdo-mime multilib python
@@ -25,9 +25,8 @@ RDEPEND="dev-python/dbus-python
libsexy? ( dev-python/sexy-python )
hal? ( sys-apps/hal )
cddb? ( dev-python/cddb-py )"
-DEPEND="doc? ( dev-python/sphinx )
- nls? ( dev-util/intltool
- sys-devel/gettext )"
+DEPEND="nls? ( dev-util/intltool
+ sys-devel/gettext )"
src_prepare() {
epatch "${FILESDIR}"/${P}-Makefile.patch \
@@ -36,27 +35,18 @@ src_prepare() {
src_compile() {
if use nls; then
- emake locale || die "emake translations failed"
- fi
- if use doc; then
- cd doc
- emake html || die "emake html failed"
+ emake locale || die
fi
}
src_install() {
local _no_locale
-
use nls || _no_locale=_no_locale
emake PREFIX="/usr" LIBINSTALLDIR="/$(get_libdir)" DESTDIR="${D}" \
- install${_no_locale} || die "emake install failed"
+ install${_no_locale} || die
- dodoc README || die "dodoc failed"
-
- if use doc; then
- dohtml -r doc/_build/html/* || die "dohtml failed"
- fi
+ dodoc README
insinto /usr/share/exaile/data
doins -r data/migrations || die "doins failed"
diff --git a/media-sound/exaile/exaile-0.3.0_alpha3-r1.ebuild b/media-sound/exaile/exaile-0.3.0_alpha3-r1.ebuild
deleted file mode 100644
index 9014e8bc77a3..000000000000
--- a/media-sound/exaile/exaile-0.3.0_alpha3-r1.ebuild
+++ /dev/null
@@ -1,80 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/exaile/exaile-0.3.0_alpha3-r1.ebuild,v 1.1 2009/08/23 14:23:04 ssuominen Exp $
-
-EAPI=2
-inherit eutils fdo-mime multilib python
-
-MY_P=${P/_alpha/a}
-
-DESCRIPTION="a media player aiming to be similar to AmaroK, but for GTK+"
-HOMEPAGE="http://www.exaile.org"
-SRC_URI="http://www.exaile.org/files/${MY_P}.tar.gz"
-
-LICENSE="GPL-2 GPL-3"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~sparc ~x86"
-IUSE="cddb doc hal libnotify +libsexy nls"
-
-RDEPEND="dev-python/dbus-python
- >=media-libs/mutagen-1.10
- >=dev-python/pygtk-2.12
- >=dev-lang/python-2.5[sqlite]
- dev-python/gst-python:0.10
- media-libs/gst-plugins-good:0.10
- media-plugins/gst-plugins-meta:0.10
- libnotify? ( dev-python/notify-python )
- libsexy? ( dev-python/sexy-python )
- hal? ( sys-apps/hal )
- cddb? ( dev-python/cddb-py )"
-DEPEND="doc? ( dev-python/sphinx )
- nls? ( dev-util/intltool
- sys-devel/gettext )"
-
-S=${WORKDIR}/${PN}
-
-src_prepare() {
- epatch "${FILESDIR}"/${P}-Makefile.patch
-}
-
-src_compile() {
- if use nls; then
- emake translations || die "emake translations failed"
- fi
- if use doc; then
- cd doc
- emake html || die "emake html failed"
- fi
-}
-
-src_install() {
- local _no_locale
-
- use nls || _no_locale=_no_locale
-
- emake PREFIX="/usr" LIBINSTALLDIR="/$(get_libdir)" DESTDIR="${D}" \
- install${_no_locale} || die "emake install failed"
-
- dodoc crossfade_design FUTURE PLANNING player_planning \
- README SEARCHING || die "dodoc failed"
-
- if use doc; then
- dohtml -r doc/_build/html/* || die "dohtml failed"
- fi
-
- insinto /usr/share/exaile/data
- doins -r data/migrations || die "doins failed"
-}
-
-pkg_postinst() {
- python_need_rebuild
- python_mod_optimize /usr/$(get_libdir)/${PN}
- fdo-mime_desktop_database_update
- fdo-mime_mime_database_update
-}
-
-pkg_postrm() {
- python_mod_cleanup /usr/$(get_libdir)/${PN}
- fdo-mime_desktop_database_update
- fdo-mime_mime_database_update
-}
diff --git a/media-sound/exaile/files/exaile-0.3.0_alpha3-Makefile.patch b/media-sound/exaile/files/exaile-0.3.0_alpha3-Makefile.patch
deleted file mode 100644
index 70d2b49c24c6..000000000000
--- a/media-sound/exaile/files/exaile-0.3.0_alpha3-Makefile.patch
+++ /dev/null
@@ -1,18 +0,0 @@
-diff -ur exaile.orig/Makefile exaile/Makefile
---- exaile.orig/Makefile 2009-07-19 17:55:42.000000000 +0300
-+++ exaile/Makefile 2009-08-02 23:11:54.000000000 +0300
-@@ -49,11 +49,11 @@
- rm -f $(DESTDIR)$(PREFIX)/share/pixmaps/exaile.png
- cd plugins && make uninstall && cd ..
-
--install: make-install-dirs install-target locale
-+install: install-target locale
-
--install_no_locale: make-install-dirs install-target
-+install_no_locale: install-target
-
--install-target:
-+install-target: make-install-dirs
- install -m 644 exaile.py $(EXAILELIBDIR)
- -install -m 644 xl/*.py[co] $(EXAILELIBDIR)/xl
- install -m 644 xl/*.py $(EXAILELIBDIR)/xl