summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonnie Berkholz <dberkholz@gentoo.org>2006-10-12 19:02:51 +0000
committerDonnie Berkholz <dberkholz@gentoo.org>2006-10-12 19:02:51 +0000
commit7bafdf6121ed5957a21358d98bbc06af7abcd24b (patch)
tree068a11aa84d187efd0cb0496ec1b8d556b387d5e /sci-chemistry/shelx
parentBlock buddha-1.2 on >=ghc-6.4. buddha-1.2-r1 now requires >=ghc-6.4. (diff)
downloadgentoo-2-7bafdf6121ed5957a21358d98bbc06af7abcd24b.tar.gz
gentoo-2-7bafdf6121ed5957a21358d98bbc06af7abcd24b.tar.bz2
gentoo-2-7bafdf6121ed5957a21358d98bbc06af7abcd24b.zip
Add a patch to allow compilation with gfortran.
(Portage version: 2.1.2_pre2-r5)
Diffstat (limited to 'sci-chemistry/shelx')
-rw-r--r--sci-chemistry/shelx/ChangeLog6
-rw-r--r--sci-chemistry/shelx/files/20060317-gfortran.patch20
-rw-r--r--sci-chemistry/shelx/shelx-20060317.ebuild5
3 files changed, 28 insertions, 3 deletions
diff --git a/sci-chemistry/shelx/ChangeLog b/sci-chemistry/shelx/ChangeLog
index ae8696051f48..06fe3363632a 100644
--- a/sci-chemistry/shelx/ChangeLog
+++ b/sci-chemistry/shelx/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-chemistry/shelx
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/shelx/ChangeLog,v 1.5 2006/09/20 05:09:00 dberkholz Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/shelx/ChangeLog,v 1.6 2006/10/12 19:02:50 dberkholz Exp $
+
+ 12 Oct 2006; Donnie Berkholz <dberkholz@gentoo.org>;
+ +files/20060317-gfortran.patch, shelx-20060317.ebuild:
+ Add a patch to allow compilation with gfortran.
20 Sep 2006; Donnie Berkholz <dberkholz@gentoo.org>; metadata.xml:
(#148281) Change herd to sci-chemistry from sci.
diff --git a/sci-chemistry/shelx/files/20060317-gfortran.patch b/sci-chemistry/shelx/files/20060317-gfortran.patch
new file mode 100644
index 000000000000..d414a8e45c31
--- /dev/null
+++ b/sci-chemistry/shelx/files/20060317-gfortran.patch
@@ -0,0 +1,20 @@
+--- unix.orig/ciftab.f 2006-10-12 11:44:46.000000000 -0700
++++ unix/ciftab.f 2006-10-12 11:38:22.000000000 -0700
+@@ -377,7 +377,7 @@
+ C systems. It enables a 'read-only' file to be opened for reading.
+ C
+ OPEN(LR,FILE=CIFDIR(1:K)//'ciftab.'//IS(1:L),STATUS='OLD',
+- +READONLY,ERR=5)
++ +ERR=5)
+ GOTO 6
+ 4 WRITE(*,'(/A)')' ** Cannot open file **'
+ GOTO 108
+@@ -1332,7 +1332,7 @@
+ 6 FORMAT(3X,4('h k l Fo Fc s',5X),'h k l Fo Fc s',
+ +A1/A1)
+ 7 FORMAT(4(I4,2I3,2I5,I4,2X),I4,2I3,2I5,I4)
+- 8 FORMAT($,1X,A)
++ 8 FORMAT(1X,A,$)
+ C
+ WRITE(LO,1)' '//ESC//AMP//'l0o5c1x'//ESC//'(0u'//
+ +ESC//'(s0p16.66h8.5v0s0b0T'//CR
diff --git a/sci-chemistry/shelx/shelx-20060317.ebuild b/sci-chemistry/shelx/shelx-20060317.ebuild
index 97a2506375ba..a4d3b431da70 100644
--- a/sci-chemistry/shelx/shelx-20060317.ebuild
+++ b/sci-chemistry/shelx/shelx-20060317.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/shelx/shelx-20060317.ebuild,v 1.2 2006/06/17 00:56:16 spyderous Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/shelx/shelx-20060317.ebuild,v 1.3 2006/10/12 19:02:50 dberkholz Exp $
inherit autotools eutils fortran
@@ -19,7 +19,7 @@ RDEPEND=""
DEPEND="${RDEPEND}"
S="${WORKDIR}/${MY_P}"
-FORTRAN="ifc"
+FORTRAN="ifc gfortran"
pkg_nofetch() {
einfo "Go to ${HOMEPAGE}"
@@ -31,6 +31,7 @@ pkg_nofetch() {
src_unpack() {
unpack ${A}
epatch ${FILESDIR}/${PV}-autotool.patch
+ epatch ${FILESDIR}/${PV}-gfortran.patch
sed -i \
-e "s:CIFDIR='/usr/local/bin/':CIFDIR='${ROOT}usr/share/${PN}/':g" \