summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-08-06 13:05:31 +0000
committerJustin Lecher <jlec@gentoo.org>2015-08-06 13:05:31 +0000
commit793990566f9cd96235cd6f7f9fd60f15c5827c92 (patch)
tree32b55927835d5b77ae5c1c92feac00479ac89fcb /sci-libs
parentStable on alpha, bug 529460 (diff)
downloadgentoo-2-793990566f9cd96235cd6f7f9fd60f15c5827c92.tar.gz
gentoo-2-793990566f9cd96235cd6f7f9fd60f15c5827c92.tar.bz2
gentoo-2-793990566f9cd96235cd6f7f9fd60f15c5827c92.zip
Fix for format-security, bug #547082
Signed-off-by: Justin Lecher <jlec@gentoo.org> (Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key E9402A79B03529A2!)
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/cctbx/ChangeLog6
-rw-r--r--sci-libs/cctbx/cctbx-2010.03.29.2334-r7.ebuild5
-rw-r--r--sci-libs/cctbx/files/2010.03.29.2334-format-security.patch117
3 files changed, 125 insertions, 3 deletions
diff --git a/sci-libs/cctbx/ChangeLog b/sci-libs/cctbx/ChangeLog
index b2e804aa050d..aabcf24fba51 100644
--- a/sci-libs/cctbx/ChangeLog
+++ b/sci-libs/cctbx/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-libs/cctbx
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/cctbx/ChangeLog,v 1.38 2015/04/22 06:58:03 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/cctbx/ChangeLog,v 1.39 2015/08/06 13:05:31 jlec Exp $
+
+ 06 Aug 2015; Justin Lecher <jlec@gentoo.org>
+ +files/2010.03.29.2334-format-security.patch, cctbx-2010.03.29.2334-r7.ebuild:
+ Fix for format-security, bug #547082
22 Apr 2015; Justin Lecher <jlec@gentoo.org> -cctbx-2010.03.29.2334-r6.ebuild:
Drop old
diff --git a/sci-libs/cctbx/cctbx-2010.03.29.2334-r7.ebuild b/sci-libs/cctbx/cctbx-2010.03.29.2334-r7.ebuild
index bee0587fc4f9..5b77b3c5869e 100644
--- a/sci-libs/cctbx/cctbx-2010.03.29.2334-r7.ebuild
+++ b/sci-libs/cctbx/cctbx-2010.03.29.2334-r7.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/cctbx/cctbx-2010.03.29.2334-r7.ebuild,v 1.7 2015/04/21 17:50:14 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/cctbx/cctbx-2010.03.29.2334-r7.ebuild,v 1.8 2015/08/06 13:05:31 jlec Exp $
EAPI=5
@@ -61,7 +61,8 @@ src_prepare() {
"${FILESDIR}"/${PV}-flags.patch \
"${FILESDIR}"/${PV}-soname.patch \
"${FILESDIR}"/${PV}-gcc-4.6.patch \
- "${FILESDIR}"/${PV}-gcc-4.7.patch
+ "${FILESDIR}"/${PV}-gcc-4.7.patch \
+ "${FILESDIR}"/${PV}-format-security.patch
eprefixify "${MY_S}"/scitbx/libtbx_refresh.py
diff --git a/sci-libs/cctbx/files/2010.03.29.2334-format-security.patch b/sci-libs/cctbx/files/2010.03.29.2334-format-security.patch
new file mode 100644
index 000000000000..057c135f9953
--- /dev/null
+++ b/sci-libs/cctbx/files/2010.03.29.2334-format-security.patch
@@ -0,0 +1,117 @@
+ cctbx_sources/scitbx/lbfgsb/raw.h | 54 +++++++++++++++++++--------------------
+ 1 file changed, 27 insertions(+), 27 deletions(-)
+
+diff --git a/cctbx_sources/scitbx/lbfgsb/raw.h b/cctbx_sources/scitbx/lbfgsb/raw.h
+index 21afed7..5b15055 100644
+--- a/cctbx_sources/scitbx/lbfgsb/raw.h
++++ b/cctbx_sources/scitbx/lbfgsb/raw.h
+@@ -853,7 +853,7 @@ namespace raw {
+ if (iprint >= 99) {
+ printf(" LINE SEARCH%12d times; norm of step = %.15G\n",
+ iback, xstep);
+- printf(fmt_2001, iter,f,sbgnrm);
++ printf("%s %i %f %f", fmt_2001, iter,f,sbgnrm);
+ if (iprint > 100) {
+ write_ref1(" X =", x);
+ write_ref1(" G =", g);
+@@ -862,7 +862,7 @@ namespace raw {
+ else if (iprint > 0) {
+ int imod = iter % iprint;
+ if (imod == 0) {
+- printf(fmt_2001, iter,f,sbgnrm);
++ printf("%s %i %f %f", fmt_2001, iter,f,sbgnrm);
+ }
+ }
+ if (iprint >= 1) {
+@@ -967,9 +967,9 @@ namespace raw {
+ " 2 rounding error dominate computation.\n";
+ if (task.substr(0,5) == "ERROR") goto lbl_999;
+ if (iprint >= 0) {
+- printf(fmt_3003);
+- printf(fmt_3004);
+- printf(fmt_3005, n,iter,nfgv,nintol,nskip,nact,sbgnrm,f);
++ printf("%s", fmt_3003);
++ printf("%s", fmt_3004);
++ printf("%s %i %i %i %i %i %i %f %f", fmt_3005, n,iter,nfgv,nintol,nskip,nact,sbgnrm,f);
+ if (iprint >= 100) {
+ write_ref1(" X =", x);
+ }
+@@ -977,40 +977,40 @@ namespace raw {
+ }
+ lbl_999:
+ if (iprint >= 0) {
+- printf(fmt_3009, task.c_str());
++ printf("%s %s", fmt_3009, task.c_str());
+ if (info != 0) {
+- if (info == -1) printf(fmt_9011);
+- if (info == -2) printf(fmt_9012);
+- if (info == -3) printf(fmt_9013);
+- if (info == -4) printf(fmt_9014);
+- if (info == -5) printf(fmt_9015);
++ if (info == -1) printf("%s", fmt_9011);
++ if (info == -2) printf("%s", fmt_9012);
++ if (info == -3) printf("%s", fmt_9013);
++ if (info == -4) printf("%s", fmt_9014);
++ if (info == -5) printf("%s", fmt_9015);
+ if (info == -6) {
+ printf(" Input nbd(%12d) is invalid.\n", k);
+ }
+ if (info == -7) {
+ printf(" l(%12d) > u(%12d). No feasible solution.\n", k, k);
+ }
+- if (info == -8) printf(fmt_9018);
+- if (info == -9) printf(fmt_9019);
++ if (info == -8) printf("%s", fmt_9018);
++ if (info == -9) printf("%s", fmt_9019);
+ }
+- if (iprint >= 1) printf(fmt_3007, cachyt,sbtime,lnscht);
+- printf(fmt_3008, time);
++ if (iprint >= 1) printf("%s %f %f %f", fmt_3007, cachyt,sbtime,lnscht);
++ printf("%s %f", fmt_3008, time);
+ if (iprint >= 1) {
+ if (info == -4 || info == -9) {
+- printf(fmt_3002,
++ printf("%s %i %i %i %i %s %i %f %f", fmt_3002,
+ iter,nfgv,nint,nact,word.c_str(),iback,stp,xstep); // itfile
+ }
+- printf(fmt_3009, task.c_str()); // itfile
++ printf("%s %s", fmt_3009, task.c_str()); // itfile
+ if (info != 0) {
+- if (info == -1) printf(fmt_9011); // itfile
+- if (info == -2) printf(fmt_9012); // itfile
+- if (info == -3) printf(fmt_9013); // itfile
+- if (info == -4) printf(fmt_9014); // itfile
+- if (info == -5) printf(fmt_9015); // itfile
+- if (info == -8) printf(fmt_9018); // itfile
+- if (info == -9) printf(fmt_9019); // itfile
++ if (info == -1) printf("%s", fmt_9011); // itfile
++ if (info == -2) printf("%s", fmt_9012); // itfile
++ if (info == -3) printf("%s", fmt_9013); // itfile
++ if (info == -4) printf("%s", fmt_9014); // itfile
++ if (info == -5) printf("%s", fmt_9015); // itfile
++ if (info == -8) printf("%s", fmt_9018); // itfile
++ if (info == -9) printf("%s", fmt_9019); // itfile
+ }
+- printf(fmt_3008, time); // itfile
++ printf("%s %f", fmt_3008, time); // itfile
+ }
+ }
+ }
+@@ -3902,7 +3902,7 @@ namespace raw {
+ " refresh the lbfgs memory and restart the iteration.\n";
+ if (info != 0) {
+ // singular triangular system detected; refresh the lbfgs memory.
+- if(iprint >= 1) printf(fmt_1005);
++ if(iprint >= 1) printf("%s", fmt_1005);
+ info = 0;
+ col = 0;
+ head = 1;
+@@ -3968,7 +3968,7 @@ namespace raw {
+ if (info != 0) {
+ // singular triangular system detected;
+ // refresh the lbfgs memory and restart the iteration.
+- if(iprint >= 1) printf(fmt_1005);
++ if(iprint >= 1) printf("%s", fmt_1005);
+ info = 0;
+ col = 0;
+ head = 1;