summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2008-07-04 17:34:47 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2008-07-04 17:34:47 +0000
commit2267788c38a1fdc9f7089c15b14ed07424fb7785 (patch)
tree7a907eb9ceb0545c930e25de37eca58822422201 /sci-physics/camfr
parentStable for HPPA (bug #230567). (diff)
downloadgentoo-2-2267788c38a1fdc9f7089c15b14ed07424fb7785.tar.gz
gentoo-2-2267788c38a1fdc9f7089c15b14ed07424fb7785.tar.bz2
gentoo-2-2267788c38a1fdc9f7089c15b14ed07424fb7785.zip
Fixed a sed syntax errors and cleaned lapack again
(Portage version: 2.1.4.4)
Diffstat (limited to 'sci-physics/camfr')
-rw-r--r--sci-physics/camfr/ChangeLog6
-rw-r--r--sci-physics/camfr/camfr-20070717.ebuild12
2 files changed, 13 insertions, 5 deletions
diff --git a/sci-physics/camfr/ChangeLog b/sci-physics/camfr/ChangeLog
index eec5f806f443..10e130eaadaf 100644
--- a/sci-physics/camfr/ChangeLog
+++ b/sci-physics/camfr/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-physics/camfr
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-physics/camfr/ChangeLog,v 1.8 2008/07/02 13:51:49 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/camfr/ChangeLog,v 1.9 2008/07/04 17:34:47 bicatali Exp $
+
+ 04 Jul 2008; Sébastien Fabbro <bicatali@gentoo.org>
+ camfr-20070717.ebuild:
+ Fixed a sed syntax errors and cleaned lapack again
02 Jul 2008; Sébastien Fabbro <bicatali@gentoo.org>
+files/camfr-20070717-gcc43.patch, camfr-20070717.ebuild:
diff --git a/sci-physics/camfr/camfr-20070717.ebuild b/sci-physics/camfr/camfr-20070717.ebuild
index 363439298a1c..c30934ea327b 100644
--- a/sci-physics/camfr/camfr-20070717.ebuild
+++ b/sci-physics/camfr/camfr-20070717.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-physics/camfr/camfr-20070717.ebuild,v 1.2 2008/07/02 13:51:49 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/camfr/camfr-20070717.ebuild,v 1.3 2008/07/04 17:34:47 bicatali Exp $
inherit eutils distutils fortran
@@ -45,10 +45,14 @@ src_unpack() {
sed -i -e '/^library_dirs/d' -e '/^libs/d' machine_cfg.py || die
local lapack_libs=
for x in $(pkg-config --libs-only-l lapack); do
- lapack_libs="${lapack_libs}, \"${x/-l/}\""
+ lapack_libs="${lapack_libs}, \"${x#-l}\""
+ done
+ local lapack_libdirs=
+ for x in $(pkg-config --libs-only-L lapack); do
+ lapack_libdirs="${lapack_libdirs}, \"${x#-L}\""
done
cat <<-EOF >> machine_cfg.py
- library_dirs = ["$(pkg-config --libs-only-L lapack | sed -e 's/-L/')"]
+ library_dirs = [${lapack_libdirs}]
libs = ["boost_python", "blitz"${lapack_libs}]
EOF
}
@@ -57,7 +61,7 @@ src_test() {
# trick to avoid X in testing (bug #229753)
echo "backend : Agg" > matplotlibrc
PYTHONPATH=".:visualisation" ${python} testsuite/camfr_test.py \
-qq || die "tests failed"
+ || die "tests failed"
rm -f matplotlibrc
}