summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Bienstman <pbienst@gentoo.org>2007-08-21 20:39:12 +0000
committerPeter Bienstman <pbienst@gentoo.org>2007-08-21 20:39:12 +0000
commitace7c8259d6bfb5630bd843f2794c103ae0c5921 (patch)
tree0d95a56631881c099f139703d508c50f93da200a /sci-physics/camfr
parentDrop old version. (diff)
downloadgentoo-2-ace7c8259d6bfb5630bd843f2794c103ae0c5921.tar.gz
gentoo-2-ace7c8259d6bfb5630bd843f2794c103ae0c5921.tar.bz2
gentoo-2-ace7c8259d6bfb5630bd843f2794c103ae0c5921.zip
Version bump.
(Portage version: 2.1.2.12)
Diffstat (limited to 'sci-physics/camfr')
-rw-r--r--sci-physics/camfr/ChangeLog7
-rw-r--r--sci-physics/camfr/camfr-20070717.ebuild56
-rw-r--r--sci-physics/camfr/files/digest-camfr-200707173
3 files changed, 65 insertions, 1 deletions
diff --git a/sci-physics/camfr/ChangeLog b/sci-physics/camfr/ChangeLog
index 67c5d321eb52..d22f2196de6f 100644
--- a/sci-physics/camfr/ChangeLog
+++ b/sci-physics/camfr/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-physics/camfr
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-physics/camfr/ChangeLog,v 1.5 2007/03/23 14:22:46 pbienst Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/camfr/ChangeLog,v 1.6 2007/08/21 20:39:12 pbienst Exp $
+
+*camfr-20070717 (21 Aug 2007)
+
+ 21 Aug 2007; <pbienst@gentoo.org> +camfr-20070717.ebuild:
+ Version bump.
23 Mar 2007; <pbienst@gentoo.org> ChangeLog:
Fix boost patch.
diff --git a/sci-physics/camfr/camfr-20070717.ebuild b/sci-physics/camfr/camfr-20070717.ebuild
new file mode 100644
index 000000000000..26a7199baeaf
--- /dev/null
+++ b/sci-physics/camfr/camfr-20070717.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/camfr/camfr-20070717.ebuild,v 1.1 2007/08/21 20:39:12 pbienst Exp $
+
+inherit eutils distutils fortran python
+
+DESCRIPTION="Full vectorial Maxwell solver based on eigenmode expansion"
+HOMEPAGE="http://camfr.sourceforge.net/"
+SRC_URI="mirror://sourceforge/camfr/${P}.tgz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="virtual/python
+ dev-python/numpy
+ sci-libs/scipy
+ >=dev-python/matplotlib-0.90.1
+ >=dev-libs/boost-1.30.2
+ >=dev-python/imaging-1.1.4
+ dev-libs/blitz
+ virtual/lapack"
+
+DEPEND="${RDEPEND}
+ dev-util/scons"
+
+FORTAN="gfortran g77"
+
+S=${WORKDIR}/${P/-/_}
+
+pkg_setup() {
+ if ! built_with_use dev-lang/python tk \
+ || ! built_with_use dev-python/imaging tk ; then
+ eerror "Python and/or imaging don't have Tk support enabled."
+ eerror "Set the tk USE flag and reinstall python and imaging before continuing."
+ die
+ fi
+ fortran_pkg_setup
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ cp machine_cfg.py{.gentoo,} || die
+}
+
+src_test() {
+ PYTHONPATH=.:visualisation ${python} testsuite/camfr_test.py \
+ || die "tests failed"
+}
+
+src_install() {
+ distutils_src_install
+ dodoc docs/camfr.pdf || die
+}
diff --git a/sci-physics/camfr/files/digest-camfr-20070717 b/sci-physics/camfr/files/digest-camfr-20070717
new file mode 100644
index 000000000000..4fc876d1f1da
--- /dev/null
+++ b/sci-physics/camfr/files/digest-camfr-20070717
@@ -0,0 +1,3 @@
+MD5 3858d6b9e3be29aa3981c2b4fe595fe2 camfr-20070717.tgz 763070
+RMD160 4e4237188caecd4dca3980b9cab381479e6382bc camfr-20070717.tgz 763070
+SHA256 f675ba7d58947076c0679c8760c9282e2efc82828bec67de90567fd8a4f135de camfr-20070717.tgz 763070