summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2012-01-21 19:23:26 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2012-01-21 19:23:26 +0000
commit9d44a8dedb10bfccabee9b3032434849a76fb8a5 (patch)
tree32034f678de94da24afcbe592074678580b7bcb2 /sci-physics/root
parentImport root ebuild from the science overlay. Main work from Andrew Savchenko,... (diff)
downloadgentoo-2-9d44a8dedb10bfccabee9b3032434849a76fb8a5.tar.gz
gentoo-2-9d44a8dedb10bfccabee9b3032434849a76fb8a5.tar.bz2
gentoo-2-9d44a8dedb10bfccabee9b3032434849a76fb8a5.zip
Import root ebuild from the science overlay. Main work from Andrew Savchenko, now proxy-maintainer
(Portage version: 2.1.10.41/cvs/Linux x86_64)
Diffstat (limited to 'sci-physics/root')
-rw-r--r--sci-physics/root/ChangeLog7
-rw-r--r--sci-physics/root/files/proofd.initd4
-rw-r--r--sci-physics/root/files/root-5.32.00-afs.patch33
-rw-r--r--sci-physics/root/files/root-5.32.00-cfitsio.patch13
-rw-r--r--sci-physics/root/files/root-5.32.00-nobyte-compile.patch137
-rw-r--r--sci-physics/root/files/rootd.initd4
6 files changed, 192 insertions, 6 deletions
diff --git a/sci-physics/root/ChangeLog b/sci-physics/root/ChangeLog
index a1c4e2535dc6..a05c2b93bcea 100644
--- a/sci-physics/root/ChangeLog
+++ b/sci-physics/root/ChangeLog
@@ -1,11 +1,14 @@
# ChangeLog for sci-physics/root
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-physics/root/ChangeLog,v 1.91 2012/01/21 19:19:46 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/root/ChangeLog,v 1.92 2012/01/21 19:23:26 bicatali Exp $
+
*root-5.32.00-r2 (21 Jan 2012)
21 Jan 2012; Sébastien Fabbro <bicatali@gentoo.org> +root-5.32.00-r2.ebuild,
- metadata.xml:
+ +files/root-5.32.00-afs.patch, +files/root-5.32.00-cfitsio.patch,
+ +files/root-5.32.00-nobyte-compile.patch, files/proofd.initd,
+ files/rootd.initd, metadata.xml:
Import root ebuild from the science overlay. Main work from Andrew Savchenko,
now proxy-maintainer
diff --git a/sci-physics/root/files/proofd.initd b/sci-physics/root/files/proofd.initd
index c34a51ccae28..7fc275a45cd9 100644
--- a/sci-physics/root/files/proofd.initd
+++ b/sci-physics/root/files/proofd.initd
@@ -1,7 +1,7 @@
#!/sbin/runscript
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-physics/root/files/proofd.initd,v 1.2 2009/01/20 18:04:09 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/root/files/proofd.initd,v 1.3 2012/01/21 19:23:26 bicatali Exp $
depend() {
need root-file-server
diff --git a/sci-physics/root/files/root-5.32.00-afs.patch b/sci-physics/root/files/root-5.32.00-afs.patch
new file mode 100644
index 000000000000..2bf31798e6e0
--- /dev/null
+++ b/sci-physics/root/files/root-5.32.00-afs.patch
@@ -0,0 +1,33 @@
+--- root/net/auth/src/TAFS.cxx.orig 2011-12-04 00:56:29.405007770 +0400
++++ root/net/auth/src/TAFS.cxx 2011-12-04 00:56:35.534709259 +0400
+@@ -138,7 +138,7 @@
+ } else {
+ if (isatty(0) != 0 && isatty(1) != 0) {
+ Gl_config("noecho", 1);
+- pw = Getline((char *) prompt.Data());
++ pw = const_cast<char *>( Getline((char *) prompt.Data()) );
+ Gl_config("noecho", 0);
+ } else {
+ Warning("TAFS", "not tty: cannot prompt for passwd: failure");
+--- root/core/clib/src/strlcat.c.orig 2011-12-04 01:49:26.495179487 +0400
++++ root/core/clib/src/strlcat.c 2011-12-04 01:50:41.407524763 +0400
+@@ -38,7 +38,7 @@
+ * Returns strlen(src) + MIN(siz, strlen(initial dst)).
+ * If retval >= siz, truncation occurred.
+ */
+-size_t
++size_t __attribute__((weak))
+ strlcat(char *dst, const char *src, size_t siz)
+ {
+ register char *d = dst;
+--- root/core/clib/src/strlcpy.c.orig 2011-12-04 01:49:34.329797251 +0400
++++ root/core/clib/src/strlcpy.c 2011-12-04 01:50:49.051151843 +0400
+@@ -36,7 +36,7 @@
+ * will be copied. Always NUL terminates (unless siz == 0).
+ * Returns strlen(src); if retval >= siz, truncation occurred.
+ */
+-size_t
++size_t __attribute__((weak))
+ strlcpy(char *dst, const char *src, size_t siz)
+ {
+ register char *d = dst;
diff --git a/sci-physics/root/files/root-5.32.00-cfitsio.patch b/sci-physics/root/files/root-5.32.00-cfitsio.patch
new file mode 100644
index 000000000000..853c3f39f207
--- /dev/null
+++ b/sci-physics/root/files/root-5.32.00-cfitsio.patch
@@ -0,0 +1,13 @@
+--- configure.orig 2012-01-19 23:44:44.127607638 +0100
++++ configure 2012-01-20 00:19:20.420652913 +0100
+@@ -3435,9 +3435,7 @@
+ cfitsioinc=$found_hdr
+ cfitsioincdir=$found_dir
+
+- # At this time, libcfitsio.a should always be prefered over .so,
+- # to avoid forcing users to install cfitsio.
+- check_library "libcfitsio cfitsio" "no" "$cfitsiolibdir" \
++ check_library "libcfitsio cfitsio" "yes" "$cfitsiolibdir" \
+ $CFITSIO ${CFITSIO:+$CFITSIO/lib} ${CFITSIO:+$CFITSIO/.libs} \
+ ${finkdir:+$finkdir/lib} \
+ /usr/local/lib /usr/lib /opt/cfitsio/lib
diff --git a/sci-physics/root/files/root-5.32.00-nobyte-compile.patch b/sci-physics/root/files/root-5.32.00-nobyte-compile.patch
new file mode 100644
index 000000000000..179e5790cc36
--- /dev/null
+++ b/sci-physics/root/files/root-5.32.00-nobyte-compile.patch
@@ -0,0 +1,137 @@
+diff -Naur root.as-needed/Makefile root/Makefile
+--- root.as-needed/Makefile 2011-07-10 10:42:49.758191296 +0400
++++ root/Makefile 2011-07-10 10:43:21.493339703 +0400
+@@ -1167,10 +1167,7 @@
+ if test "x$(RFLX_GRFLXPY)" != "x"; then \
+ rm -f $(DESTDIR)$(LIBDIR)/$(RFLX_GRFLXPY); \
+ fi; \
+- if test "x$(RFLX_GRFLXPYC)" != "x"; then \
+- rm -f $(DESTDIR)$(LIBDIR)/$(RFLX_GRFLXPYC); \
+- fi; \
+- if test "x$(RFLX_GRFLXPY)$(RFLX_GRFLXPYC)" != "x"; then \
++ if test "x$(RFLX_GRFLXPY)" != "x"; then \
+ dir=$(RFLX_GRFLXDD:lib/=); \
+ while test "x$${dir}" != "x" && \
+ test -d $(DESTDIR)$(LIBDIR)/$${dir} && \
+diff -Naur root.as-needed/bindings/pyroot/Module.mk root/bindings/pyroot/Module.mk
+--- root.as-needed/bindings/pyroot/Module.mk 2011-07-10 10:42:48.991561304 +0400
++++ root/bindings/pyroot/Module.mk 2011-07-10 10:43:21.493339703 +0400
+@@ -48,8 +48,6 @@
+ ROOTPY := $(subst $(MODDIR),$(LPATH),$(ROOTPYS))
+ $(LPATH)/%.py: $(MODDIR)/%.py; cp $< $@
+ endif
+-ROOTPYC := $(ROOTPY:.py=.pyc)
+-ROOTPYO := $(ROOTPY:.py=.pyo)
+
+ # used in the main Makefile
+ ALLHDRS += $(patsubst $(MODDIRI)/%.h,include/%.h,$(PYROOTH))
+@@ -68,10 +66,8 @@
+ include/%.h: $(PYROOTDIRI)/%.h
+ cp $< $@
+
+-%.pyc: %.py; python -c 'import py_compile; py_compile.compile( "$<" )'
+-%.pyo: %.py; python -O -c 'import py_compile; py_compile.compile( "$<" )'
+
+-$(PYROOTLIB): $(PYROOTO) $(PYROOTDO) $(ROOTPY) $(ROOTPYC) $(ROOTPYO) \
++$(PYROOTLIB): $(PYROOTO) $(PYROOTDO) $(ROOTPY) \
+ $(ROOTLIBSDEP) $(PYTHONLIBDEP)
+ @$(MAKELIB) $(PLATFORM) $(LD) "$(LDFLAGS)" \
+ "$(SOFLAGS)" libPyROOT.$(SOEXT) $@ \
+@@ -113,7 +109,7 @@
+
+ distclean-$(MODNAME): clean-$(MODNAME)
+ @rm -f $(PYROOTDEP) $(PYROOTDS) $(PYROOTDH) $(PYROOTLIB) \
+- $(ROOTPY) $(ROOTPYC) $(ROOTPYO) $(PYROOTMAP) \
++ $(ROOTPY) $(PYROOTMAP) \
+ $(PYROOTPYD) $(PYTHON64DEP) $(PYTHON64)
+
+ distclean:: distclean-$(MODNAME)
+diff -Naur root.as-needed/build/package/debian/rules root/build/package/debian/rules
+--- root.as-needed/build/package/debian/rules 2011-07-10 10:42:49.241549346 +0400
++++ root/build/package/debian/rules 2011-07-10 10:48:06.989670589 +0400
+@@ -691,10 +691,6 @@
+ -X$(SYSCONFDIR)/root/system.rootauthrc \
+ -X$(SYSCONFDIR)/root/system.rootdaemonrc \
+ -X$(PREFIX)/lib/root/$(SOVERS)/libAfterImage.a \
+- -X$(PREFIX)/lib/root/$(SOVERS)/PyCintex.pyc \
+- -X$(PREFIX)/lib/root/$(SOVERS)/PyCintex.pyo \
+- -X$(PREFIX)/lib/root/$(SOVERS)/ROOT.pyc \
+- -X$(PREFIX)/lib/root/$(SOVERS)/ROOT.pyo \
+ -X$(PREFIX)/lib/root/$(SOVERS)/cint7 \
+ -X$(PREFIX)/include/root/Minuit2
+ # $(foreach i, \
+diff -Naur root.as-needed/cint/cintex/Module.mk root/cint/cintex/Module.mk
+--- root.as-needed/cint/cintex/Module.mk 2011-07-10 10:42:49.104889217 +0400
++++ root/cint/cintex/Module.mk 2011-07-10 10:43:21.496672876 +0400
+@@ -31,10 +31,6 @@
+ CINTEXPY := $(subst $(MODDIR)/python,$(LPATH),$(CINTEXPYS))
+ $(LPATH)/%.py: $(MODDIR)/python/%.py; cp $< $@
+ endif
+-ifneq ($(BUILDPYTHON),no)
+-CINTEXPYC := $(CINTEXPY:.py=.pyc)
+-CINTEXPYO := $(CINTEXPY:.py=.pyo)
+-endif
+
+ # used in the main Makefile
+ ALLHDRS += $(patsubst $(MODDIRI)/Cintex/%.h,include/Cintex/%.h,$(CINTEXH))
+@@ -86,8 +82,6 @@
+ fi)
+ cp $< $@
+
+-%.pyc: %.py; python -c 'import py_compile; py_compile.compile( "$<" )'
+-%.pyo: %.py; python -O -c 'import py_compile; py_compile.compile( "$<" )'
+
+ $(CINTEXLIB): $(CINTEXO) $(CINTEXPY) $(CINTEXPYC) $(CINTEXPYO) \
+ $(ORDER_) $(subst $(CINTEXLIB),,$(MAINLIBS)) $(CINTEXLIBDEP)
+diff -Naur root.as-needed/cint/reflex/Module.mk root/cint/reflex/Module.mk
+--- root.as-needed/cint/reflex/Module.mk 2011-07-10 10:42:49.074890651 +0400
++++ root/cint/reflex/Module.mk 2011-07-10 10:43:21.496672876 +0400
+@@ -48,9 +48,6 @@
+ RFLX_GRFLXS := $(wildcard $(RFLX_GRFLXSD)/*.py)
+ RFLX_GRFLXPY := $(patsubst $(RFLX_GRFLXSD)/%.py,$(RFLX_GRFLXDD)/%.py,$(RFLX_GRFLXS))
+ RFLX_GRFLXPY += $(RFLX_GCCXMLPATHPY)
+-ifneq ($(BUILDPYTHON),no)
+-RFLX_GRFLXPYC := $(subst .py,.pyc,$(RFLX_GRFLXPY))
+-endif
+
+ RFLX_LIBDIR = $(LIBDIR)
+
+@@ -92,7 +89,7 @@
+
+ ALLEXECS += $(RFLX_GENMAPX)
+
+-POSTBIN += $(RFLX_GRFLXPYC) $(RFLX_GRFLXPY)
++POSTBIN += $(RFLX_GRFLXPY)
+
+ ##### local rules #####
+ .PHONY: all-$(MODNAME) clean-$(MODNAME) distclean-$(MODNAME) \
+@@ -122,8 +119,6 @@
+ mkdir -p lib/python/genreflex; fi )
+ cp $< $@
+
+-$(RFLX_GRFLXDD)/%.pyc: $(RFLX_GRFLXDD)/%.py
+- @python -c 'import py_compile; py_compile.compile( "$<" )'
+
+ $(RFLX_GENMAPO) : CXXFLAGS += -I$(REFLEXDIRS)/genmap
+
+@@ -149,7 +144,7 @@
+ $(RLIBMAP) -o $@ -l $(REFLEXDICTLIB) \
+ -d $(REFLEXDICTLIBDEPM) -c $(REFLEXL)
+
+-all-$(MODNAME): $(REFLEXLIB) $(REFLEXDICTLIB) $(REFLEXDICTMAP) $(RFLX_GRFLXPYC) $(RFLX_GRFLXPY)
++all-$(MODNAME): $(REFLEXLIB) $(REFLEXDICTLIB) $(REFLEXDICTMAP) $(RFLX_GRFLXPY)
+
+ clean-genreflex:
+ @rm -rf lib/python/genreflex
+diff -Naur root.as-needed/cint/reflex/python/CMakeLists.txt root/cint/reflex/python/CMakeLists.txt
+--- root.as-needed/cint/reflex/python/CMakeLists.txt 2011-07-10 10:42:49.074890651 +0400
++++ root/cint/reflex/python/CMakeLists.txt 2011-07-10 10:43:21.496672876 +0400
+@@ -15,7 +15,7 @@
+ ##################### sources ####################
+
+ FILE(GLOB_RECURSE GENREFLEX_SRCS RELATIVE ${CMAKE_CURRENT_SOURCE_DIR} genreflex/*.py)
+-SET(GENREFLEX_SCRIPT ${CMAKE_CURRENT_BINARY_DIR}/genreflex/genreflex.pyc PARENT_SCOPE)
++SET(GENREFLEX_SCRIPT PARENT_SCOPE)
+
+ ##################### gccxmlpath ####################
+
diff --git a/sci-physics/root/files/rootd.initd b/sci-physics/root/files/rootd.initd
index 72dccb559ff6..14c0d8e1c159 100644
--- a/sci-physics/root/files/rootd.initd
+++ b/sci-physics/root/files/rootd.initd
@@ -1,7 +1,7 @@
#!/sbin/runscript
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-physics/root/files/rootd.initd,v 1.2 2009/01/20 18:04:09 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/root/files/rootd.initd,v 1.3 2012/01/21 19:23:26 bicatali Exp $
depend() {
need net