summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2013-05-10 02:47:10 +0000
committerMatthew Thode <prometheanfire@gentoo.org>2013-05-10 02:47:10 +0000
commit9667c196d6b9ea211ea647ca8f1d71ae908982b3 (patch)
treee252ba7a529c1b02357920c43dbae01ae9c10136 /sys-auth
parentupdate to latest openstack glance releases 2012.2.4 and 2013.1.1 (diff)
downloadgentoo-2-9667c196d6b9ea211ea647ca8f1d71ae908982b3.tar.gz
gentoo-2-9667c196d6b9ea211ea647ca8f1d71ae908982b3.tar.bz2
gentoo-2-9667c196d6b9ea211ea647ca8f1d71ae908982b3.zip
update to latest openstack keystone releases 2012.2.4 and 2013.1.1
(Portage version: 2.1.11.55/cvs/Linux x86_64, signed Manifest commit with key 0x2471eb3e40ac5ac3)
Diffstat (limited to 'sys-auth')
-rw-r--r--sys-auth/keystone/ChangeLog10
-rw-r--r--sys-auth/keystone/keystone-2012.2.4.ebuild (renamed from sys-auth/keystone/keystone-2012.2.3-r2.ebuild)8
-rw-r--r--sys-auth/keystone/keystone-2013.1.1.ebuild90
3 files changed, 102 insertions, 6 deletions
diff --git a/sys-auth/keystone/ChangeLog b/sys-auth/keystone/ChangeLog
index 58ee084f4b0f..9057ae3ff554 100644
--- a/sys-auth/keystone/ChangeLog
+++ b/sys-auth/keystone/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for sys-auth/keystone
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-auth/keystone/ChangeLog,v 1.14 2013/05/06 15:57:35 prometheanfire Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/keystone/ChangeLog,v 1.15 2013/05/10 02:47:10 prometheanfire Exp $
+
+*keystone-2012.2.4 (10 May 2013)
+*keystone-2013.1.1 (10 May 2013)
+
+ 10 May 2013; Matthew Thode <prometheanfire@gentoo.org>
+ +keystone-2012.2.4.ebuild, +keystone-2013.1.1.ebuild,
+ -keystone-2012.2.3-r2.ebuild:
+ update to latest openstack keystone releases 2012.2.4 and 2013.1.1
*keystone-2013.1-r1 (06 May 2013)
diff --git a/sys-auth/keystone/keystone-2012.2.3-r2.ebuild b/sys-auth/keystone/keystone-2012.2.4.ebuild
index 2c2a6eb9c1d7..ccde2c02c823 100644
--- a/sys-auth/keystone/keystone-2012.2.3-r2.ebuild
+++ b/sys-auth/keystone/keystone-2012.2.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-auth/keystone/keystone-2012.2.3-r2.ebuild,v 1.1 2013/03/20 17:17:08 prometheanfire Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/keystone/keystone-2012.2.4.ebuild,v 1.1 2013/05/10 02:47:10 prometheanfire Exp $
EAPI=5
#test restricted becaues of bad requirements given (old webob for instance)
@@ -69,10 +69,8 @@ RDEPEND="${DEPEND}
# "${PYTHON}" setup.py nosetests || die
#}
-PATCHES=( "${FILESDIR}/keystone-CVE-2013-0270.patch"
- "${FILESDIR}/keystone-CVE-2013-0282.patch"
- "${FILESDIR}/keystone-CVE-2013-1664_1665.patch"
- "${FILESDIR}/keystone-folsom-3-CVE-2013-1865.patch" )
+PATCHES=(
+)
python_install() {
distutils-r1_python_install
diff --git a/sys-auth/keystone/keystone-2013.1.1.ebuild b/sys-auth/keystone/keystone-2013.1.1.ebuild
new file mode 100644
index 000000000000..1ca41972fcde
--- /dev/null
+++ b/sys-auth/keystone/keystone-2013.1.1.ebuild
@@ -0,0 +1,90 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/keystone/keystone-2013.1.1.ebuild,v 1.1 2013/05/10 02:47:10 prometheanfire Exp $
+
+EAPI=5
+#test restricted becaues of bad requirements given (old webob for instance)
+RESTRICT="test"
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Keystone is the Openstack authentication, authorization, and
+service catalog written in Python."
+HOMEPAGE="https://launchpad.net/keystone"
+SRC_URI="http://launchpad.net/${PN}/grizzly/${PV}/+download/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="folsom"
+KEYWORDS="~amd64 ~x86"
+IUSE="+sqlite mysql postgres ldap"
+#IUSE="+sqlite mysql postgres ldap test"
+REQUIRED_USE="|| ( ldap mysql postgres sqlite )"
+
+#todo, seperate out rdepend via use flags
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}
+ dev-python/eventlet[${PYTHON_USEDEP}]
+ dev-python/greenlet[${PYTHON_USEDEP}]
+ >=dev-python/iso8601-0.1.4[${PYTHON_USEDEP}]
+ >=dev-python/python-keystoneclient-0.2.1[${PYTHON_USEDEP}]
+ <=dev-python/python-keystoneclient-0.3[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+ >=dev-python/oslo-config-1.1.0[${PYTHON_USEDEP}]
+ dev-python/passlib[${PYTHON_USEDEP}]
+ dev-python/paste[${PYTHON_USEDEP}]
+ dev-python/pastedeploy[${PYTHON_USEDEP}]
+ dev-python/python-daemon
+ >=dev-python/python-pam-0.1.4[${PYTHON_USEDEP}]
+ dev-python/routes[${PYTHON_USEDEP}]
+ >=dev-python/sqlalchemy-migrate-0.7.2
+ =dev-python/webob-1.2.3-r1[${PYTHON_USEDEP}]
+ virtual/python-argparse[${PYTHON_USEDEP}]
+ sqlite? ( >=dev-python/sqlalchemy-0.7.8[sqlite]
+ <=dev-python/sqlalchemy-0.7.9[sqlite] )
+ mysql? ( >=dev-python/sqlalchemy-0.7.8[mysql]
+ <=dev-python/sqlalchemy-0.7.9[mysql] )
+ postgres? ( >=dev-python/sqlalchemy-0.7.8[postgres]
+ <=dev-python/sqlalchemy-0.7.9[postgres] )
+ ldap? ( dev-python/python-ldap[${PYTHON_USEDEP}] )"
+# test? ( dev-python/Babel
+# dev-python/decorator
+# dev-python/eventlet
+# dev-python/greenlet
+# dev-python/httplib2
+# dev-python/iso8601
+# dev-python/lxml
+# dev-python/netifaces
+# dev-python/nose
+# dev-python/nosexcover
+# dev-python/passlib
+# dev-python/paste
+# dev-python/pastedeploy
+# dev-python/python-pam
+# dev-python/repoze-lru
+# dev-python/routes
+# dev-python/sphinx
+# >=dev-python/sqlalchemy-migrate-0.7
+# dev-python/tempita
+# >=dev-python/webob-1.0.8
+# dev-python/webtest
+# )
+PATCHES=(
+)
+#
+#python_test() {
+# "${PYTHON}" setup.py nosetests || die
+#}
+
+python_install() {
+ distutils-r1_python_install
+ newconfd "${FILESDIR}/keystone.confd" keystone
+ newinitd "${FILESDIR}/keystone.initd" keystone
+
+ diropts -m 0750
+ dodir /var/run/keystone /var/log/keystone /etc/keystone
+ keepdir /etc/keystone
+ insinto /etc/keystone
+ doins etc/keystone.conf.sample etc/logging.conf.sample
+ doins etc/default_catalog.templates etc/policy.json
+}