summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-vcs/vcsh')
-rw-r--r--dev-vcs/vcsh/ChangeLog9
-rw-r--r--dev-vcs/vcsh/vcsh-1.20150502.ebuild40
2 files changed, 47 insertions, 2 deletions
diff --git a/dev-vcs/vcsh/ChangeLog b/dev-vcs/vcsh/ChangeLog
index 65f58675996b..4a7b8039899a 100644
--- a/dev-vcs/vcsh/ChangeLog
+++ b/dev-vcs/vcsh/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-vcs/vcsh
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/vcsh/ChangeLog,v 1.11 2014/11/11 23:38:35 tamiko Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/vcsh/ChangeLog,v 1.12 2015/05/10 10:21:40 tamiko Exp $
+
+*vcsh-1.20150502 (10 May 2015)
+
+ 10 May 2015; Matthias Maier <tamiko@gentoo.org> +vcsh-1.20150502.ebuild:
+ version bump; bug #548794; thanks to Austin M. Matherne
*vcsh-1.20141026 (11 Nov 2014)
diff --git a/dev-vcs/vcsh/vcsh-1.20150502.ebuild b/dev-vcs/vcsh/vcsh-1.20150502.ebuild
new file mode 100644
index 000000000000..73b2ff674dbe
--- /dev/null
+++ b/dev-vcs/vcsh/vcsh-1.20150502.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/vcsh/vcsh-1.20150502.ebuild,v 1.1 2015/05/10 10:21:40 tamiko Exp $
+
+EAPI=5
+
+DESCRIPTION='Manage config files in $HOME via fake bare git repositories'
+HOMEPAGE="https://github.com/RichiH/vcsh/"
+SRC_URI="http://github.com/RichiH/vcsh/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="|| ( GPL-3 GPL-2 )"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-vcs/git"
+DEPEND=""
+
+DOCS=( changelog README.md CONTRIBUTORS )
+
+src_prepare() {
+ default
+ sed -i \
+ -e 's,vendor-completions,site-functions,' \
+ -e "s,\(\$(DOCDIR_PREFIX)\)/\$(self),\1/${PF}," \
+ Makefile || die "sed failed"
+
+ # remove dysfunctional tests
+ sed -i -e 's,install: all,install:,' \
+ Makefile || die "sed failed"
+}
+
+src_compile() {
+ :
+}
+
+src_install() {
+ default
+ dodoc -r doc/sample_hooks
+}