summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs/vtk/files/vtk-6.3.0-xdmf3-libxml2.patch')
-rw-r--r--sci-libs/vtk/files/vtk-6.3.0-xdmf3-libxml2.patch42
1 files changed, 42 insertions, 0 deletions
diff --git a/sci-libs/vtk/files/vtk-6.3.0-xdmf3-libxml2.patch b/sci-libs/vtk/files/vtk-6.3.0-xdmf3-libxml2.patch
new file mode 100644
index 0000000..a382a0f
--- /dev/null
+++ b/sci-libs/vtk/files/vtk-6.3.0-xdmf3-libxml2.patch
@@ -0,0 +1,42 @@
+From 6216f98a7124e12a2c1cefd113347f94b51f3c51 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Nico=20Schl=C3=B6mer?= <nico.schloemer@gmail.com>
+Date: Thu, 18 Jun 2015 13:30:30 +0200
+Subject: [PATCH] clarify logic for finding libxml2 in xdmf3
+
+---
+ ThirdParty/xdmf3/vtkxdmf3/core/CMakeLists.txt | 21 ++++++++++-----------
+ 1 file changed, 10 insertions(+), 11 deletions(-)
+
+diff --git a/ThirdParty/xdmf3/vtkxdmf3/core/CMakeLists.txt b/ThirdParty/xdmf3/vtkxdmf3/core/CMakeLists.txt
+index 241fa0a..15955b7 100644
+--- a/ThirdParty/xdmf3/vtkxdmf3/core/CMakeLists.txt
++++ b/ThirdParty/xdmf3/vtkxdmf3/core/CMakeLists.txt
+@@ -93,18 +93,17 @@ if(HDF5_FOUND)
+ endif()
+
+
+-set(LIBXML2_LIBRARIES ${vtklibxml2_LIBRARIES})
+-set(LIBXML2_INCLUDE_DIR ${vtklibxml2_INCLUDE_DIRS})
+-set(LIBXML2_FOUND TRUE)
+-find_package(LibXml2 REQUIRED)
+-if(LIBXML2_FOUND)
+- include_directories(${LIBXML2_INCLUDE_DIR})
+- get_filename_component(LIBXML2_ROOT "${LIBXML2_INCLUDE_DIR}/../" REALPATH)
+- set(LIBXML2_BINARY_DIRS ${LIBXML2_ROOT}/bin)
+- set(LIBXML2_BINARY_DIRS ${LIBXML2_BINARY_DIRS} PARENT_SCOPE)
+- set(XDMF_LIBRARIES ${XDMF_LIBRARIES} ${LIBXML2_LIBRARIES})
+- set(XDMF_BINARIES ${XDMF_BINARIES} ${LIBXML2_BINARY_DIRS})
++find_package(LibXml2)
++if(NOT LIBXML2_FOUND)
++ set(LIBXML2_LIBRARIES ${vtklibxml2_LIBRARIES})
++ set(LIBXML2_INCLUDE_DIR ${vtklibxml2_INCLUDE_DIRS})
+ endif()
++include_directories(${LIBXML2_INCLUDE_DIR})
++get_filename_component(LIBXML2_ROOT "${LIBXML2_INCLUDE_DIR}/../" REALPATH)
++set(LIBXML2_BINARY_DIRS ${LIBXML2_ROOT}/bin)
++set(LIBXML2_BINARY_DIRS ${LIBXML2_BINARY_DIRS} PARENT_SCOPE)
++set(XDMF_LIBRARIES ${XDMF_LIBRARIES} ${LIBXML2_LIBRARIES})
++set(XDMF_BINARIES ${XDMF_BINARIES} ${LIBXML2_BINARY_DIRS})
+
+ # Perform compile-time checks and generate XdmfCoreConfig.hpp
+