summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pyDes/pyDes-2.0.1_p20190107.ebuild')
-rw-r--r--dev-python/pyDes/pyDes-2.0.1_p20190107.ebuild21
1 files changed, 21 insertions, 0 deletions
diff --git a/dev-python/pyDes/pyDes-2.0.1_p20190107.ebuild b/dev-python/pyDes/pyDes-2.0.1_p20190107.ebuild
new file mode 100644
index 0000000..8c1b768
--- /dev/null
+++ b/dev-python/pyDes/pyDes-2.0.1_p20190107.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+DISTUTILS_USE_SETUPTOOLS=no
+inherit distutils-r1
+
+DESCRIPTION="Python implementation of DES an Triple-DES algorithms"
+HOMEPAGE="https://github.com/twhiteman/pyDes"
+SRC_URI="https://dev.gentoo.org/~bircoph/distfiles/${P}.tar.xz"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+python_test() {
+ python test_pydes.py
+}