summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Gryniewicz <dang@gentoo.org>2006-11-03 15:53:05 +0000
committerDaniel Gryniewicz <dang@gentoo.org>2006-11-03 15:53:05 +0000
commitccdfd52c00699968a4ce1f682c06501ba9c47121 (patch)
tree1aff9dc16c32c4220f81e86b10c01fca854a55a8
parentAdd init-race fix for gstreamer from ubuntu (diff)
downloaduser-ccdfd52c00699968a4ce1f682c06501ba9c47121.tar.gz
user-ccdfd52c00699968a4ce1f682c06501ba9c47121.tar.bz2
user-ccdfd52c00699968a4ce1f682c06501ba9c47121.zip
Fix cores on token ' id '
svn path=/user/; revision=7
-rw-r--r--mail-filter/bogofilter/Manifest12
-rw-r--r--mail-filter/bogofilter/bogofilter-1.1.1.ebuild73
-rw-r--r--mail-filter/bogofilter/files/bogofilter-1.1.1-id-core.patch13
-rw-r--r--mail-filter/bogofilter/files/digest-bogofilter-1.1.13
-rw-r--r--net-im/gaim/Manifest15
-rw-r--r--net-im/gaim/files/digest-gaim-2.0.0_beta3-r13
-rw-r--r--net-im/gaim/gaim-2.0.0_beta3-r1.ebuild227
7 files changed, 108 insertions, 238 deletions
diff --git a/mail-filter/bogofilter/Manifest b/mail-filter/bogofilter/Manifest
new file mode 100644
index 0000000..d227bf1
--- /dev/null
+++ b/mail-filter/bogofilter/Manifest
@@ -0,0 +1,12 @@
+AUX bogofilter-1.1.1-id-core.patch 449 RMD160 4f4d6a8981e6e4023f655eba2c473a97494e45d7 SHA1 152cd2d931a30aac328efb6d7b68d5fdd498b09f SHA256 b5828daf347d888d6b3da1575ef87d0bfe4b12ff61492d0b8ceb52ad0042675b
+MD5 51f91f774884bc0a89b64d0cceddc39a files/bogofilter-1.1.1-id-core.patch 449
+RMD160 4f4d6a8981e6e4023f655eba2c473a97494e45d7 files/bogofilter-1.1.1-id-core.patch 449
+SHA256 b5828daf347d888d6b3da1575ef87d0bfe4b12ff61492d0b8ceb52ad0042675b files/bogofilter-1.1.1-id-core.patch 449
+DIST bogofilter-1.1.1.tar.bz2 790929 RMD160 0510317b5cac1197dc99e837b0fc67471422c9d3 SHA1 5c88e00f0b8415eb6a9b4274f5a4a335639a40b9 SHA256 98684dd687139af5c04ed73c3c64016f7ec9e951da8d435d9666a9a036099fa5
+EBUILD bogofilter-1.1.1.ebuild 2247 RMD160 38aa09424c3f81b9407e1b5a4ae34874b001ab87 SHA1 b060a5cce1b6b317dd21c524f8200981595a8f2e SHA256 247026bb4fb5bd53a2736b5bfc680e47fd5d2ea6f5a916c7656722bc5ec7b752
+MD5 1ee091ba2e54ee8e1f1f4e75b74ee2c4 bogofilter-1.1.1.ebuild 2247
+RMD160 38aa09424c3f81b9407e1b5a4ae34874b001ab87 bogofilter-1.1.1.ebuild 2247
+SHA256 247026bb4fb5bd53a2736b5bfc680e47fd5d2ea6f5a916c7656722bc5ec7b752 bogofilter-1.1.1.ebuild 2247
+MD5 b8e0e6cb411b297e2d338fe300ee9bbe files/digest-bogofilter-1.1.1 253
+RMD160 97fecdec25faf7c29fd7fb8761b27a54d00313e3 files/digest-bogofilter-1.1.1 253
+SHA256 60de5207a6505e04638e479ab398b93193f89a134d006d538d76fb4f9a383dc0 files/digest-bogofilter-1.1.1 253
diff --git a/mail-filter/bogofilter/bogofilter-1.1.1.ebuild b/mail-filter/bogofilter/bogofilter-1.1.1.ebuild
new file mode 100644
index 0000000..5e62182
--- /dev/null
+++ b/mail-filter/bogofilter/bogofilter-1.1.1.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/mail-filter/bogofilter/bogofilter-1.1.1.ebuild,v 1.5 2006/11/01 22:30:19 kloeri Exp $
+
+inherit eutils
+
+DESCRIPTION="Bayesian spam filter designed with fast algorithms, and tuned for speed."
+HOMEPAGE="http://bogofilter.sourceforge.net/"
+SRC_URI="mirror://sourceforge/bogofilter/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ia64 ppc ppc64 sparc ~x86"
+#KEYWORDS="${KEYWORDS} ~arm ~mips" # missing, see bug #74046
+IUSE="gsl berkdb sqlite"
+
+DEPEND="virtual/libiconv
+ berkdb? ( >=sys-libs/db-3.2 )
+ !berkdb? (
+ sqlite? ( >=dev-db/sqlite-3.2.6 )
+ !sqlite? ( >=sys-libs/db-3.2 ) )
+ gsl? ( sci-libs/gsl )"
+# app-arch/pax" # only needed for bf_tar
+
+src_compile() {
+ epatch ${FILESDIR}/${P}-id-core.patch
+
+ local myconf=""
+ myconf="$(use_with !gsl included-gsl)"
+
+ # determine backend: berkdb *is* default
+ if use berkdb && use sqlite ; then
+ einfo "Both berkdb and sqlite are in USE."
+ einfo "Choosing berkdb as default database backend."
+ elif use sqlite ; then
+ myconf="${myconf} --with-database=sqlite"
+ elif ! use berkdb ; then
+ einfo "Using berkdb as database backend."
+ fi
+
+ econf ${myconf} || die "configure failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+
+ exeinto /usr/share/${PN}/contrib
+ doexe contrib/{bogofilter-qfe,parmtest,randomtrain}.sh \
+ contrib/{bfproxy,bogominitrain,mime.get.rfc822,printmaildir}.pl \
+ contrib/{spamitarium,stripsearch}.pl || die "doexec failed"
+
+ insinto /usr/share/${PN}/contrib
+ doins contrib/{README.*,dot-qmail-bogofilter-default} \
+ contrib/{bogogrep.c,bogo.R,bogofilter-milter.pl,*.example} \
+ contrib/vm-bogofilter.el \
+ contrib/{trainbogo,scramble}.sh || die "doins failed"
+
+ dodoc AUTHORS NEWS README RELEASE.NOTES* TODO GETTING.STARTED \
+ doc/integrating-with-* doc/README.{db,sqlite} || die "dodoc failed"
+
+ dohtml doc/*.html
+
+ dodir /usr/share/doc/${PF}/samples
+ mv "${D}"/etc/bogofilter.cf.example "${D}"/usr/share/doc/${PF}/samples/
+ rmdir "${D}"/etc
+}
+
+pkg_postinst() {
+ echo
+ einfo "If you need ${ROOT}usr/bin/bf_tar please install app-arch/pax."
+ echo
+}
diff --git a/mail-filter/bogofilter/files/bogofilter-1.1.1-id-core.patch b/mail-filter/bogofilter/files/bogofilter-1.1.1-id-core.patch
new file mode 100644
index 0000000..33d3239
--- /dev/null
+++ b/mail-filter/bogofilter/files/bogofilter-1.1.1-id-core.patch
@@ -0,0 +1,13 @@
+diff --exclude-from=/home/dang/.diffrc -up -ruN bogofilter-1.1.1.orig/src/token.c bogofilter-1.1.1/src/token.c
+--- bogofilter-1.1.1.orig/src/token.c 2006-08-10 21:43:59.000000000 -0400
++++ bogofilter-1.1.1/src/token.c 2006-11-03 10:42:23.000000000 -0500
+@@ -352,6 +352,9 @@ token_t parse_new_token(word_t *token)
+ text += 1;
+ leng -= 1;
+ }
++ if (leng == 0) {
++ continue;
++ }
+ if (text[leng-1] == '>') {
+ leng -= 1;
+ }
diff --git a/mail-filter/bogofilter/files/digest-bogofilter-1.1.1 b/mail-filter/bogofilter/files/digest-bogofilter-1.1.1
new file mode 100644
index 0000000..424c90e
--- /dev/null
+++ b/mail-filter/bogofilter/files/digest-bogofilter-1.1.1
@@ -0,0 +1,3 @@
+MD5 e7f236002daf22d732cad0433adac2ff bogofilter-1.1.1.tar.bz2 790929
+RMD160 0510317b5cac1197dc99e837b0fc67471422c9d3 bogofilter-1.1.1.tar.bz2 790929
+SHA256 98684dd687139af5c04ed73c3c64016f7ec9e951da8d435d9666a9a036099fa5 bogofilter-1.1.1.tar.bz2 790929
diff --git a/net-im/gaim/Manifest b/net-im/gaim/Manifest
index fee86aa..eb28145 100644
--- a/net-im/gaim/Manifest
+++ b/net-im/gaim/Manifest
@@ -11,18 +11,17 @@ MD5 6b61448d39f6673487fccc1a817d249f files/gaim-2.0.0_beta3-remove-asserts.patch
RMD160 4d09f0c76e8f3297229dc4eec551ffee2828d0c8 files/gaim-2.0.0_beta3-remove-asserts.patch 1542
SHA256 6b36802e7ac1ab842fde34871cf5d9b320ce31958fb8a388c607c9d24bd4f51d files/gaim-2.0.0_beta3-remove-asserts.patch 1542
DIST gaim-2.0.0beta3.1.tar.bz2 5445059 RMD160 5987586fee212a5c5e9287a9dce55a35c30ea7b7 SHA1 5897cc8b89e0937645be21a0655a6ebb4fb3e626 SHA256 a282c56f32a37f7838c5332f182bdd920d4e80099b96313e503c6acc020931f4
-DIST gaim-2.0.0beta3.tar.bz2 8056708 RMD160 f7c7273ebb5149b5eb3b3759f4a1d756f68392c5 SHA1 e23363cdcf928d503c6fa583239537b409d10b84 SHA256 5ce3a0054b26e96cacb5471d0d3456fde00223cadc267a3e010155b6a2ffe710
-EBUILD gaim-2.0.0_beta3-r1.ebuild 6485 RMD160 4330e1b76ef139d80b3588c3c03ee6930fe30b48 SHA1 e09f1a2ff49166397e4df7871560fe1e8695b3ea SHA256 e8ea2843bcff18b0c66109936acb013e9914c119ee48057b17e631ac8190d406
-MD5 127c7115c87cf9f57a59a03d02853349 gaim-2.0.0_beta3-r1.ebuild 6485
-RMD160 4330e1b76ef139d80b3588c3c03ee6930fe30b48 gaim-2.0.0_beta3-r1.ebuild 6485
-SHA256 e8ea2843bcff18b0c66109936acb013e9914c119ee48057b17e631ac8190d406 gaim-2.0.0_beta3-r1.ebuild 6485
EBUILD gaim-2.0.0_beta3-r2.ebuild 6564 RMD160 0061d1bec17a28fa480fdae9e087974ada146721 SHA1 ecf5d1b62b7d9027a4ca7ecdef19943e0c26051d SHA256 dbb52266ac9bd36441b2b70675da39e7e786f09745f29469455cf1b3c061ddf6
MD5 785f03d74872bdfdf50b2a977be63b0e gaim-2.0.0_beta3-r2.ebuild 6564
RMD160 0061d1bec17a28fa480fdae9e087974ada146721 gaim-2.0.0_beta3-r2.ebuild 6564
SHA256 dbb52266ac9bd36441b2b70675da39e7e786f09745f29469455cf1b3c061ddf6 gaim-2.0.0_beta3-r2.ebuild 6564
-MD5 18ac09d4d582248a50d0f68546832419 files/digest-gaim-2.0.0_beta3-r1 253
-RMD160 f5f547a5d04a6d1e1a3dc043abeabbe930ab8d55 files/digest-gaim-2.0.0_beta3-r1 253
-SHA256 4e8269e2659d7e240380f43cef0fa13244ce16c29457d81ba55a20ac071f62e4 files/digest-gaim-2.0.0_beta3-r1 253
+EBUILD gaim-2.0.0_beta3-r3.ebuild 6301 RMD160 e0001f6fad1c55d41e05a981b945759cb4e8cf97 SHA1 9c1cfad1c72f698515b551b9703eeec69be7e962 SHA256 a3b4b6f2160248bba7bdf8b7cc6bd42808446329488f23aad99aaa385b2c9072
+MD5 b792ea128385b6e395b4dbe2e06a8c32 gaim-2.0.0_beta3-r3.ebuild 6301
+RMD160 e0001f6fad1c55d41e05a981b945759cb4e8cf97 gaim-2.0.0_beta3-r3.ebuild 6301
+SHA256 a3b4b6f2160248bba7bdf8b7cc6bd42808446329488f23aad99aaa385b2c9072 gaim-2.0.0_beta3-r3.ebuild 6301
MD5 ffd99b34dae16b5b118de79bff8a948c files/digest-gaim-2.0.0_beta3-r2 259
RMD160 53b88544cfe6ea127784fcb43fc82a24097dcf94 files/digest-gaim-2.0.0_beta3-r2 259
SHA256 94f6c231a875fc84a7e98d49e9e32d31d19107375f600bbe357457d951fcc15d files/digest-gaim-2.0.0_beta3-r2 259
+MD5 ffd99b34dae16b5b118de79bff8a948c files/digest-gaim-2.0.0_beta3-r3 259
+RMD160 53b88544cfe6ea127784fcb43fc82a24097dcf94 files/digest-gaim-2.0.0_beta3-r3 259
+SHA256 94f6c231a875fc84a7e98d49e9e32d31d19107375f600bbe357457d951fcc15d files/digest-gaim-2.0.0_beta3-r3 259
diff --git a/net-im/gaim/files/digest-gaim-2.0.0_beta3-r1 b/net-im/gaim/files/digest-gaim-2.0.0_beta3-r1
deleted file mode 100644
index 8079211..0000000
--- a/net-im/gaim/files/digest-gaim-2.0.0_beta3-r1
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 c077655e4dd251cf22c406777c985a74 gaim-2.0.0beta3.tar.bz2 8056708
-RMD160 f7c7273ebb5149b5eb3b3759f4a1d756f68392c5 gaim-2.0.0beta3.tar.bz2 8056708
-SHA256 5ce3a0054b26e96cacb5471d0d3456fde00223cadc267a3e010155b6a2ffe710 gaim-2.0.0beta3.tar.bz2 8056708
diff --git a/net-im/gaim/gaim-2.0.0_beta3-r1.ebuild b/net-im/gaim/gaim-2.0.0_beta3-r1.ebuild
deleted file mode 100644
index 90d88a3..0000000
--- a/net-im/gaim/gaim-2.0.0_beta3-r1.ebuild
+++ /dev/null
@@ -1,227 +0,0 @@
-# Copyright 1999-2006 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/gaim/gaim-2.0.0_beta3-r1.ebuild,v 1.13 2006/07/10 17:59:50 gothgirl Exp $
-
-inherit flag-o-matic eutils toolchain-funcs debug multilib mono autotools perl-app
-
-MY_PV=${PV/_beta/beta}
-MY_P="${PN}-${MY_PV}"
-
-DESCRIPTION="GTK Instant Messenger client"
-HOMEPAGE="http://gaim.sourceforge.net/"
-SRC_URI="mirror://sourceforge/gaim/${MY_P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
-IUSE="avahi audiofile bonjour cjk dbus debug eds gadu gnutls meanwhile mono nas nls perl silc spell startup-notification tcl tk xscreensaver custom-flags ssl msn"
-
-RDEPEND="
- audiofile? ( media-libs/libao
- media-libs/audiofile )
- bonjour? ( !avahi? ( net-misc/howl )
- avahi? ( net-dns/avahi ) )
- dbus? ( >=sys-apps/dbus-0.35
- >=dev-lang/python-2.4 )
- >=x11-libs/gtk+-2.0
- >=dev-libs/glib-2.0
- nas? ( >=media-libs/nas-1.4.1-r1 )
- perl? ( >=dev-lang/perl-5.8.2-r1 )
- spell? ( >=app-text/gtkspell-2.0.2 )
- gadu? ( net-libs/libgadu )
- ssl? (
- gnutls? ( net-libs/gnutls )
- !gnutls? ( >=dev-libs/nss-3.11 )
- )
- msn? (
- gnutls? ( net-libs/gnutls )
- !gnutls? ( >=dev-libs/nss-3.11 )
- )
- meanwhile? ( net-libs/meanwhile )
- silc? ( >=net-im/silc-toolkit-0.9.12-r3 )
- eds? ( gnome-extra/evolution-data-server )
- tcl? ( dev-lang/tcl )
- tk? ( dev-lang/tk )
- startup-notification? ( >=x11-libs/startup-notification-0.5 )
- mono? ( dev-lang/mono )
- xscreensaver? ( x11-misc/xscreensaver
- x11-libs/libXScrnSaver )"
-
-DEPEND="$RDEPEND
- dev-util/pkgconfig
- nls? ( sys-devel/gettext )"
-
-
-S="${WORKDIR}/${MY_P}"
-
-# List of plugins
-# app-accessibility/festival-gaim
-# net-im/gaim-blogger
-# net-im/gaim-bnet
-# net-im/gaim-meanwhile
-# net-im/gaim-snpp
-# x11-plugins/autoprofile
-# x11-plugins/gaim-assistant
-# x11-plugins/gaim-encryption
-# x11-plugins/gaim-extprefs
-# x11-plugins/gaim-latex
-# x11-plugins/gaim-otr
-# x11-plugins/gaim-rhythmbox
-# x11-plugins/gaim-xmms-remote
-# x11-plugins/gaimosd
-# x11-plugins/guifications
-
-
-print_gaim_warning() {
- ewarn
- ewarn "This is a beta release! Please back up everything in your .gaim"
- ewarn "directory. We're looking for lots of feedback on this release"
- ewarn "especially what you love about it and what you hate about it."
- ewarn
- ewarn "Again, this is a beta release and should not be used by those"
- ewarn "with a heart condition, if you are pregnant, or if you are under"
- ewarn "the age of 8. Side-effects include awesomeness, dumbfoundedness,"
- ewarn "dry mouth and lava. Consult your doctor to find out if"
- ewarn "${MY_P} is right for you."
- ewarn
- ewarn "If you are merging ${MY_P} from an earlier version, you may need"
- ewarn "to re-merge any plugins like gaim-encryption or gaim-snpp."
- ewarn
- ewarn "If you experience problems with gaim, file them as bugs with"
- ewarn "Gentoo's bugzilla, http://bugs.gentoo.org. DO NOT report them"
- ewarn "as bugs with gaim's sourceforge tracker, and by all means DO NOT"
- ewarn "seek help in #gaim."
- ewarn
- ewarn "Be sure to USE=\"debug\" and include a backtrace for any seg"
- ewarn "faults, see http://gaim.sourceforge.net/gdb.php for details on"
- ewarn "backtraces."
- ewarn
- ewarn "Please read the gaim FAQ at http://gaim.sourceforge.net/faq.php"
- ewarn
- einfo
- if use custom-flags; then
- einfo "Note that you have chosen NOT TO FILTER UNSTABLE C[XX]FLAGS."
- einfo "DO NOT file bugs with GENTOO or UPSTREAM while using custom-flags"
- einfo
- else
- einfo "Note that we are now filtering all unstable flags in C[XX]FLAGS."
- einfo
- fi
-
- if use silc; then
- einfo "To be able to connect to silc network, you need to run"
- einfo "\`usermod -c \"comment\"\` as user as which you are running gaim,"
- einfo "where \"comment\" is either your real name if you want show it"
- einfo "on silc or any othe not empty string."
- einfo
- fi
- ebeep 5
- epause 3
-}
-
-pkg_setup() {
- print_gaim_warning
-
- if use avahi && ! built_with_use net-dns/avahi howl-compat ; then
- eerror
- eerror You need to rebuild net-dns/avavhi with USE=howl-compat in order
- eerror to enable howl support for the bonjour protocol in gaim.
- eerror
- die "Configure failed"
- fi
-
- if use gadu && built_with_use net-libs/libgadu ssl ; then
- eerror
- eerror You need to rebuild net-libs/libgadu with USE=-ssl in order
- eerror enable gadu gadu support in gaim.
- eerror
- die "Configure failed"
- fi
-}
-
-src_unpack() {
- unpack ${A}
- cd ${S}
-
- epatch ${FILESDIR}/${P}-as-needed.patch
- epatch ${FILESDIR}/${P}-avahi-compat.patch
- epatch ${FILESDIR}/${P}-remove-asserts.patch
-
- eautomake || die "Failed running eautomake"
-}
-
-src_compile() {
- # Stabilize things, for your own good
- if ! use custom-flags; then
- strip-flags
- fi
- #replace-flags -O? -O2
-
- # -msse2 doesn't play nice on gcc 3.2
- [ "`gcc-version`" == "3.2" ] && filter-flags -msse2
-
- local myconf
-
- if ! use bonjour ; then
- myconf="${myconf} --with-howl-includes=."
- myconf="${myconf} --with-howl-libs=."
- fi
-
- if ! use silc; then
- einfo "Disabling SILC protocol"
- myconf="${myconf} --with-silc-includes=."
- myconf="${myconf} --with-silc-libs=."
- fi
-
- if ! use gadu ; then
- myconf="${myconf} --with-gadu-includes=."
- myconf="${myconf} --with-gadu-libs=."
- fi
-
- if use ssl || use msn ; then
- if use gnutls ; then
- einfo "Disabling NSS, using GnuTLS"
- myconf="${myconf} --enable-nss=no --enable-gnutls=yes"
- myconf="${myconf} --with-gnutls-includes=/usr/include/gnutls"
- myconf="${myconf} --with-gnutls-libs=/usr/$(get_libdir)"
- else
- einfo "Disabling GnuTLS, using NSS"
- myconf="${myconf} --enable-gnutls=no --enable-nss=yes"
- fi
- else
- einfo "No SSL support selected"
- myconf="${myconf} --enable-gnutls=no --enable-nss=no"
- fi
-
- if use xscreensaver ; then
- myconf="${myconf} --x-includes=/usr/include/X11"
- fi
-
- econf \
- $(use_enable nls) \
- $(use_enable perl) \
- $(use_enable spell gtkspell) \
- $(use_enable startup-notification) \
- $(use_enable tcl) \
- $(use_enable tk) \
- $(use_enable mono) \
- $(use_enable debug) \
- $(use_enable dbus) \
- $(use_enable meanwhile) \
- $(use_enable nas) \
- $(use_enable eds gevolution) \
- $(use_enable audiofile audio) \
- ${myconf} || die "Configuration failed"
-
- emake -j1 || die "Make failed"
-}
-
-src_install() {
- make install DESTDIR=${D} || die "Install failed"
- use perl && fixlocalpod
- dodoc ABOUT-NLS AUTHORS COPYING HACKING INSTALL NEWS PROGRAMMING_NOTES README ChangeLog VERSION
-}
-
-pkg_postinst() {
- print_gaim_warning
-}