aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonnie Berkholz <dberkholz@gentoo.org>2009-07-24 11:52:27 -0700
committerDonnie Berkholz <dberkholz@gentoo.org>2009-07-24 11:52:27 -0700
commitf2f51bd2435f03e39cf726c6029614c8a009ea9e (patch)
treecd05e8c67748b5daae5c349dedd317b0a8090387 /sci-biology
parenttheseus: bump to 1.4.3. (diff)
downloaddberkholz-f2f51bd2435f03e39cf726c6029614c8a009ea9e.tar.gz
dberkholz-f2f51bd2435f03e39cf726c6029614c8a009ea9e.tar.bz2
dberkholz-f2f51bd2435f03e39cf726c6029614c8a009ea9e.zip
Add ebuild for CE, a protein structural alignment program.
CE: 3-D protein structure comparison and alignment using the Combinatorial Extension (CE) method. The ebuild is a hack, the build system sucks, etc.
Diffstat (limited to 'sci-biology')
-rw-r--r--sci-biology/ce/Manifest2
-rw-r--r--sci-biology/ce/ce-20040716.ebuild47
2 files changed, 49 insertions, 0 deletions
diff --git a/sci-biology/ce/Manifest b/sci-biology/ce/Manifest
new file mode 100644
index 0000000..799d8fb
--- /dev/null
+++ b/sci-biology/ce/Manifest
@@ -0,0 +1,2 @@
+DIST ce-20040716.tar.gz 1178703 RMD160 294c5800d4ddb29f9a9fe793833ab2670fe02560 SHA1 8446c6b3048dd1d09ac02b525b1f8ec06d32f22d SHA256 390d3485679690e9b9f17dcc9486a383ad3f1c47dd6c37d16c1196fc1691469a
+EBUILD ce-20040716.ebuild 928 RMD160 4514b4bd8b5ea461d73ddc4cf2d44b0bb43bb75d SHA1 0ebb87eef12bc312051994a7dbb2a1ae06c9ba8f SHA256 4b4c89244518efb5328438171eb1751636cb1b32df4a38fffed67ee616e1772a
diff --git a/sci-biology/ce/ce-20040716.ebuild b/sci-biology/ce/ce-20040716.ebuild
new file mode 100644
index 0000000..3b0d32c
--- /dev/null
+++ b/sci-biology/ce/ce-20040716.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=2
+
+inherit toolchain-funcs
+
+DESCRIPTION="3-D protein structure comparison and alignment using the Combinatorial Extension (CE) method"
+HOMEPAGE="http://cl.sdsc.edu/"
+SRC_URI="ftp://ftp.sdsc.edu/pub/sdsc/biology/CE/src/ce_linux.tar.gz -> ${P}.tar.gz"
+LICENSE="free-noncomm"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+RDEPEND=""
+DEPEND="${RDEPEND}"
+S=${WORKDIR}/ce_distr
+
+src_prepare() {
+ # clean up precompiled files
+ find . -name '*.o' | xargs rm -f || die
+ rm -f CE ce/ce pom/mkDB || die
+
+ # gcc 4.3 fix
+ sed -i \
+ -e "s:iostream.h:iostream:" \
+ pom/calc.C
+
+ # Look in path for mkDB
+ sed -i \
+ -e "s:pom/mkDB:mkDB:" \
+ ce/ce.C
+
+ sed -i \
+ -e "/^CC/ s:g++:$(tc-getCXX):" \
+ ce/Makefile pom/Makefile
+}
+
+src_compile() {
+ emake -j1 || die
+}
+
+src_install() {
+ dobin CE pom/mkDB || die
+ dodoc README || die
+}