summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Schweizer <genstef@gentoo.org>2008-03-15 21:05:32 +0000
committerStefan Schweizer <genstef@gentoo.org>2008-03-15 21:05:32 +0000
commit6b14255aba7a241ca15823eaa3254a83b340c3e3 (patch)
tree0f6739cbba0c588b17c6adef00b585bbcf5474c0 /games-strategy
parentplease use the kde overlay (diff)
downloadgenstef-master.tar.gz
genstef-master.tar.bz2
genstef-master.zip
ccd2iso needs too much space ;)HEADmaster
svn path=/; revision=112
Diffstat (limited to 'games-strategy')
-rw-r--r--games-strategy/freeciv/freeciv-9999.ebuild34
1 files changed, 23 insertions, 11 deletions
diff --git a/games-strategy/freeciv/freeciv-9999.ebuild b/games-strategy/freeciv/freeciv-9999.ebuild
index 8bccc10..be7fa5d 100644
--- a/games-strategy/freeciv/freeciv-9999.ebuild
+++ b/games-strategy/freeciv/freeciv-9999.ebuild
@@ -6,9 +6,11 @@ inherit eutils games subversion flag-o-matic
ESVN_REPO_URI="http://svn.gna.org/svn/freeciv/trunk"
+MY_P=${PN}-${PV/_/-}
DESCRIPTION="multiplayer strategy game (Civilization Clone)"
HOMEPAGE="http://www.freeciv.org/"
-SRC_URI="mirror://gentoo/${PN}.png
+SRC_URI="
+ mirror://gentoo/${PN}.png
!dedicated? (
alsa? (
ftp://ftp.freeciv.org/freeciv/contrib/audio/soundsets/stdsounds3.tar.gz )
@@ -29,10 +31,16 @@ RDEPEND="readline? ( sys-libs/readline )
gtk? ( >=x11-libs/gtk+-2 )
!gtk? (
Xaw3d? ( x11-libs/Xaw3d )
- !Xaw3d? ( x11-libs/libXaw )
- x11-libs/libXmu
- x11-libs/libXpm
+ !Xaw3d? (
+ sdl? (
+ media-libs/libsdl
+ media-libs/sdl-image
+ media-libs/freetype
+ )
+ !sdl? ( x11-libs/libXaw )
+ )
)
+ media-libs/libpng
alsa? (
media-libs/alsa-lib
media-libs/audiofile
@@ -43,9 +51,12 @@ RDEPEND="readline? ( sys-libs/readline )
)"
DEPEND="${RDEPEND}
nls? ( sys-devel/gettext )
- !dedicated? ( gtk? ( dev-util/pkgconfig ) )
- x11-proto/xextproto
- media-libs/libpng"
+ !dedicated? (
+ gtk? ( dev-util/pkgconfig )
+ x11-proto/xextproto
+ )"
+
+S=${WORKDIR}/${MY_P}
pkg_setup() {
games_pkg_setup
@@ -54,6 +65,8 @@ pkg_setup() {
elog "The Freeciv Client will be built with the GTK+-2 toolkit"
elif use Xaw3d ; then
elog "The Freeciv Client will be built with the Xaw3d toolkit"
+ elif use sdl ; then
+ elog "The Freeciv Client will be built with the SDL toolkit"
else
elog "The Freeciv Client will be built with the Xaw toolkit"
fi
@@ -116,6 +129,7 @@ src_compile() {
myclient="no"
else
myclient="xaw"
+ use sdl && myclient="sdl"
use Xaw3d && myclient="xaw3d"
if use gtk ; then
myclient="gtk-2.0"
@@ -134,7 +148,6 @@ src_compile() {
$(use_enable nls) \
$(use_with readline) \
--enable-client=${myclient} \
- --disable-nls \
${mysoundconf} \
|| die "egamesconf failed"
@@ -146,7 +159,7 @@ src_install() {
if ! use dedicated ; then
# Install the app-defaults if Xaw/Xaw3d toolkit
- if ! use gtk ; then
+ if ! use gtk && ! use sdl ; then
insinto /etc/X11/app-defaults
doins data/Freeciv || die "doins failed"
fi
@@ -165,8 +178,7 @@ src_install() {
rm -f "${D}/${GAMES_BINDIR}"/civmanual
fi
- dodoc ChangeLog NEWS \
- doc/{BUGS,CodingStyle,HACKING,HOWTOPLAY,PEOPLE,README*,TODO}
+ dodoc ChangeLog NEWS doc/{BUGS,CodingStyle,HACKING,HOWTOPLAY,README*,TODO}
doicon "${DISTDIR}"/${PN}.png
prepgamesdirs