summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-strategy/freeciv/freeciv-9999.ebuild')
-rw-r--r--games-strategy/freeciv/freeciv-9999.ebuild94
1 files changed, 37 insertions, 57 deletions
diff --git a/games-strategy/freeciv/freeciv-9999.ebuild b/games-strategy/freeciv/freeciv-9999.ebuild
index 3e36168..eb51bfe 100644
--- a/games-strategy/freeciv/freeciv-9999.ebuild
+++ b/games-strategy/freeciv/freeciv-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $
@@ -8,69 +8,54 @@ ESVN_REPO_URI="svn://svn.gna.org/svn/freeciv/trunk"
DESCRIPTION="multiplayer strategy game (Civilization Clone)"
HOMEPAGE="http://www.freeciv.org/"
-SRC_URI="!dedicated? (
+SRC_URI="mirror://gentoo/${PN}.png
+ !dedicated? (
alsa? (
- http://www.freeciv.org/ftp/contrib/sounds/sets/stdsounds3.tar.gz )
+ ftp://ftp.freeciv.org/freeciv/contrib/audio/soundsets/stdsounds3.tar.gz )
esd? (
- http://www.freeciv.org/ftp/contrib/sounds/sets/stdsounds3.tar.gz )
+ ftp://ftp.freeciv.org/freeciv/contrib/audio/soundsets/stdsounds3.tar.gz )
sdl? (
- http://www.freeciv.org/ftp/contrib/sounds/sets/stdsounds3.tar.gz ) )"
+ ftp://ftp.freeciv.org/freeciv/contrib/audio/soundsets/stdsounds3.tar.gz )
+ )"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="-*"
-IUSE="alsa dedicated esd gtk nls readline sdl Xaw3d"
+KEYWORDS=""
+IUSE="alsa auth dedicated esd gtk nls readline sdl Xaw3d"
-RDEPEND="sys-libs/zlib
- readline? ( sys-libs/readline )
+RDEPEND="readline? ( sys-libs/readline )
!dedicated? (
- gtk? (
- >=dev-util/pkgconfig-0.9
- >=x11-libs/gtk+-2.0.0
- >=dev-libs/glib-2.0.0
- >=dev-libs/atk-1.0.3
- >=x11-libs/pango-1.0.5
- )
+ nls? ( virtual/libintl )
+ gtk? ( >=x11-libs/gtk+-2 )
!gtk? (
- Xaw3d? (
- x11-libs/Xaw3d )
- !Xaw3d? (
- || (
- x11-libs/libXaw
- virtual/x11 ) )
- || ( (
- x11-libs/libX11
- x11-libs/libICE
- x11-libs/libSM
- x11-libs/libXt
- x11-libs/libXext
- x11-libs/libXmu
- x11-libs/libXpm )
- virtual/x11 ) )
- alsa? (
- >=media-libs/alsa-lib-1.0
- >=media-libs/audiofile-0.2
+ Xaw3d? ( x11-libs/Xaw3d )
+ !Xaw3d? ( x11-libs/libXaw )
+ x11-libs/libXmu
+ x11-libs/libXpm
)
- esd? ( >=media-sound/esound-0.2 )
- sdl? (
- >=media-libs/sdl-mixer-1.2
- >=media-libs/libsdl-1.2
+ alsa? (
+ media-libs/alsa-lib
+ media-libs/audiofile
)
+ esd? ( media-sound/esound )
+ sdl? ( media-libs/sdl-mixer )
+ auth? ( virtual/mysql )
)"
DEPEND="${RDEPEND}
nls? ( sys-devel/gettext )
- || ( ( x11-proto/xextproto )
- virtual/x11 )"
+ !dedicated? ( gtk? ( dev-util/pkgconfig ) )
+ x11-proto/xextproto
+ media-libs/libpng"
pkg_setup() {
games_pkg_setup
if ! use dedicated ; then
if use gtk ; then
- einfo "The Freeciv Client will be built with the GTK+-2 toolkit"
+ elog "The Freeciv Client will be built with the GTK+-2 toolkit"
elif use Xaw3d ; then
- einfo "The Freeciv Client will be built with the Xaw3d toolkit"
+ elog "The Freeciv Client will be built with the Xaw3d toolkit"
else
- einfo "The Freeciv Client will be built with the Xaw toolkit"
+ elog "The Freeciv Client will be built with the Xaw toolkit"
fi
if ! use esd && ! use alsa && ! use sdl ; then
ewarn
@@ -96,19 +81,14 @@ src_unpack() {
intl/Makefile.in po/Makefile.in.in \
|| die "sed failed"
sed -i \
- -e '/^#define LOCALEDIR/s:".*":"/usr/share/locale":' \
+ -e 's:$datadir/locale:/usr/share/locale:' \
configure \
|| die "sed failed"
- # change .desktop icon to the freeciv icon rather than the gnome globe
- sed -i \
- -e 's:^\(Icon=\).*:\1freeciv.png:' \
- bootstrap/freeciv.desktop.in \
- || die "sed failed"
-
# change .desktop category so it is not gnome specific
sed -i \
-e 's:^\(Categories=GNOME;Application;Game;Strategy;\):Categories=Application;Game;StrategyGame;:' \
+ -e 's:^\(Icon=\).*:\1freeciv.png:' \
bootstrap/freeciv.desktop.in \
|| die "sed failed"
# install the .desktop in /usr/share/applications
@@ -150,9 +130,10 @@ src_compile() {
egamesconf \
--disable-dependency-tracking \
--with-zlib \
+ $(use_enable auth) \
$(use_enable nls) \
$(use_with readline) \
- --enable-client=sdl \
+ --enable-client=${myclient} \
${mysoundconf} \
|| die "egamesconf failed"
@@ -160,7 +141,7 @@ src_compile() {
}
src_install() {
- make DESTDIR="${D}" install || die "make install failed"
+ emake DESTDIR="${D}" install || die "emake install failed"
if ! use dedicated ; then
# Install the app-defaults if Xaw/Xaw3d toolkit
@@ -170,8 +151,8 @@ src_install() {
fi
# Install sounds if at least one sound plugin was built
if use alsa || use esd || use sdl ; then
- cp -R ../data/stdsounds* "${D}${GAMES_DATADIR}/${PN}" \
- || die "failed to install sounds"
+ insinto "${GAMES_DATADIR}"/${PN}
+ doins -r ../data/stdsounds* || die "doins sounds failed"
fi
# Create and install the html manual. It can't be done for dedicated
# servers, because the 'civmanual' tool is then not built. Also
@@ -180,13 +161,12 @@ src_install() {
# something like that, but then it's a PITA to avoid orphan files...
./manual/civmanual || die "civmanual failed"
dohtml manual*.html || die "dohtml failed"
- rm -f "${D}/${GAMES_BINDIR}/civmanual"
+ rm -f "${D}/${GAMES_BINDIR}"/civmanual
fi
dodoc ChangeLog NEWS \
doc/{BUGS,CodingStyle,HACKING,HOWTOPLAY,PEOPLE,README*,TODO}
- doicon "${FILESDIR}/${PN}.png"
-
+ doicon "${DISTDIR}"/${PN}.png
prepgamesdirs
}