summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuca Barbato <lu_zero@gentoo.org>2006-11-11 11:24:31 +0000
committerLuca Barbato <lu_zero@gentoo.org>2006-11-11 11:24:31 +0000
commitdfd34799296309c14bb9a3b1fb18cb0c0a308f6c (patch)
treeb12ab5c82a505139f657c404a4ff646b71e4627c /sys-kernel/cell-sources/cell-sources-2.6.19_rc5-r1.ebuild
parentUseful documentation, I'm undecided if lump it to libspe or keep it separated (diff)
downloadlu_zero-dfd34799296309c14bb9a3b1fb18cb0c0a308f6c.tar.gz
lu_zero-dfd34799296309c14bb9a3b1fb18cb0c0a308f6c.tar.bz2
lu_zero-dfd34799296309c14bb9a3b1fb18cb0c0a308f6c.zip
Updated kernel sources, I'm undecided about providing the ps3pf bits yet
svn path=/; revision=62
Diffstat (limited to 'sys-kernel/cell-sources/cell-sources-2.6.19_rc5-r1.ebuild')
-rw-r--r--sys-kernel/cell-sources/cell-sources-2.6.19_rc5-r1.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/sys-kernel/cell-sources/cell-sources-2.6.19_rc5-r1.ebuild b/sys-kernel/cell-sources/cell-sources-2.6.19_rc5-r1.ebuild
new file mode 100644
index 0000000..c219df0
--- /dev/null
+++ b/sys-kernel/cell-sources/cell-sources-2.6.19_rc5-r1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/gentoo-sources/gentoo-sources-2.6.16-r13.ebuild,v 1.3 2006/07/24 14:14:55 gustavoz Exp $
+
+ETYPE="sources"
+IUSE=""
+inherit kernel-2 eutils
+detect_version
+detect_arch
+
+KEYWORDS="~ppc ~ppc64"
+HOMEPAGE="http://dev.gentoo.org/~dsd/genpatches
+http://kernel.org/pub/linux/kernel/people/arnd/patches/"
+
+DESCRIPTION="Full sources including the arnd patchset for the ${KV_MAJOR}.${KV_MINOR} kernel tree"
+
+ARND_VER="${PV/_/-}-arnd${PR//r}"
+
+CELLPATCHES_URI="http://kernel.org/pub/linux/kernel/people/arnd/patches/${ARND_VER}/${ARND_VER}.diff.bz2"
+
+SRC_URI="${KERNEL_URI} ${ARCH_URI} ${CELLPATCHES_URI}"
+
+src_unpack() {
+ kernel-2_src_unpack
+
+ cd ${S}
+ epatch ${DISTDIR}/${ARND_VER}.diff.bz2
+}
+
+pkg_postinst() {
+ postinst_sources
+
+ echo
+
+ if [ "${ARCH}" = "sparc" ]; then
+ if [ x"`cat /proc/openprom/name 2>/dev/null`" \
+ = x"'SUNW,Ultra-1'" ]; then
+ einfo "For users with an Enterprise model Ultra 1 using the HME"
+ einfo "network interface, please emerge the kernel using the"
+ einfo "following command: USE=ultra1 emerge ${PN}"
+ fi
+ fi
+ einfo "For more info on this patchset, and how to report problems, see:"
+ einfo "${HOMEPAGE}"
+}