summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-auth/pam_mobile_otp/pam_mobile_otp-0.6.1.ebuild')
-rw-r--r--sys-auth/pam_mobile_otp/pam_mobile_otp-0.6.1.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/sys-auth/pam_mobile_otp/pam_mobile_otp-0.6.1.ebuild b/sys-auth/pam_mobile_otp/pam_mobile_otp-0.6.1.ebuild
new file mode 100644
index 0000000..c4288c0
--- /dev/null
+++ b/sys-auth/pam_mobile_otp/pam_mobile_otp-0.6.1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="3"
+inherit eutils pam toolchain-funcs
+
+DESCRIPTION="Mobile One Time Passwords"
+HOMEPAGE="http://motp.sourceforge.net/"
+SRC_URI="http://motp.sourceforge.net/${P}.tgz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="sys-libs/pam"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${PN}"
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-gentoo.patch"
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" || die
+}
+
+src_install() {
+ dopammod pam_mobile_otp.so || die
+
+ keepdir /var/cache/motp || die
+ fperms 0700 /var/cache/motp || die
+
+ dopamsecurity '' motp.conf || die
+
+ dodoc CHANGELOG README || die
+ dohtml MOTP.html || die
+}