summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/ELFIO/ELFIO-1.0.3.ebuild')
-rw-r--r--dev-libs/ELFIO/ELFIO-1.0.3.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-libs/ELFIO/ELFIO-1.0.3.ebuild b/dev-libs/ELFIO/ELFIO-1.0.3.ebuild
new file mode 100644
index 0000000..0edbfeb
--- /dev/null
+++ b/dev-libs/ELFIO/ELFIO-1.0.3.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit flag-o-matic toolchain-funcs
+
+DESCRIPTION="ELF (Executable and Linkable Format) reader and producer implemented as a C++ library."
+HOMEPAGE="http://elfio.sourceforge.net/"
+SRC_URI="mirror://sourceforge/elfio/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~mips ~sparc ~x86"
+IUSE=""
+
+src_compile() {
+ append-flags -fPIC
+ econf || die "econf failed"
+ emake || die "emake failed"
+
+ # for secondlife
+ cd ELFIO && $(tc-getCC) -shared *.o -o libelfio.so || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "install failed"
+ dolib.so ELFIO/libelfio.so || die
+
+ dodoc AUTHORS NEWS README
+}