summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason Wever <weeve@gentoo.org>2007-02-06 00:24:28 +0000
committerJason Wever <weeve@gentoo.org>2007-02-06 00:24:28 +0000
commitdcd816c16d57fb1e5d93f35e6980a3600750ec13 (patch)
tree1858126aea95b59f0ad84ef423540d9e54e7d966 /net-misc/check_sync_reboot/check_sync_reboot-1.0.ebuild
parentInitial commit of fl0p, a passive layer 7 flow fingerprinter. (diff)
downloadweeve-dcd816c16d57fb1e5d93f35e6980a3600750ec13.tar.gz
weeve-dcd816c16d57fb1e5d93f35e6980a3600750ec13.tar.bz2
weeve-dcd816c16d57fb1e5d93f35e6980a3600750ec13.zip
Add packages for most of the tools used in the Hacking VoIP Exposed book.HEADmaster
svn path=/; revision=3
Diffstat (limited to 'net-misc/check_sync_reboot/check_sync_reboot-1.0.ebuild')
-rw-r--r--net-misc/check_sync_reboot/check_sync_reboot-1.0.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/net-misc/check_sync_reboot/check_sync_reboot-1.0.ebuild b/net-misc/check_sync_reboot/check_sync_reboot-1.0.ebuild
new file mode 100644
index 0000000..27b4e0e
--- /dev/null
+++ b/net-misc/check_sync_reboot/check_sync_reboot-1.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit eutils
+DESCRIPTION="Command to send a NOTIFY request to a SIP Phone, written by the Hacking VoIP Exposed authors"
+HOMEPAGE="http://www.hackingvoip.com/sec_tools.html"
+SRC_URI="http://www.hackingvoip.com/tools/hack_library.tar.gz
+ http://www.hackingvoip.com/tools/${PN}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE=""
+DEPEND="virtual/libc"
+RDEPEND="${DEPEND}"
+
+src_compile() {
+ # Make the library dependency
+ cd ${WORKDIR}/hack_library
+ emake || die "emake failed"
+
+ # Make the package
+ cd ${WORKDIR}/${PN}
+ emake || die "emake failed"
+}
+
+src_install() {
+ cd ${WORKDIR}/${PN}
+ dobin ${PN}
+ dodoc LICENSE_SOFTWARE
+}