aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWalfred Tedeschi <walfred.tedeschi@intel.com>2013-11-20 13:01:09 +0100
committerWalfred Tedeschi <walfred.tedeschi@intel.com>2013-11-20 14:42:50 +0100
commitccc42043f7a34784560e08553bbf51ce3044785e (patch)
tree0ce757ff65a435721a9c7d681b1e069e28a1a454 /gdb/regformats
parentFix conditions in creating a bitfield. (diff)
downloadbinutils-gdb-ccc42043f7a34784560e08553bbf51ce3044785e.tar.gz
binutils-gdb-ccc42043f7a34784560e08553bbf51ce3044785e.tar.bz2
binutils-gdb-ccc42043f7a34784560e08553bbf51ce3044785e.zip
Add MPX registers XML files.
2013-11-20 Walfred Tedeschi <walfred.tedeschi@intel.com> * features/i386/Makefile: Adapts for using MPX registers. * features/i386/32bit-mpx.xml: New file. * features/i386/64bit-mpx.xml: Likewise. * features/i386/amd64-mpx-linux.c: Likewise. * features/i386/amd64-mpx-linux.xml: Likewise. * features/i386/amd64-mpx.c: Likewise. * features/i386/amd64-mpx.xml: Likewise. * features/i386/i386-mpx-linux.c: Likewise. * features/i386/i386-mpx-linux.xml: Likewise. * features/i386/i386-mpx.c: Likewise. * features/i386/i386-mpx.xml: Likewise. * regformats/i386/amd64-mpx-linux.dat: New file. * regformats/i386/amd64-mpx.dat: Likewise. * regformats/i386/i386-mpx-linux.dat: Likewise. * regformats/i386/i386-mpx.dat: Likewise.
Diffstat (limited to 'gdb/regformats')
-rw-r--r--gdb/regformats/i386/amd64-mpx-linux.dat84
-rw-r--r--gdb/regformats/i386/amd64-mpx.dat83
-rw-r--r--gdb/regformats/i386/i386-mpx-linux.dat60
-rw-r--r--gdb/regformats/i386/i386-mpx.dat59
4 files changed, 286 insertions, 0 deletions
diff --git a/gdb/regformats/i386/amd64-mpx-linux.dat b/gdb/regformats/i386/amd64-mpx-linux.dat
new file mode 100644
index 00000000000..992541d83d3
--- /dev/null
+++ b/gdb/regformats/i386/amd64-mpx-linux.dat
@@ -0,0 +1,84 @@
+# DO NOT EDIT: generated from i386/amd64-mpx-linux.xml
+name:amd64_mpx_linux
+xmltarget:amd64-mpx-linux.xml
+expedite:rbp,rsp,rip
+64:rax
+64:rbx
+64:rcx
+64:rdx
+64:rsi
+64:rdi
+64:rbp
+64:rsp
+64:r8
+64:r9
+64:r10
+64:r11
+64:r12
+64:r13
+64:r14
+64:r15
+64:rip
+32:eflags
+32:cs
+32:ss
+32:ds
+32:es
+32:fs
+32:gs
+80:st0
+80:st1
+80:st2
+80:st3
+80:st4
+80:st5
+80:st6
+80:st7
+32:fctrl
+32:fstat
+32:ftag
+32:fiseg
+32:fioff
+32:foseg
+32:fooff
+32:fop
+128:xmm0
+128:xmm1
+128:xmm2
+128:xmm3
+128:xmm4
+128:xmm5
+128:xmm6
+128:xmm7
+128:xmm8
+128:xmm9
+128:xmm10
+128:xmm11
+128:xmm12
+128:xmm13
+128:xmm14
+128:xmm15
+32:mxcsr
+64:orig_rax
+128:ymm0h
+128:ymm1h
+128:ymm2h
+128:ymm3h
+128:ymm4h
+128:ymm5h
+128:ymm6h
+128:ymm7h
+128:ymm8h
+128:ymm9h
+128:ymm10h
+128:ymm11h
+128:ymm12h
+128:ymm13h
+128:ymm14h
+128:ymm15h
+128:bnd0raw
+128:bnd1raw
+128:bnd2raw
+128:bnd3raw
+64:bndcfgu
+64:bndstatus
diff --git a/gdb/regformats/i386/amd64-mpx.dat b/gdb/regformats/i386/amd64-mpx.dat
new file mode 100644
index 00000000000..e411ebd3f68
--- /dev/null
+++ b/gdb/regformats/i386/amd64-mpx.dat
@@ -0,0 +1,83 @@
+# DO NOT EDIT: generated from i386/amd64-mpx.xml
+name:amd64_mpx
+xmltarget:amd64-mpx.xml
+expedite:rbp,rsp,rip
+64:rax
+64:rbx
+64:rcx
+64:rdx
+64:rsi
+64:rdi
+64:rbp
+64:rsp
+64:r8
+64:r9
+64:r10
+64:r11
+64:r12
+64:r13
+64:r14
+64:r15
+64:rip
+32:eflags
+32:cs
+32:ss
+32:ds
+32:es
+32:fs
+32:gs
+80:st0
+80:st1
+80:st2
+80:st3
+80:st4
+80:st5
+80:st6
+80:st7
+32:fctrl
+32:fstat
+32:ftag
+32:fiseg
+32:fioff
+32:foseg
+32:fooff
+32:fop
+128:xmm0
+128:xmm1
+128:xmm2
+128:xmm3
+128:xmm4
+128:xmm5
+128:xmm6
+128:xmm7
+128:xmm8
+128:xmm9
+128:xmm10
+128:xmm11
+128:xmm12
+128:xmm13
+128:xmm14
+128:xmm15
+32:mxcsr
+128:ymm0h
+128:ymm1h
+128:ymm2h
+128:ymm3h
+128:ymm4h
+128:ymm5h
+128:ymm6h
+128:ymm7h
+128:ymm8h
+128:ymm9h
+128:ymm10h
+128:ymm11h
+128:ymm12h
+128:ymm13h
+128:ymm14h
+128:ymm15h
+128:bnd0raw
+128:bnd1raw
+128:bnd2raw
+128:bnd3raw
+64:bndcfgu
+64:bndstatus
diff --git a/gdb/regformats/i386/i386-mpx-linux.dat b/gdb/regformats/i386/i386-mpx-linux.dat
new file mode 100644
index 00000000000..1ba08d306a7
--- /dev/null
+++ b/gdb/regformats/i386/i386-mpx-linux.dat
@@ -0,0 +1,60 @@
+# DO NOT EDIT: generated from i386/i386-mpx-linux.xml
+name:i386_mpx_linux
+xmltarget:i386-mpx-linux.xml
+expedite:ebp,esp,eip
+32:eax
+32:ecx
+32:edx
+32:ebx
+32:esp
+32:ebp
+32:esi
+32:edi
+32:eip
+32:eflags
+32:cs
+32:ss
+32:ds
+32:es
+32:fs
+32:gs
+80:st0
+80:st1
+80:st2
+80:st3
+80:st4
+80:st5
+80:st6
+80:st7
+32:fctrl
+32:fstat
+32:ftag
+32:fiseg
+32:fioff
+32:foseg
+32:fooff
+32:fop
+128:xmm0
+128:xmm1
+128:xmm2
+128:xmm3
+128:xmm4
+128:xmm5
+128:xmm6
+128:xmm7
+32:mxcsr
+32:orig_eax
+128:ymm0h
+128:ymm1h
+128:ymm2h
+128:ymm3h
+128:ymm4h
+128:ymm5h
+128:ymm6h
+128:ymm7h
+128:bnd0raw
+128:bnd1raw
+128:bnd2raw
+128:bnd3raw
+64:bndcfgu
+64:bndstatus
diff --git a/gdb/regformats/i386/i386-mpx.dat b/gdb/regformats/i386/i386-mpx.dat
new file mode 100644
index 00000000000..8b0c95bb6fc
--- /dev/null
+++ b/gdb/regformats/i386/i386-mpx.dat
@@ -0,0 +1,59 @@
+# DO NOT EDIT: generated from i386/i386-mpx.xml
+name:i386_mpx
+xmltarget:i386-mpx.xml
+expedite:ebp,esp,eip
+32:eax
+32:ecx
+32:edx
+32:ebx
+32:esp
+32:ebp
+32:esi
+32:edi
+32:eip
+32:eflags
+32:cs
+32:ss
+32:ds
+32:es
+32:fs
+32:gs
+80:st0
+80:st1
+80:st2
+80:st3
+80:st4
+80:st5
+80:st6
+80:st7
+32:fctrl
+32:fstat
+32:ftag
+32:fiseg
+32:fioff
+32:foseg
+32:fooff
+32:fop
+128:xmm0
+128:xmm1
+128:xmm2
+128:xmm3
+128:xmm4
+128:xmm5
+128:xmm6
+128:xmm7
+32:mxcsr
+128:ymm0h
+128:ymm1h
+128:ymm2h
+128:ymm3h
+128:ymm4h
+128:ymm5h
+128:ymm6h
+128:ymm7h
+128:bnd0raw
+128:bnd1raw
+128:bnd2raw
+128:bnd3raw
+64:bndcfgu
+64:bndstatus