aboutsummaryrefslogtreecommitdiff
path: root/po
diff options
context:
space:
mode:
authorZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2017-11-13 13:30:39 +0100
committerZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2017-11-13 21:35:28 +0100
commitc81217920effddc93fb780cf8f9eb699d6fe1319 (patch)
tree9329d39638ffac8fa7fc3fd8c03c9530e66dacf6 /po
parentMerge pull request #7284 from poettering/cgroup-delegate-mask (diff)
downloadsystemd-c81217920effddc93fb780cf8f9eb699d6fe1319.tar.gz
systemd-c81217920effddc93fb780cf8f9eb699d6fe1319.tar.bz2
systemd-c81217920effddc93fb780cf8f9eb699d6fe1319.zip
i18n: drop intltool use, use meson's merge_file directly
This didn't work during the initial conversion to meson, but should now. A sufficiently new polkit is also required, for the .its rules files. Note that https://github.com/mesonbuild/meson/blob/master/docs/markdown/i18n-module.md says that 'install' argument was added in meson 0.43.0. If this is accurate, warnigs might be generated with older mesons. Fedora has 0.43.0 across the board, but other distros probably don't, but I guess that a warning is prefereable to having to update do latest meson. The advantages are: - one less dependency (intltool) - using the generic implementation instead of our open-coded calls - we don't need to use the fake "_" prefixes in XML Replaces #1609, fixes #7300.
Diffstat (limited to 'po')
-rw-r--r--po/meson.build8
1 files changed, 0 insertions, 8 deletions
diff --git a/po/meson.build b/po/meson.build
index f89291bfc..c4654be5f 100644
--- a/po/meson.build
+++ b/po/meson.build
@@ -1,12 +1,4 @@
i18n = import('i18n')
i18n.gettext(meson.project_name())
-#####################################################################
-
-intltool_merge = find_program('intltool-merge')
po_dir = meson.current_source_dir()
-
-intltool_cache = join_paths(meson.current_build_dir(), 'intltool-merge-cache')
-intltool_command = [intltool_merge, '-x', '-u',
- '-c', intltool_cache,
- po_dir, '@INPUT@', '@OUTPUT@']