summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-libs/rb_libtorrent/rb_libtorrent-0.15.8.ebuild')
-rw-r--r--net-libs/rb_libtorrent/rb_libtorrent-0.15.8.ebuild78
1 files changed, 0 insertions, 78 deletions
diff --git a/net-libs/rb_libtorrent/rb_libtorrent-0.15.8.ebuild b/net-libs/rb_libtorrent/rb_libtorrent-0.15.8.ebuild
deleted file mode 100644
index 70de22e..0000000
--- a/net-libs/rb_libtorrent/rb_libtorrent-0.15.8.ebuild
+++ /dev/null
@@ -1,78 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/rb_libtorrent/rb_libtorrent-0.15.8.ebuild,v 1.3 2012/02/05 01:32:54 floppym Exp $
-
-EAPI="2"
-PYTHON_DEPEND="python? 2:2.6"
-PYTHON_USE_WITH="threads"
-PYTHON_USE_WITH_OPT="python"
-
-inherit eutils multilib versionator python
-
-MY_P=${P/rb_/}
-MY_P=${MY_P/torrent/torrent-rasterbar}
-S=${WORKDIR}/${MY_P}
-
-DESCRIPTION="C++ BitTorrent implementation focusing on efficiency and scalability"
-HOMEPAGE="http://www.rasterbar.com/products/libtorrent/"
-SRC_URI="http://libtorrent.googlecode.com/files/${MY_P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
-IUSE="debug doc examples python ssl static-libs"
-RESTRICT="test"
-
-DEPEND="<dev-libs/boost-1.48[python?]
- >=sys-devel/libtool-2.2
- sys-libs/zlib
- examples? ( !net-p2p/mldonkey )
- ssl? ( dev-libs/openssl )"
-
-RDEPEND="${DEPEND}"
-
-pkg_setup() {
- use python && python_set_active_version 2
-}
-
-src_prepare() {
- use python && python_convert_shebangs -r 2 .
-}
-
-src_configure() {
- # use multi-threading versions of boost libs
- local BOOST_LIBS="--with-boost-system=boost_system-mt \
- --with-boost-filesystem=boost_filesystem-mt \
- --with-boost-thread=boost_thread-mt \
- --with-boost-python=boost_python-mt"
- # detect boost version and location, bug 295474
- BOOST_PKG="$(best_version ">=dev-libs/boost-1.34.1")"
- BOOST_VER="$(get_version_component_range 1-2 "${BOOST_PKG/*boost-/}")"
- BOOST_VER="$(replace_all_version_separators _ "${BOOST_VER}")"
- BOOST_INC="/usr/include/boost-${BOOST_VER}"
- BOOST_LIB="/usr/$(get_libdir)/boost-${BOOST_VER}"
-
- local LOGGING
- use debug && LOGGING="--enable-logging=verbose"
-
- econf $(use_enable debug) \
- $(use_enable test tests) \
- $(use_enable examples) \
- $(use_enable python python-binding) \
- $(use_enable ssl encryption) \
- $(use_enable static-libs static) \
- --with-zlib=system \
- ${LOGGING} \
- --with-boost=${BOOST_INC} \
- --with-boost-libdir=${BOOST_LIB} \
- ${BOOST_LIBS}
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die 'emake install failed'
- use static-libs || find "${D}" -name '*.la' -exec rm -f {} +
- dodoc ChangeLog AUTHORS NEWS README || die 'dodoc failed'
- if use doc ; then
- dohtml docs/* || die "Could not install HTML documentation"
- fi
-}