aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Schlemmer <azarah@gentoo.org>2003-03-09 16:46:15 +0000
committerMartin Schlemmer <azarah@gentoo.org>2003-03-09 16:46:15 +0000
commit8aa25ef942326819306e0afb725cb94e3aa85ca9 (patch)
treeacf6e94d7ebf788db0fbdb594c279086422b42d7
parentnew version (diff)
downloadautotools-wrappers-8aa25ef942326819306e0afb725cb94e3aa85ca9.tar.gz
autotools-wrappers-8aa25ef942326819306e0afb725cb94e3aa85ca9.tar.bz2
autotools-wrappers-8aa25ef942326819306e0afb725cb94e3aa85ca9.zip
update am-wrapper.pl to work with AC_PREREQ in []
-rwxr-xr-xam-wrapper.pl8
1 files changed, 4 insertions, 4 deletions
diff --git a/am-wrapper.pl b/am-wrapper.pl
index 0bd13a3..83e926e 100755
--- a/am-wrapper.pl
+++ b/am-wrapper.pl
@@ -92,9 +92,9 @@ if ($ENV{WANT_AUTOMAKE} ne '1.4') {
|| (cat_('aclocal.m4') =~ /^\s*\[?AM_AUTOMAKE_VERSION\(\[?([^\)]{3})[^\)]*\]?\)/m ? $1 : '') ge '1.6'
# Autoconf 2.53d and later need automake-1.6c, so enable 1.6 for 2.53
# and up .....
- || (cat_('configure.in') =~ /^\s*AC_PREREQ\(\[?([^\)]{4})[^\)]*\]?\)/m ? $1 : '') gt '2.52'
+ || (cat_('configure.in') =~ /^\s*\[?AC_PREREQ\(\[?([^\)]{4})[^\)]*\]?\)/m ? $1 : '') gt '2.52'
|| (cat_('configure') =~ /^# Generated by Autoconf (\S+)/m ? $1 : '') gt '2.52'
- || (cat_('aclocal.m4') =~ /^\s*AC_PREREQ\(\[?([^\)]{4})[^\)]*\]?\)/m ? $1 : '') gt '2.52')) {
+ || (cat_('aclocal.m4') =~ /^\s*\[?AC_PREREQ\(\[?([^\)]{4})[^\)]*\]?\)/m ? $1 : '') gt '2.52')) {
$ENV{WANT_AUTOMAKE} = '1.6'; # to prevent further "cats" and to enhance consistency (possible cwd etc)
$binary = $binary_1_6;
} elsif (-x $binary_1_5 # user may have only 1.4 ...
@@ -102,9 +102,9 @@ if ($ENV{WANT_AUTOMAKE} ne '1.4') {
|| -r 'configure.ac'
|| (cat_('Makefile.in') =~ /^# Makefile\.in generated by automake (\S+)/ ? $1 : '') ge '1.5'
|| (cat_('aclocal.m4') =~ /^# aclocal.m4 generated automatically by aclocal (\S+)/ ? $1 : '') ge '1.5'
- || (cat_('configure.in') =~ /^\s*AC_PREREQ\(\[?([^\)]{3})[^\)]*\]?\)/m ? $1 : '') gt '2.1'
+ || (cat_('configure.in') =~ /^\s*\[?AC_PREREQ\(\[?([^\)]{3})[^\)]*\]?\)/m ? $1 : '') gt '2.1'
|| (cat_('configure') =~ /^# Generated by Autoconf (\S+)/m ? $1 : '') gt '2.1'
- || (cat_('aclocal.m4') =~ /^\s*AC_PREREQ\(\[?([^\)]{3})[^\)]*\]?\)/m ? $1 : '') gt '2.1')) {
+ || (cat_('aclocal.m4') =~ /^\s*\[?AC_PREREQ\(\[?([^\)]{3})[^\)]*\]?\)/m ? $1 : '') gt '2.1')) {
$ENV{WANT_AUTOMAKE} = '1.5'; # to prevent further "cats" and to enhance consistency (possible cwd etc)
$binary = $binary_1_5;
} else {