aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDoug Goldstein <cardoe@cardoe.com>2019-12-23 20:09:11 -0600
committerDoug Goldstein <cardoe@cardoe.com>2020-01-26 09:20:10 -0600
commit92920325a7ba4d39a7443d10fec19a8a35ece40b (patch)
tree570503b62515258de8a31d4fc2d817e394d0473d /Cargo.toml
parentadd some more badges for crates.io (diff)
downloadcargo-ebuild-92920325a7ba4d39a7443d10fec19a8a35ece40b.tar.gz
cargo-ebuild-92920325a7ba4d39a7443d10fec19a8a35ece40b.tar.bz2
cargo-ebuild-92920325a7ba4d39a7443d10fec19a8a35ece40b.zip
switch to cargo_metadata for dep info
Switched from using Cargo to resolve the dependencies to using the cargo_metadata crate, which calls Cargo and parses the machine parseable data back.
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml2
1 files changed, 2 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
index ab7e8d1..828d38d 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -30,5 +30,7 @@ maintenance = { status = "passively-maintained" }
[dependencies]
cargo = "^0.37"
+cargo_metadata = "^0.9"
+failure = "^0.1"
structopt = "^0.3"
time = "^0.1"