aboutsummaryrefslogtreecommitdiff
path: root/eclass
diff options
context:
space:
mode:
authorAlon Bar-Lev <alon.barlev@gmail.com>2009-03-28 09:18:29 +0000
committerAlon Bar-Lev <alon.barlev@gmail.com>2009-03-28 09:18:29 +0000
commit3cddad2c449e6cd70cf48196d64c962b3478a907 (patch)
tree242a3c89c058fbcce1c636d5010f9955641148c9 /eclass
parentRemove temp file (diff)
downloadembedded-cross-3cddad2c449e6cd70cf48196d64c962b3478a907.tar.gz
embedded-cross-3cddad2c449e6cd70cf48196d64c962b3478a907.tar.bz2
embedded-cross-3cddad2c449e6cd70cf48196d64c962b3478a907.zip
Use e17 eclass better
Diffstat (limited to 'eclass')
-rw-r--r--eclass/enlightenment.eclass12
1 files changed, 10 insertions, 2 deletions
diff --git a/eclass/enlightenment.eclass b/eclass/enlightenment.eclass
index c72f3d3..ba68cce 100644
--- a/eclass/enlightenment.eclass
+++ b/eclass/enlightenment.eclass
@@ -6,6 +6,7 @@ inherit autotools eutils subversion
SVN_SUBDIR="${SVN_SUBDIR:=}"
E17_PATCHES="${E17_PATCHES:=}"
+E17_EXTRA_CONF="${E17_EXTRA_CONF:=}"
ESVN_REPO_URI="http://svn.enlightenment.org/svn/e/trunk$SVN_SUBDIR/${PN}"
@@ -33,12 +34,19 @@ enlightenment_src_unpack() {
epatch "${FILESDIR}/${patch}"
done
+ if tc-is-cross-compiler; then
+ sed -i -e 's%SDL_CFLAGS=`$SDL_CONFIG --cflags`%SDL_CFLAGS=`$SDL_CONFIG --prefix='${SYSROOT}'/usr --cflags`%' configure.ac
+ fi
+
+ [ -e README ] || touch README
+ if grep -q AM_GNU_GETTEXT_VERSION configure.ac; then
+ autopoint -f
+ fi
eautoreconf || die "eautoreconf failed"
}
enlightenment_src_compile() {
-
- econf || die "econf failed"
+ econf ${E17_EXTRA_CONF} || die "econf failed"
emake || die "emake failed"
}