aboutsummaryrefslogtreecommitdiff
path: root/eclass
diff options
context:
space:
mode:
authorSven 'sleipnir' Rebhan <odinshorse@googlemail.com>2009-05-09 17:31:08 +0000
committerSven 'sleipnir' Rebhan <odinshorse@googlemail.com>2009-05-09 17:31:08 +0000
commitfed07fdcd49ee48f07f5cad80a619dd4a8ffb4e4 (patch)
tree5063bccb547e30e674e0a77665ea56462c853e82 /eclass
parentRework the SHR application suite... (diff)
downloadembedded-cross-fed07fdcd49ee48f07f5cad80a619dd4a8ffb4e4.tar.gz
embedded-cross-fed07fdcd49ee48f07f5cad80a619dd4a8ffb4e4.tar.bz2
embedded-cross-fed07fdcd49ee48f07f5cad80a619dd4a8ffb4e4.zip
Reworked SHR eclass... Beware, the old packages won't work anymore...
Diffstat (limited to 'eclass')
-rw-r--r--eclass/shr.eclass37
1 files changed, 22 insertions, 15 deletions
diff --git a/eclass/shr.eclass b/eclass/shr.eclass
index d364251..8b3bf3c 100644
--- a/eclass/shr.eclass
+++ b/eclass/shr.eclass
@@ -4,37 +4,44 @@
inherit autotools eutils git
+IUSE="nls"
+DEPEND="${DEPEND}
+ nls? ( dev-util/cvs )"
+
+# Init the extra econfs
+SHR_EXTRA_ECONF_OPTS=""
+
+# Location of the project
EGIT_REPO_URI="http://shr.bearstech.com/repo/shr.git"
EGIT_PROJECT="shr"
-case "${PV}" in
- 20090308)
- EGIT_TREE="10c44ec2d1a86efc2670671655715707814ccdaf"
- ;;
- 99999999)
- ;;
- *)
- die "Unsupported version"
- ;;
-esac
shr_src_unpack() {
git_src_unpack
+
cd "${S}/${PROJECT_NAME}"
- if grep -q AM_GNU_GETTEXT_VERSION configure.ac; then
- autopoint -f
- fi
- eautoreconf || die "autoreconf failed"
- glib-gettextize --force --copy || die "glib-gettextize failed"
+
+ # Create files that might be missing
+ touch ABOUT-NLS config.rpath
+
+ # If nls is enables, try to find out if we can autopoint that thing
+ use nls && grep -q AM_GNU_GETTEXT_VERSION configure.ac && autopoint -f
+
+ eautoreconf
+ use nls && glib-gettextize --force --copy
}
shr_src_compile() {
cd "${S}/${PROJECT_NAME}"
+
+echo ${SHR_EXTRA_ECONF_OPTS}
+
econf ${SHR_EXTRA_ECONF_OPTS} || die "econf failed"
emake || die "emake failed"
}
shr_src_install() {
cd "${S}/${PROJECT_NAME}"
+
emake DESTDIR="${D}" install || die "emake install failed"
dodoc AUTHORS NEWS README
}