aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRafael G. Martins <rafael@rafaelmartins.eng.br>2010-07-02 14:02:12 -0300
committerRafael G. Martins <rafael@rafaelmartins.eng.br>2010-07-02 14:02:12 -0300
commited6ac2539ffef8a2d8a446a169b8a26c3b5404fe (patch)
treee2560b89c4aaad5fb90f900a72a86dab0cd4c5ea /ebuilds
parentAdded tag 0.2 for changeset 768ee6674897 (diff)
downloadg-octave-ed6ac2539ffef8a2d8a446a169b8a26c3b5404fe.tar.gz
g-octave-ed6ac2539ffef8a2d8a446a169b8a26c3b5404fe.tar.bz2
g-octave-ed6ac2539ffef8a2d8a446a169b8a26c3b5404fe.zip
ebuilds updated
Diffstat (limited to 'ebuilds')
-rw-r--r--ebuilds/g-octave-0.1.ebuild30
-rw-r--r--ebuilds/g-octave-0.2.ebuild77
-rw-r--r--ebuilds/g-octave-9999.ebuild18
3 files changed, 92 insertions, 33 deletions
diff --git a/ebuilds/g-octave-0.1.ebuild b/ebuilds/g-octave-0.1.ebuild
deleted file mode 100644
index 9f42174..0000000
--- a/ebuilds/g-octave-0.1.ebuild
+++ /dev/null
@@ -1,30 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: $
-
-EAPI="2"
-
-inherit distutils
-
-DESCRIPTION="A tool that generates and installs ebuilds for Octave-Forge"
-HOMEPAGE="http://g-octave.rafaelmartins.eng.br/"
-SRC_URI="http://files.rafaelmartins.eng.br/distfiles/${PN}/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="test"
-
-DEPEND="( >=dev-lang/python-2.6 <dev-lang/python-3 )"
-RDEPEND="${DEPEND}
- || ( >=sys-apps/portage-2.1.7[-python3] <sys-apps/portage-2.1.7 )"
-
-src_install() {
- distutils_src_install
- dohtml ${PN}.html
- doman ${PN}.1
-}
-
-src_test() {
- PYTHONPATH=. scripts/run_tests.py || die "test failed."
-}
diff --git a/ebuilds/g-octave-0.2.ebuild b/ebuilds/g-octave-0.2.ebuild
new file mode 100644
index 0000000..6667e01
--- /dev/null
+++ b/ebuilds/g-octave-0.2.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="2"
+
+inherit distutils
+
+MY_PV="1278015626"
+INFO_REV="1"
+#PATCHES_REV="1"
+
+DESCRIPTION="A tool that generates and installs ebuilds for Octave-Forge"
+HOMEPAGE="http://g-octave.rafaelmartins.eng.br/"
+
+SRC_URI="http://g-octave.rafaelmartins.eng.br/distfiles/releases/${P}.tar.gz
+ http://g-octave.rafaelmartins.eng.br/distfiles/db/octave-forge-${MY_PV}.db.tar.gz
+ http://g-octave.rafaelmartins.eng.br/distfiles/db/info-${MY_PV}-${INFO_REV}.json"
+ #http://g-octave.rafaelmartins.eng.br/distfiles/db/patches-${MY_PV}-${PATCHES_REV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="svn test"
+
+DEPEND="( >=dev-lang/python-2.6 <dev-lang/python-3 )"
+RDEPEND="${DEPEND}
+ svn? ( dev-python/pysvn )
+ || ( >=sys-apps/portage-2.1.7[-python3] <sys-apps/portage-2.1.7 )"
+
+PYTHON_MODNAME="g_octave"
+
+src_unpack() {
+ unpack ${P}.tar.gz
+}
+
+src_prepare() {
+ distutils_src_prepare
+ sed -i -e 's/^has_fetch.*$/has_fetch = False/' scripts/g-octave \
+ || die 'failed to patch the g-octave main script'
+ if ! use svn; then
+ rm -rf g_octave/svn/ || die 'failed to remove the Subversion stuff.'
+ sed -i -e '/g_octave.svn/d' -e '/pysvn/d' setup.py \
+ || die 'failed to remove the SVN stuff from setup.py'
+ fi
+}
+
+src_install() {
+ distutils_src_install
+ dohtml ${PN}.html
+ doman ${PN}.1
+}
+
+src_test() {
+ PYTHONPATH=. scripts/run_tests.py || die "test failed."
+}
+
+pkg_postinst() {
+ distutils_pkg_postinst
+ elog
+ elog 'To be able to use g-octave with the shipped package database, please'
+ elog 'edit your configuration file, clean your db directory and run:'
+ elog " emerge --config =${PF}"
+ elog
+}
+
+pkg_config() {
+ local db="$(g-octave --config db)"
+ mkdir -p "${db}"
+ elog "Copying g-octave database files to: ${db}"
+ cp "${DISTDIR}/octave-forge-${MY_PV}.db.tar.gz" "${db}/" \
+ || die "failed to copy octave-forge-${MY_PV}.db.tar.gz"
+ cp "${DISTDIR}/info-${MY_PV}-${INFO_REV}.json" "${db}/" \
+ || die "failed to copy info-${MY_PV}-${INFO_REV}.json"
+ #cp "${DISTDIR}/patches-${MY_P}-${PATCHES_REV}.tar.gz" "${db}/" \
+ # || die "failed to copy patches-${MY_P}-${PATCHES_REV}.tar.gz"
+}
diff --git a/ebuilds/g-octave-9999.ebuild b/ebuilds/g-octave-9999.ebuild
index fe8c1f7..ebab60f 100644
--- a/ebuilds/g-octave-9999.ebuild
+++ b/ebuilds/g-octave-9999.ebuild
@@ -8,20 +8,32 @@ inherit distutils mercurial
DESCRIPTION="A tool that generates and installs ebuilds for Octave-Forge"
HOMEPAGE="http://g-octave.rafaelmartins.eng.br/"
-EHG_REPO_URI="http://hg.rafaelmartins.eng.br/g-octave/"
+EHG_REPO_URI="http://g-octave.rafaelmartins.eng.br/hg/"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS=""
-IUSE="test"
+IUSE="svn test"
CDEPEND="( >=dev-lang/python-2.6 <dev-lang/python-3 )"
DEPEND="${CDEPEND}
>=dev-python/docutils-0.6"
RDEPEND="${CDEPEND}
+ svn? ( dev-python/pysvn )
|| ( >=sys-apps/portage-2.1.7[-python3] <sys-apps/portage-2.1.7 )"
-S="${WORKDIR}/${PN}"
+S="${WORKDIR}/hg"
+
+PYTHON_MODNAME="g_octave"
+
+src_prepare() {
+ distutils_src_prepare
+ if ! use svn; then
+ rm -rf g_octave/svn/ || die 'failed to remove the Subversion stuff.'
+ sed -i -e '/g_octave.svn/d' -e '/pysvn/d' setup.py \
+ || die 'failed to remove the SVN stuff from setup.py'
+ fi
+}
src_install() {
distutils_src_install