summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVadim A. Misbakh-Soloviov <git@mva.name>2016-10-05 14:07:35 +0700
committerVadim A. Misbakh-Soloviov <git@mva.name>2016-10-05 14:07:35 +0700
commited8288fa26345cfe211c76786991f505d0007239 (patch)
treee4ebfa9f6e0ba0fd92012115301784c8b6af7b04 /games-action
parentnet-libs/htmlcxx: Remove in favour of version in Gentoo repo (diff)
downloadgamerlay-ed8288fa26345cfe211c76786991f505d0007239.tar.gz
gamerlay-ed8288fa26345cfe211c76786991f505d0007239.tar.bz2
gamerlay-ed8288fa26345cfe211c76786991f505d0007239.zip
dex: added
Diffstat (limited to 'games-action')
-rw-r--r--games-action/dex/Manifest2
-rw-r--r--games-action/dex/dex-2.1.0.2.ebuild113
2 files changed, 115 insertions, 0 deletions
diff --git a/games-action/dex/Manifest b/games-action/dex/Manifest
new file mode 100644
index 0000000..94c64da
--- /dev/null
+++ b/games-action/dex/Manifest
@@ -0,0 +1,2 @@
+DIST gog_dex_2.1.0.2.sh 2145744946 SHA256 ea9bb5d952ff304f761694b1438a8253e2265a077dbae74a300981c6ad443214 SHA512 9b54be3edabb807899b3f72b8517deeeb46350fa9920e132f8c312044cedb92bbf4cde8bf7dfc82c31779f1d103e4107c7d96e15c0b8f7039a4243bfa8ebbf15 WHIRLPOOL 6a3ebe67ba57a5d91a64b12d50664d76a0b0fbfad948f8a836ef5dd9d3666e304e80fa5d7ad51e84a86a6f402b2490b5cb70422b5ad79f6887f85b061b1ff03c
+DIST patch_dex_2.0.1.2.sh 367632038 SHA256 ffc2799bd59cfa8ed0cbadf33445130bba64f8d0b7035234244fb5c9999a7d4e SHA512 215dc253f0c7a45f32f695443c1d83780de09cf0b358c6f1ab67acba04b4acf1b3e49a9854dffa3bfa733eb51994342fdf6fe299ad206ee9f00076e7f3af1afb WHIRLPOOL 1034f2d3dc58b22ce66837b640b1a056dc8cbf2b857ed70220783a827e899aa707afd93893d5b6fcdb9e9e4f57b5bb543a0ac20d3365fd6cc330148b41ae02a3
diff --git a/games-action/dex/dex-2.1.0.2.ebuild b/games-action/dex/dex-2.1.0.2.ebuild
new file mode 100644
index 0000000..972db97
--- /dev/null
+++ b/games-action/dex/dex-2.1.0.2.ebuild
@@ -0,0 +1,113 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=6
+
+inherit eutils unpacker
+
+GOG_PATCH_PV="2.0.1.2"
+
+DESCRIPTION="2D Action-RPG with a rich cyberpunk world"
+HOMEPAGE="http://en.dreadlocks.cz/games/dex/"
+SRC_URI="
+ gog? (
+ gog_${PN}_${PV}.sh
+ patch_${PN}_${GOG_PATCH_PV}.sh
+ )
+"
+
+RESTRICT="fetch strip"
+LICENSE="EULA"
+
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="+gog"
+
+DEPEND="
+ app-arch/unzip
+ dev-util/xdelta3
+"
+RDEPEND="
+ dev-libs/glib
+ media-libs/mesa
+ virtual/libc
+ x11-libs/gdk-pixbuf
+ x11-libs/gtk+
+ x11-libs/libX11
+ x11-libs/libXcursor
+ x11-libs/libXrandr
+"
+
+S="${WORKDIR}"
+
+pkg_nofetch() {
+ einfo ""
+ einfo "Please open ${HOMEPAGE}, choose a place to buy it,"
+ einfo "then download \"${SRC_URI}\", and move/link it to \"${DISTDIR}\""
+ einfo ""
+ einfo "P.S.: I've only gog version. So, if you have Humble Store version"
+ einfo "and want this ebuild to also cover it — please contact me."
+}
+
+src_unpack() {
+ for f in ${A[@]}; do
+ unzip -qn "${DISTDIR}/${f}"
+ done
+}
+
+src_prepare() {
+ rm -r meta scripts
+ default
+ while read Line # -- patch files
+ do
+ Line2=$(echo $Line | cut -d " " -f 2-)
+ xdelta3 -v -d -s "${Line2}" patch/"${Line2}".delta patch/"${Line2}".tmp || die "ERROR (patching): File version mismatch, quitting"
+ done < patch/files_to_patch.list
+
+ while read Line # -- move patched files to the right place
+ do
+ Line2=$(echo $Line | cut -d " " -f 2-)
+ chmod $(stat -c%a "${Line2}") patch/"${Line2}".tmp
+ mv -vf patch/"${Line2}".tmp "${Line2}"
+ done < patch/files_to_patch.list
+
+ while read Line # -- remove patch files
+ do
+ Line2=$(echo $Line | cut -d " " -f 2-)
+ rm -vfr "patch/${Line2}".delta
+ done < patch/files_to_patch.list
+}
+
+src_install() {
+ local dir="/opt/${PN}" arch="x86" exe modexe;
+
+# use amd64 && arch="x86_64";
+ exe="${PN^}.x86"; # fixme when gog'll release x86_64 version
+ cfgexe="GamepadConfigTool.x86" #.${arch}";
+
+ insinto "${dir}";
+ exeinto "${dir}";
+
+ cd data/noarch;
+
+ doins -r game/*
+ doexe "game/${exe}" "game/${cfgexe}" "support/gog-system-report.sh"
+
+ touch "${D}/${dir}/controller.config"
+ fperms 666 "${dir}/controller.config" # so, gamepad config tool will be able to save content to it, even if runs under unpriv. user
+
+ make_wrapper "${PN}" "./${exe}" "${dir}"
+ make_wrapper "${PN}-gog-system-report" "./gog-system-report.sh" "${dir}"
+ make_wrapper "${PN}-gc" "./${cfgexe}" "${dir}"
+ newicon "support/icon.png" "${PN}.png"
+ make_desktop_entry "${PN}" "${PN^}: Play" "${PN}"
+ make_desktop_entry "${PN}-gc" "${PN^}: Gamepad Configuration tool" "${PN}"
+}
+
+pkg_postinst() {
+ einfo 'If game badly detects your gamepad (i.e. some keys is not working),'
+ einfo 'you can run `dex-gc` tool (Gamepad Configuration tool)'
+ einfo 'It will calibrate your gamepad and save configuration so Dex game'
+ einfo 'will be able to load it and work normally with your gamepad'
+}