aboutsummaryrefslogtreecommitdiff
path: root/4.0.3
diff options
context:
space:
mode:
authorMark Loeser <halcy0n@gentoo.org>2006-03-14 06:04:25 +0000
committerMark Loeser <halcy0n@gentoo.org>2006-03-14 06:04:25 +0000
commit61b0a5951ea7f9223b1e5e74b1f88d6cd6ab244d (patch)
tree85df3a731bfc9251bc2ed8ca015c2aba5942bf01 /4.0.3
parentcut pointless wchar hunk (diff)
downloadgcc-patches-61b0a5951ea7f9223b1e5e74b1f88d6cd6ab244d.tar.gz
gcc-patches-61b0a5951ea7f9223b1e5e74b1f88d6cd6ab244d.tar.bz2
gcc-patches-61b0a5951ea7f9223b1e5e74b1f88d6cd6ab244d.zip
Patch to fix bug #114359; backported from trunk
Diffstat (limited to '4.0.3')
-rw-r--r--4.0.3/gentoo/37_all_gcc42-boehmgc-include.patch142
1 files changed, 142 insertions, 0 deletions
diff --git a/4.0.3/gentoo/37_all_gcc42-boehmgc-include.patch b/4.0.3/gentoo/37_all_gcc42-boehmgc-include.patch
new file mode 100644
index 0000000..2b1839c
--- /dev/null
+++ b/4.0.3/gentoo/37_all_gcc42-boehmgc-include.patch
@@ -0,0 +1,142 @@
+--- libobjc/configure 2006-03-14 00:51:43.000000000 -0500
++++ libobjc/configure 2006-03-14 00:56:08.000000000 -0500
+@@ -309,7 +309,7 @@
+ # include <unistd.h>
+ #endif"
+
+-ac_subst_vars='SHELL PATH_SEPARATOR PACKAGE_NAME PACKAGE_TARNAME PACKAGE_VERSION PACKAGE_STRING PACKAGE_BUGREPORT exec_prefix prefix program_transform_name bindir sbindir libexecdir datadir sysconfdir sharedstatedir localstatedir libdir includedir oldincludedir infodir mandir build_alias host_alias target_alias DEFS ECHO_C ECHO_N ECHO_T LIBS VERSION OBJC_BOEHM_GC toplevel_srcdir build build_cpu build_vendor build_os host host_cpu host_vendor host_os target target_cpu target_vendor target_os target_noncanonical glibcpp_srcdir gcc_version_trigger gcc_version_full gcc_version toolexecdir toolexeclibdir includedirname libext CC ac_ct_CC EXEEXT OBJEXT CFLAGS AS ac_ct_AS AR ac_ct_AR RANLIB ac_ct_RANLIB INSTALL_PROGRAM INSTALL_SCRIPT INSTALL_DATA MAINTAINER_MODE_TRUE MAINTAINER_MODE_FALSE MAINT LN_S STRIP ac_ct_STRIP LIBTOOL SET_MAKE CPP CPPFLAGS EGREP GTHREAD_FLAGS LIBOBJS LTLIBOBJS'
++ac_subst_vars='SHELL PATH_SEPARATOR PACKAGE_NAME PACKAGE_TARNAME PACKAGE_VERSION PACKAGE_STRING PACKAGE_BUGREPORT exec_prefix prefix program_transform_name bindir sbindir libexecdir datadir sysconfdir sharedstatedir localstatedir libdir includedir oldincludedir infodir mandir build_alias host_alias target_alias DEFS ECHO_C ECHO_N ECHO_T LIBS VERSION OBJC_BOEHM_GC OBJC_BOEHM_GC_INCLUDES toplevel_srcdir build build_cpu build_vendor build_os host host_cpu host_vendor host_os target target_cpu target_vendor target_os target_noncanonical glibcpp_srcdir gcc_version_trigger gcc_version_full gcc_version toolexecdir toolexeclibdir includedirname libext CC ac_ct_CC EXEEXT OBJEXT CFLAGS AS ac_ct_AS AR ac_ct_AR RANLIB ac_ct_RANLIB INSTALL_PROGRAM INSTALL_SCRIPT INSTALL_DATA MAINTAINER_MODE_TRUE MAINTAINER_MODE_FALSE MAINT LN_S STRIP ac_ct_STRIP LIBTOOL SET_MAKE CPP CPPFLAGS EGREP GTHREAD_FLAGS LIBOBJS LTLIBOBJS'
+ ac_subst_files=''
+
+ # Initialize some variables set by options.
+@@ -719,13 +719,13 @@
+ /^X\(\/\).*/{ s//\1/; q; }
+ s/.*/./; q'`
+ srcdir=$ac_confdir
+- if test ! -r $srcdir/$ac_unique_file; then
++ if test ! -r "$srcdir/$ac_unique_file"; then
+ srcdir=..
+ fi
+ else
+ ac_srcdir_defaulted=no
+ fi
+-if test ! -r $srcdir/$ac_unique_file; then
++if test ! -r "$srcdir/$ac_unique_file"; then
+ if test "$ac_srcdir_defaulted" = yes; then
+ { echo "$as_me: error: cannot find sources ($ac_unique_file) in $ac_confdir or .." >&2
+ { (exit 1); exit 1; }; }
+@@ -734,7 +734,7 @@
+ { (exit 1); exit 1; }; }
+ fi
+ fi
+-(cd $srcdir && test -r ./$ac_unique_file) 2>/dev/null ||
++(cd $srcdir && test -r "./$ac_unique_file") 2>/dev/null ||
+ { echo "$as_me: error: sources are in $srcdir, but \`cd $srcdir' does not work" >&2
+ { (exit 1); exit 1; }; }
+ srcdir=`echo "$srcdir" | sed 's%\([^\\/]\)[\\/]*$%\1%'`
+@@ -1383,14 +1383,21 @@
+ if test "${enable_objc_gc+set}" = set; then
+ enableval="$enable_objc_gc"
+ case $enable_objc_gc in
+- no) OBJC_BOEHM_GC='' ;;
+- *) OBJC_BOEHM_GC=libobjc_gc.la ;;
++ no)
++ OBJC_BOEHM_GC=''
++ OBJC_BOEHM_GC_INCLUDES=''
++ ;;
++ *)
++ OBJC_BOEHM_GC=libobjc_gc.la
++ OBJC_BOEHM_GC_INCLUDES='-I$(top_srcdir)/../boehm-gc/include -I../boehm-gc/include'
++ ;;
+ esac
+ else
+- OBJC_BOEHM_GC=''
++ OBJC_BOEHM_GC=''; OBJC_BOEHM_GC_INCLUDES=''
+ fi;
+
+
++
+ # -----------
+ # Directories
+ # -----------
+@@ -3675,7 +3682,7 @@
+ case $host in
+ *-*-irix6*)
+ # Find out which ABI we are using.
+- echo '#line 3678 "configure"' > conftest.$ac_ext
++ echo '#line 3685 "configure"' > conftest.$ac_ext
+ if { (eval echo "$as_me:$LINENO: \"$ac_compile\"") >&5
+ (eval $ac_compile) 2>&5
+ ac_status=$?
+@@ -5110,7 +5117,7 @@
+ :
+ else
+ cat > conftest.$ac_ext << EOF
+-#line 5113 "configure"
++#line 5120 "configure"
+ @interface Frob
+ @end
+ @implementation Frob
+@@ -5816,6 +5823,7 @@
+ s,@LIBS@,$LIBS,;t t
+ s,@VERSION@,$VERSION,;t t
+ s,@OBJC_BOEHM_GC@,$OBJC_BOEHM_GC,;t t
++s,@OBJC_BOEHM_GC_INCLUDES@,$OBJC_BOEHM_GC_INCLUDES,;t t
+ s,@toplevel_srcdir@,$toplevel_srcdir,;t t
+ s,@build@,$build,;t t
+ s,@build_cpu@,$build_cpu,;t t
+--- libobjc/configure.ac 2006-03-14 00:51:43.000000000 -0500
++++ libobjc/configure.ac 2006-03-14 00:56:02.000000000 -0500
+@@ -1,6 +1,6 @@
+ # Process this file with autoconf to produce a configure script.
+ # Copyright 1994, 1995, 1996, 1997, 1998, 1999, 2001, 2002, 2003, 2004
+-# Free Software Foundation, Inc.
++# 2005, 2006 Free Software Foundation, Inc.
+ # Originally contributed by Dave Love (d.love@dl.ac.uk).
+ #
+ #This file is part of GCC.
+@@ -72,11 +72,18 @@
+ [ --enable-objc-gc enable the use of Boehm's garbage collector with
+ the GNU Objective-C runtime.],
+ [case $enable_objc_gc in
+- no) OBJC_BOEHM_GC='' ;;
+- *) OBJC_BOEHM_GC=libobjc_gc.la ;;
++ no)
++ OBJC_BOEHM_GC=''
++ OBJC_BOEHM_GC_INCLUDES=''
++ ;;
++ *)
++ OBJC_BOEHM_GC=libobjc_gc.la
++ OBJC_BOEHM_GC_INCLUDES='-I$(top_srcdir)/../boehm-gc/include -I../boehm-gc/include'
++ ;;
+ esac],
+-[OBJC_BOEHM_GC=''])
++[OBJC_BOEHM_GC=''; OBJC_BOEHM_GC_INCLUDES=''])
+ AC_SUBST(OBJC_BOEHM_GC)
++AC_SUBST(OBJC_BOEHM_GC_INCLUDES)
+
+ # -----------
+ # Directories
+--- libobjc/Makefile.in 2006-03-14 00:51:43.000000000 -0500
++++ libobjc/Makefile.in 2006-03-14 00:56:02.000000000 -0500
+@@ -89,13 +89,16 @@
+ LIBTOOL_CLEAN = $(LIBTOOL) --mode=clean
+ #LIBTOOL_UNINSTALL = $(LIBTOOL) --mode=uninstall
+
+-INCLUDES = -I$(srcdir)/objc -I$(srcdir)/$(MULTISRCTOP)../gcc \
+- -I$(srcdir)/$(MULTISRCTOP)../gcc/config -I$(MULTIBUILDTOP)../../gcc \
+- -I$(srcdir)/$(MULTISRCTOP)../include
+-
+ OBJC_GCFLAGS=-DOBJC_WITH_GC=1
+ OBJC_THREAD_FILE=thr-objc
+ OBJC_BOEHM_GC=@OBJC_BOEHM_GC@
++OBJC_BOEHM_GC_INCLUDES=@OBJC_BOEHM_GC_INCLUDES@
++
++INCLUDES = -I$(srcdir)/objc -I$(srcdir)/$(MULTISRCTOP)../gcc \
++ -I$(srcdir)/$(MULTISRCTOP)../gcc/config -I$(MULTIBUILDTOP)../../gcc \
++ -I$(srcdir)/$(MULTISRCTOP)../include \
++ $(OBJC_BOEHM_GC_INCLUDES)
++
+
+ .SUFFIXES:
+ .SUFFIXES: .c .m .lo