aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2017-07-14 12:52:49 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2017-07-14 12:52:58 -0700
commit91002e56bb0391bdc31716dd65b42151d230ff62 (patch)
tree90e42a563c05a95791e175a1a1559bceb1acb8cd /Makefile
parentmodules_load: more filesystems. (diff)
downloadgenkernel-91002e56bb0391bdc31716dd65b42151d230ff62.tar.gz
genkernel-91002e56bb0391bdc31716dd65b42151d230ff62.tar.bz2
genkernel-91002e56bb0391bdc31716dd65b42151d230ff62.zip
Improve release process.
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/Makefile b/Makefile
index e7f08a3d..d18a3f25 100644
--- a/Makefile
+++ b/Makefile
@@ -28,8 +28,12 @@ clean:
rm -f $(EXTRA_DIST)
check-git-repository:
+ifneq ($(UNCLEAN),1)
git diff --quiet || { echo 'STOP, you have uncommitted changes in the working directory' ; false ; }
git diff --cached --quiet || { echo 'STOP, you have uncommitted changes in the index' ; false ; }
+else
+ @true
+endif
dist: verify-doc check-git-repository distclean $(EXTRA_DIST)
mkdir "$(distdir)"