summaryrefslogtreecommitdiff
path: root/eclass
diff options
context:
space:
mode:
authorYuta SATOH <nigoro@gentoo.gr.jp>2013-11-01 01:57:34 +0900
committerYuta SATOH <nigoro@gentoo.gr.jp>2013-11-01 01:57:34 +0900
commit1c3c267d81d0b90263efa3a9b0a07a9075b4c29b (patch)
tree148ab3c941ba994a9786d55ce3b7e0f00f3e480d /eclass
parentsys-freebsd/*-10.9999_p257166: bump 10.0-BETA2 (diff)
downloadgentoo-bsd-1c3c267d81d0b90263efa3a9b0a07a9075b4c29b.tar.gz
gentoo-bsd-1c3c267d81d0b90263efa3a9b0a07a9075b4c29b.tar.bz2
gentoo-bsd-1c3c267d81d0b90263efa3a9b0a07a9075b4c29b.zip
freebsd.eclass: Fixed a problem of numerical comparison in 10.0.
Diffstat (limited to 'eclass')
-rw-r--r--eclass/freebsd.eclass16
1 files changed, 8 insertions, 8 deletions
diff --git a/eclass/freebsd.eclass b/eclass/freebsd.eclass
index 0ce056a..8ad32c8 100644
--- a/eclass/freebsd.eclass
+++ b/eclass/freebsd.eclass
@@ -129,16 +129,15 @@ freebsd_rename_libraries() {
freebsd_src_unpack() {
if [[ ${MY_PV} == *9999* ]]; then
S="${WORKDIR}" subversion_src_unpack
+
+ # When share/mk exists in ${WORKDIR}, it is used on FreeBSD 10.0.
+ # Removed "${WORKDIR}"/share/mk/*.mk, use to force /usr/share/mk.
+ if [[ ${PN} != freebsd-mk-defs ]] ; then
+ [[ -e "${WORKDIR}"/share/mk ]] && rm -rf "${WORKDIR}"/share/mk/*.mk
+ fi
else
unpack ${A}
fi
-
- # When share/mk exists in ${WORKDIR}, it is used on FreeBSD 10.0.
- # I would enable the code until I find a better solution.
- if [[ ${MY_PV} == 9999 ]] && [[ ${PN} != freebsd-mk-defs ]]; then
- [[ -e "${WORKDIR}"/share/mk ]] && rm -rf "${WORKDIR}"/share/mk/*.mk
- fi
-
cd "${S}"
dummy_mk ${REMOVE_SUBDIRS}
@@ -148,7 +147,8 @@ freebsd_src_unpack() {
# Starting from FreeBSD 9.2, its install command supports the -l option and
# they now use it. Emulate it if we are on a system that does not have it.
- if [[ ${RV} > 9.1 ]] && ! has_version '>=sys-freebsd/freebsd-ubin-9.2_beta1' ; then
+ version_compare ${RV} 9.1
+ if [[ $? -eq 3 ]] && ! has_version '>=sys-freebsd/freebsd-ubin-9.2_beta1' ; then
export INSTALL_LINK="ln -f"
export INSTALL_SYMLINK="ln -fs"
fi