summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKerin Millar <kfm@plushkava.net>2023-06-10 06:40:35 +0100
committerKerin Millar <kfm@plushkava.net>2023-06-10 06:40:35 +0100
commit02d2824b4daeedd4084da53ebf3633a8b5508a92 (patch)
tree8f3707f16c9eefc25405e7d8b5dc1dbd61d5dab9 /meson.build
parentmeson.build: Use the TAP protocol for running the tests (diff)
downloadgentoo-functions-02d2824b4daeedd4084da53ebf3633a8b5508a92.tar.gz
gentoo-functions-02d2824b4daeedd4084da53ebf3633a8b5508a92.tar.bz2
gentoo-functions-02d2824b4daeedd4084da53ebf3633a8b5508a92.zip
test-functions: Really fix non-conforming TAP output
The previous "fix" was an experimental patch that was not yet intended for inclusion. This supplemental commit does as little as is necessary to render the test suite properly functional under meson, given that meson.build has been configured to expect the use of the TAP protocol. It also configures meson to be verbose while executing the test suite. As far as I can gather, the TAP support in meson is weak. Subtests do not appear to be supported. For that reason, I have dropped the TAP version from 14 to 13. While meson recognises "# SKIP" as a directive, it does not report the reason that may follow the text. Another issue is that no controlling terminal is present under meson. Therefore, test_update_cursor_coords() is rendered useless, for it will always be skipped. I have left the test in for the time being, in the hope that there may yet be a solution. In any case, this should be enough to render the -9999 ebuild both testable and usable. Signed-off-by: Kerin Millar <kfm@plushkava.net>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build3
1 files changed, 2 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index aa56907..2557168 100644
--- a/meson.build
+++ b/meson.build
@@ -46,6 +46,7 @@ if do_tests
test(
'test-functions', files('test-functions'),
workdir : meson.current_build_dir(),
- protocol : 'tap'
+ protocol : 'tap',
+ verbose : true
)
endif