summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2013-09-11 12:14:16 +0200
committerMichał Górny <mgorny@gentoo.org>2013-09-11 12:15:01 +0200
commit4136dd16f9b0ff6f5864573d74de20a8d62ee07e (patch)
treee6fb1eec92d8d7b594c2c781e3908c9e186da3e8
parentUse 'echo' instead of 'cat <<_EOF_'. Thanks to pacho and grawity. (diff)
downloadgentoo-systemd-integration-4136dd16f9b0ff6f5864573d74de20a8d62ee07e.tar.gz
gentoo-systemd-integration-4136dd16f9b0ff6f5864573d74de20a8d62ee07e.tar.bz2
gentoo-systemd-integration-4136dd16f9b0ff6f5864573d74de20a8d62ee07e.zip
Require systemdsystem{unit,generator}dir. Drop stale unitdir.
-rw-r--r--Makefile.am2
-rw-r--r--configure.ac11
2 files changed, 10 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index 0e81c9f..5099c6d 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,7 +1,7 @@
ACLOCAL_AMFLAGS = -I m4
DISTCHECK_CONFIGURE_FLAGS = \
--with-systemdsystemunitdir=\$${libdir}/systemd/system \
- --with-systemdutildir=\$${libdir}/systemd
+ --with-systemdsystemgeneratordir=\$${libdir}/systemd/system-generators
dist_tmpfiles_DATA = \
tmpfiles.d/gentoo-run.conf
diff --git a/configure.ac b/configure.ac
index 2af3c36..0e03a5e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -5,11 +5,18 @@ AM_INIT_AUTOMAKE([1.6 foreign dist-bzip2 subdir-objects])
AC_PROG_SED
-# https://bitbucket.org/mgorny/systemd-sdk/
+# https://bitbucket.org/mgorny/systemd-m4/
SYSTEMD_MISC
+
SYSTEMD_SYSTEMUNITDIR
+if test -z "$systemdsystemunitdir"; then
+ AC_MSG_ERROR([systemdsystemunitdir must be set])
+fi
+
SYSTEMD_SYSTEMGENERATORDIR
-SYSTEMD_UTILDIR
+if test -z "$systemdsystemgeneratordir"; then
+ AC_MSG_ERROR([systemdsystemgeneratordir must be set])
+fi
AC_CONFIG_FILES([Makefile])
AC_OUTPUT