summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2007-08-13 19:58:32 +0000
committerFabian Groffen <grobian@gentoo.org>2007-08-13 19:58:32 +0000
commit5d068a9b28e2483cbb4f92bd0f833ebe54dc80f7 (patch)
tree16ded36339f9d0c6329669baea3cdecab29e5cab
parentadd gnustep-apps/stepchat (diff)
downloadprefix-5d068a9b28e2483cbb4f92bd0f833ebe54dc80f7.tar.gz
prefix-5d068a9b28e2483cbb4f92bd0f833ebe54dc80f7.tar.bz2
prefix-5d068a9b28e2483cbb4f92bd0f833ebe54dc80f7.zip
add gnustep-apps/etoile ... well almost everything is in prefix now
(Portage 2.2.00.7595-prefix/SVN/Linux 2.6.20-1.2925.fc6 AMD Athlon(tm) 64 X2 Dual Core Processor 3800+) svn path=/prefix-overlay/; revision=295
-rw-r--r--gnustep-apps/etoile/Manifest2
-rw-r--r--gnustep-apps/etoile/etoile-0.2.ebuild77
2 files changed, 79 insertions, 0 deletions
diff --git a/gnustep-apps/etoile/Manifest b/gnustep-apps/etoile/Manifest
new file mode 100644
index 0000000..27fb5cb
--- /dev/null
+++ b/gnustep-apps/etoile/Manifest
@@ -0,0 +1,2 @@
+DIST etoile-0.2.tar.gz 21233211 RMD160 340add5114d6bd2ba9d6da648ec041702a09d565 SHA1 9d384114f5ac317eebcc6b5cda3a0f5898a7c1c7 SHA256 e3a016ceaeb28c02b9a7ac71db51ced38c0dc0fc36c8b539d878b826f988ae0f
+EBUILD etoile-0.2.ebuild 2159 RMD160 02d5c7118a9e1293120e0fbf126f29f772aec3dc SHA1 922520edd5792e9cadf83f7ebae50fd974cb04ae SHA256 424596f6bff3ae57927b24eb28cb50ffd2341dcbaf6a67ae31f7149c5e7d438b
diff --git a/gnustep-apps/etoile/etoile-0.2.ebuild b/gnustep-apps/etoile/etoile-0.2.ebuild
new file mode 100644
index 0000000..f9a14b8
--- /dev/null
+++ b/gnustep-apps/etoile/etoile-0.2.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="prefix"
+
+inherit gnustep-2
+
+S="${WORKDIR}/Etoile-${PV}/Services/Private/System"
+
+DESCRIPTION="Meta-package for the Etoile desktop environment"
+HOMEPAGE="http://www.etoile-project.org"
+SRC_URI="http://download.gna.org/etoile/etoile-${PV}.tar.gz"
+
+LICENSE="as-is"
+KEYWORDS="~x86 ~amd64"
+SLOT="0"
+
+RDEPEND=">=gnustep-apps/addresses-0.4.7
+ ~gnustep-apps/azalea-${PV}
+ ~gnustep-apps/azbackground-${PV}
+ ~gnustep-apps/azdock-${PV}
+ ~gnustep-apps/azswitch-${PV}
+ ~gnustep-apps/calc-${PV}
+ ~gnustep-apps/dictionaryreader-${PV}
+ ~gnustep-apps/etoile-corner-${PV}
+ ~gnustep-apps/etoile-idle-${PV}
+ ~gnustep-apps/etoile-menuserver-${PV}
+ ~gnustep-apps/etoile-system-${PV}
+ ~gnustep-apps/fontmanager-${PV}
+ ~gnustep-apps/grr-${PV}
+ ~gnustep-apps/outerspace-${PV}
+ ~gnustep-apps/sketch-${PV}
+ ~gnustep-apps/stepchat-${PV}
+ ~gnustep-apps/typewriter-${PV}
+ ~gnustep-apps/vindaloo-${PV}
+ ~gnustep-libs/camaelon-${PV}
+ ~gnustep-libs/etoile-behavior-${PV}
+ ~gnustep-libs/etoile-wildmenus-${PV}"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ # Fix path
+ egnustep_env
+ sed -i "s#/usr/local/bin/etoile#${GNUSTEP_SYSTEM_TOOLS}/etoile_system#" \
+ etoile.desktop || die "Fixing desktop file failed"
+}
+
+src_compile() {
+ einfo "Nothing to compile"
+}
+
+src_install() {
+ egnustep_env
+
+ # Install SystemTaskList
+ dodir ${GNUSTEP_SYSTEM_LIBRARY#${EPREFIX}}/Etoile
+ insinto ${GNUSTEP_SYSTEM_LIBRARY#${EPREFIX}}/Etoile
+ doins SystemTaskList.plist
+
+ # Install desktop entry file
+ insinto /usr/share/xsessions
+ doins etoile.desktop
+}
+
+pkg_postinst() {
+ elog "Thanks for trying Etoile ebuilds from the GNUstep overlay"
+ elog "This is still a work in progress. For now,"
+ elog "to enable all Etoile features, you will need to run (as user):"
+ elog "# defaults write NSGlobalDomain GSAppKitUserBundles '("
+ elog "\"/usr/GNUstep/System/Library/Bundles/Camaelon.themeEngine\","
+ elog "\"/usr/GNUstep/System/Library/Bundles/EtoileMenus.bundle",
+ elog "\"/usr/GNUstep/System/Library/Bundles/EtoileBehavior.bundle\")'"
+ elog "This will probably be changed in the near future"
+}