aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@flameeyes.eu>2012-12-01 22:32:01 -0800
committerDiego Elio Pettenò <flameeyes@flameeyes.eu>2012-12-01 22:32:01 -0800
commit1c18250a9dd236f3299e621e0e3597d03c40543e (patch)
tree5b28a777b588d6c4f59e0521fda7ccc8203e7ba9 /Makefile
parentAdd oui.txt and let's all hope that IEEE is brighter than they seem. (diff)
downloadhwids-1c18250a9dd236f3299e621e0e3597d03c40543e.tar.gz
hwids-1c18250a9dd236f3299e621e0e3597d03c40543e.tar.bz2
hwids-1c18250a9dd236f3299e621e0e3597d03c40543e.zip
Update makefile to handle tagging of oui.txt.hwids-20121202.1
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index 58592e5..95b304e 100644
--- a/Makefile
+++ b/Makefile
@@ -12,9 +12,10 @@ endif
fetch:
$(Q)$(HTTPCAT) http://pci-ids.ucw.cz/v2.2/pci.ids.bz2 | bzcat > pci.ids
$(Q)$(HTTPCAT) http://www.linux-usb.org/usb.ids.bz2 | bzcat > usb.ids
+ $(Q)$(HTTPCAT) http://standards.ieee.org/develop/regauth/oui/oui.txt > oui.txt
$(Q)$(STATUS)
-PV ?= $(shell awk '$$2 == "Date:" { gsub("-", "", $$3); print $$3; nextfile }' pci.ids usb.ids | sort | tail -n 1)
+PV ?= $(shell ( awk '$$2 == "Date:" { print $$3; nextfile }' pci.ids usb.ids; git log --format=format:%ci -1 -- oui.txt | cut -d ' ' -f1; ) | sort | tail -n 1 | tr -d -)
P = hwids-$(PV)
tag: