aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2024-05-13 23:38:33 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2024-05-14 01:11:32 +0200
commita7c7530b3edf121abd4eb42cd8b12d9d5013a9b4 (patch)
treea33e85bb8568121ea3bbeed6f8a349d7d5a67a83 /app-cdr
parentkde-apps/umbrello: 24.04.90 version bump (diff)
downloadkde-a7c7530b3edf121abd4eb42cd8b12d9d5013a9b4.tar.gz
kde-a7c7530b3edf121abd4eb42cd8b12d9d5013a9b4.tar.bz2
kde-a7c7530b3edf121abd4eb42cd8b12d9d5013a9b4.zip
app-cdr/dolphin-plugins-mountiso: 24.04.90 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'app-cdr')
-rw-r--r--app-cdr/dolphin-plugins-mountiso/Manifest1
-rw-r--r--app-cdr/dolphin-plugins-mountiso/dolphin-plugins-mountiso-24.04.90.ebuild61
2 files changed, 62 insertions, 0 deletions
diff --git a/app-cdr/dolphin-plugins-mountiso/Manifest b/app-cdr/dolphin-plugins-mountiso/Manifest
new file mode 100644
index 0000000000..f48ed1be4b
--- /dev/null
+++ b/app-cdr/dolphin-plugins-mountiso/Manifest
@@ -0,0 +1 @@
+DIST dolphin-plugins-24.04.90.tar.xz 304688 BLAKE2B 9cb14275badd693abc2dab46f4e9192c63ff0e01ba0f7d5356df14b7c9fdb93c58e6b2fe22e4bd384c7a39457697fc3087093287c357758f86e1d9bb0f1cafc9 SHA512 94bd585ba80304728b228f2a2e623b5f05ecb4a73a80806aa47b4bd6506ec4a7aea52cdeebd3f31de80efe4cd8d2bcaf805de89abd736f87600726593224f5da
diff --git a/app-cdr/dolphin-plugins-mountiso/dolphin-plugins-mountiso-24.04.90.ebuild b/app-cdr/dolphin-plugins-mountiso/dolphin-plugins-mountiso-24.04.90.ebuild
new file mode 100644
index 0000000000..11419012f8
--- /dev/null
+++ b/app-cdr/dolphin-plugins-mountiso/dolphin-plugins-mountiso-24.04.90.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ECM_HANDBOOK="false"
+KDE_ORG_CATEGORY="sdk"
+KDE_ORG_NAME="dolphin-plugins"
+MY_PLUGIN_NAME="mountiso"
+KFMIN=6.0.0
+PVCUT=$(ver_cut 1-3)
+QTMIN=6.6.2
+inherit ecm gear.kde.org
+
+DESCRIPTION="Dolphin plugin for ISO loopback device mounting"
+HOMEPAGE="https://apps.kde.org/dolphin_plugins/"
+
+LICENSE="GPL-2+"
+SLOT="6"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND="
+ >=dev-qt/qtbase-${QTMIN}:6[dbus,gui,widgets]
+ >=kde-apps/dolphin-${PVCUT}:6
+ >=kde-frameworks/kcompletion-${KFMIN}:6
+ >=kde-frameworks/kconfig-${KFMIN}:6
+ >=kde-frameworks/kcoreaddons-${KFMIN}:6
+ >=kde-frameworks/ki18n-${KFMIN}:6
+ >=kde-frameworks/kio-${KFMIN}:6
+ >=kde-frameworks/ktextwidgets-${KFMIN}:6
+ >=kde-frameworks/solid-${KFMIN}:6
+"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ ecm_src_prepare
+ # kxmlgui, qtnetwork only required by dropbox
+ ecm_punt_qt_module Network
+ ecm_punt_kf_module XmlGui
+ # delete non-${PN} translations
+ find po -type f -name "*po" -and -not -name "*${MY_PLUGIN_NAME}plugin" -delete || die
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_${MY_PLUGIN_NAME}=ON
+ -DBUILD_bazaar=OFF
+ -DBUILD_dropbox=OFF
+ -DBUILD_git=OFF
+ -DBUILD_hg=OFF
+ -DBUILD_makefileactions=OFF
+ -DBUILD_svn=OFF
+ )
+ ecm_src_configure
+}
+
+src_install() {
+ ecm_src_install
+ rm "${D}"/usr/share/metainfo/org.kde.dolphin-plugins.metainfo.xml || die
+}