aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-07-07 11:20:22 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2020-07-07 11:20:22 +0200
commit2418bb4dce9eee8714ccb8eb0a9e8d7a3ac5fdd1 (patch)
tree201a7f57664d345397766a11e5692f0039919ad3 /kde-apps/kldap
parentkde-apps/kitinerary: 20.04.3 version bump (diff)
downloadkde-2418bb4dce9eee8714ccb8eb0a9e8d7a3ac5fdd1.tar.gz
kde-2418bb4dce9eee8714ccb8eb0a9e8d7a3ac5fdd1.tar.bz2
kde-2418bb4dce9eee8714ccb8eb0a9e8d7a3ac5fdd1.zip
kde-apps/kldap: 20.04.3 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-apps/kldap')
-rw-r--r--kde-apps/kldap/Manifest1
-rw-r--r--kde-apps/kldap/kldap-20.04.3.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/kde-apps/kldap/Manifest b/kde-apps/kldap/Manifest
new file mode 100644
index 0000000000..7101c07fd6
--- /dev/null
+++ b/kde-apps/kldap/Manifest
@@ -0,0 +1 @@
+DIST kldap-20.04.3.tar.xz 149012 BLAKE2B e94d495dfcf2b41de9174595338004b486d99e1dd286f84de03bdc3977ec77167068fee96a5603b58e2139fa6fe4a71fb8515a419c1e55d57f35bba2a074ab83 SHA512 6ae46a9ca2bc6d44c4ff4ba17d9681e74d20e50307af2a924b323487f368ade746a8d13060b8d2410b6f67a7a8577df2ef413f3987faad5c73eb49d4ac36d303
diff --git a/kde-apps/kldap/kldap-20.04.3.ebuild b/kde-apps/kldap/kldap-20.04.3.ebuild
new file mode 100644
index 0000000000..1399f8fdfd
--- /dev/null
+++ b/kde-apps/kldap/kldap-20.04.3.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+ECM_HANDBOOK="forceoptional"
+ECM_TEST="true"
+KFMIN=5.70.0
+QTMIN=5.14.2
+inherit ecm kde.org
+
+DESCRIPTION="Library for interacting with LDAP servers"
+HOMEPAGE="https://api.kde.org/kdepim/kldap/html/index.html"
+
+LICENSE="GPL-2+"
+SLOT="5"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE=""
+
+DEPEND="
+ dev-libs/cyrus-sasl
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ >=kde-frameworks/ki18n-${KFMIN}:5
+ >=kde-frameworks/kio-${KFMIN}:5
+ >=kde-frameworks/kwidgetsaddons-${KFMIN}:5
+ net-nds/openldap
+"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ ecm_src_prepare
+
+ if ! use handbook ; then
+ sed -e "/add_subdirectory(doc)/I s/^/#DONOTCOMPILE /" \
+ -i kioslave/CMakeLists.txt || die "failed to comment add_subdirectory(doc)"
+ fi
+}